Bug 115405 - Failure to launch Libreoffice 6 after installation
Summary: Failure to launch Libreoffice 6 after installation
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-02 15:49 UTC by Surya Sunder Dey
Modified: 2018-04-20 09:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Just a JPG Screenshot (44.84 KB, image/jpeg)
2018-02-02 15:51 UTC, Surya Sunder Dey
Details
As instructed, this is the VC install log. (15.45 KB, text/plain)
2018-04-10 05:29 UTC, Surya Sunder Dey
Details
Continuation of the log. (178.18 KB, text/plain)
2018-04-10 05:30 UTC, Surya Sunder Dey
Details
Concluding part of the log (190.66 KB, text/plain)
2018-04-10 05:30 UTC, Surya Sunder Dey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Surya Sunder Dey 2018-02-02 15:49:06 UTC
Description:
When I double clicked icon on the desktop after installing LibreOffice 6 from the MSI, I was shown an error message that said "The program can't start because api-ms-win-core-synch-l1-2-0.dll is missing from your computer. Try reinstalling the program to fix this problem." So, I tried to reinstall the program and this time tried the "REPAIR" option. But the problem persists. What am I doing wrong?

Steps to Reproduce:
1.Double Click on the icon on the desktop
2. There is the error message on your desktop
3.

Actual Results:  
An error message was shown that said "The program can't start because api-ms-win-core-synch-|1-2-0.dll is missing from your computer. Try reinstalling the program to fix this problem.

Expected Results:
The Libreoffice should have started.


Reproducible: Always


User Profile Reset: No



Additional Info:
The OS is Windows 7. Libreoffice 5.4 was already installed when Libreoffice 6 was installed. Actually LO 6 setup overwrote the components onto LO 5.4. I earlier saw this problem with LO 5.0 which was rectified in the latter releases.

Please


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36 OPR/50.0.2762.67
Comment 1 Surya Sunder Dey 2018-02-02 15:51:22 UTC
Created attachment 139532 [details]
Just a JPG Screenshot
Comment 2 Timur 2018-02-02 15:52:04 UTC Comment hidden (obsolete)
Comment 3 Aron Budea 2018-02-02 16:12:16 UTC
Looks a bit similar to bug 108580.
Comment 4 Mike Kaganski 2018-02-02 16:34:50 UTC
When you first installed version 6, did it offer you to install VS Redist after main installation had finished? (It might had asked you for admin permission, if you have UAC enabled).
Comment 5 Surya Sunder Dey 2018-02-03 16:13:57 UTC
(In reply to Mike Kaganski from comment #4)
> When you first installed version 6, did it offer you to install VS Redist
> after main installation had finished? (It might had asked you for admin
> permission, if you have UAC enabled).

It did install VS Redist on its own, without bothering to ask. And since it's LO we're dealing with I assumed whatever setup is doing is doing for the best and didn't cancel that installation. When the installed program failed to start with the aforesaid error message I uninstalled it, registry and all and then uninstalled the VS Redist so that no corrupted leftover remains. Then I installed it again from the MSI that I have downloaded along with the VS Redist, which I believe is bundled. Even then the error persists.
Comment 6 Robby 2018-02-06 09:33:08 UTC
I've got the same problem. I've tried the X86 and the 64 version. Also installed the missing DLL from a third party. The problem remained. Now deinstalled LO 6.0 and reinstalled version 5..
Comment 7 Surya Sunder Dey 2018-04-09 09:31:57 UTC
The problem persists even in LO 6.0.3. The OS is Win7 x64. This time the system is asking for a different DLL file.
Comment 8 Mike Kaganski 2018-04-09 09:34:00 UTC
Please mention the service pack level of used OS.
Comment 9 Surya Sunder Dey 2018-04-09 14:50:26 UTC
It is WIN 7 X64, SP-1
Comment 10 Mike Kaganski 2018-04-09 17:17:15 UTC
(In reply to Surya Sunder Dey from comment #9)

It's unclear what happens in your case. I suspected that you are using Win7 without SP1, which is required to the redist to install (and which is why SP1 is the minimal supported version, as mentioned at https://www.libreoffice.org/get-help/system-requirements/). But as you say that SP1 is installed, this is not the case here.

I would be glad to understand what's wrong here to try and fix this. Could you please uninstall vc redist  from your system, and then run the standalone vc redist install from https://www.microsoft.com/en-us/download/details.aspx?id=53840, with command-line switch to enable logging, like

> vc_redist.x64.exe /log c:\redist_log.txt

and then attach the generated log here?
Comment 11 Surya Sunder Dey 2018-04-10 05:09:35 UTC
It _was_ x86 when I tried to install LO 6.0.0. But since then I have upgraded my OS with x64 and SP1, and then I tried to install LO 6.0.3. which has been published later on. But like I said, the problem persists. Perhaps this is a different problem altogether, though file LO is asking for is still a DLL, but it is a different DLL. I have reverted back to the LO 5x series, but I am hoping a solution would emerge.
Comment 12 Surya Sunder Dey 2018-04-10 05:29:21 UTC
Created attachment 141244 [details]
As instructed, this is the VC install log.
Comment 13 Surya Sunder Dey 2018-04-10 05:30:12 UTC
Created attachment 141245 [details]
Continuation of the log.
Comment 14 Surya Sunder Dey 2018-04-10 05:30:57 UTC
Created attachment 141246 [details]
Concluding part of the log
Comment 15 Surya Sunder Dey 2018-04-10 05:34:48 UTC
Like you told me to do, here are the install logs. I deeply grateful to you for taking time to look into this problem. With regard to LO, I have always prided myself to be an early adapter. That comeuppance was busted in case of 5x. When I had to revert back to the 4x version that I was using. But I could use the 5x series since 5.4.x. I hope that will be case now too. :-)
Comment 16 Mike Kaganski 2018-04-10 08:04:28 UTC
(In reply to Surya Sunder Dey from comment #15)

The logs you provided tell that the redist installer detects the presence of Universal CRT (and various api-*.dlls are part of the Universal CRT (ucrt)), and doesn't try to install it:

> [0898:13B8][2018-04-10T10:49:17]i100: Detect begin, 10 packages
> [0898:13B8][2018-04-10T10:49:17]i000: Setting version variable 'windows_uCRT_DetectKey' to value '10.0.16299.15'
> [0898:13B8][2018-04-10T10:49:17]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 1
> ...
> [0898:13B8][2018-04-10T10:49:19]i201: Planned package: Windows7_MSU_x64, state: Present, default requested: Present, ba requested: Present, execute: None, rollback: None, cache: No, uncache: No, dependency: None

The detection consists of finding the file "ucrtbase.dll" in %windir%\System32, and getting its version. As shown above, the present version is very high (10.0.16299.15), much higher than that of the bundled with LO (we use the redist from the link given in comment 10, and it contains "Update for Universal C Runtime in Windows" (KB2999226) [1] with ucrtbase version 10.0.10240.16390). I know of the other update (KB3118401 [2]), but it also contains a lower version: 10.0.10586.9.

So, this must mean that you system has the updated ucrt, but it is broken for some reason, missing some components. This must have happened on the update; I suppose it was Windows Update that has updated *and broke* the component. Why I think so? Well: if the component was broken before the update, then proper update would repair it. So it must be the last operation on the component that was faulty. And since the version is higher than bundled with LO, it must mean that the component was either pre-installed before LO, or had been updated after.

I don't know the KB article of the update that updates ucrt on Win7 to your version (I have created a VM with Win7x64 and am updating it ATM to find out), but my guess is that you should uninstall the update and reinstall it using command like

> wusa /uninstall /kb:2999226

and then reinstalling the redist.

[1] https://support.microsoft.com/en-us/help/2999226
[2] https://support.microsoft.com/en-us/help/3118401
Comment 17 Mike Kaganski 2018-04-11 11:50:45 UTC
Hmm, the fully updated Win7x64 still has ucrtbase.dll at version 10.0.10586.1171, unlike your case. So my next guess would be either manual copy from some external source, or some other app installing ucrt wrongly (maybe copying DLLs from Win10 or something).

Possibly it could help if you rename your ucrtbase.dll in Windows\System32 to something like ucrtbase.dll.bak, and then try installing the redist again; or maybe download the ucrt directly from https://www.microsoft.com/en-us/download/details.aspx?id=48234, and install it.
Comment 18 Mike Kaganski 2018-04-11 11:57:17 UTC
(In reply to Mike Kaganski from comment #17)
> So my next guess would be either manual copy from some external source,

Clarification:
I meant, the manual copy performed by user was the reason for the problem; I didn't mean that you should copy the file manually to solve the problem.
Comment 19 Surya Sunder Dey 2018-04-17 06:27:08 UTC
Yaay!!! It works! I mean reference to Comment 17. I was a little bit apprehensive to mess around with my Windows installation. But, finally . . .
Comment 20 Mike Kaganski 2018-04-17 06:32:28 UTC
(In reply to Surya Sunder Dey from comment #19)

Great you solved it!
Since it apparently was some third-party application that installed parts of ucrt in utterly wrong way, I'm closing this as NOTOURBUG. I would be most thankful if you post here if you later find out which application behaves that way.

Thank you for the report, and for your efforts to make LibreOffice better!
Comment 21 Surya Sunder Dey 2018-04-20 09:16:49 UTC
I didn't do it. Had YOU not guided me to the UCRT package, I'd have been fumbling around VC redists all the time. Maybe I'd have given up hope and stayed with 5.4. 

Please accept my heartfelt gratitude. Nothing that I can say at this point would fully express how grateful I feel.

I hope you guys continue to touch many more lives like mine.

Best of luck from India.