Bug 119910 - Trying to install. Message states api-ms-win-crt-string-l1-1-0.dll is missing
Summary: Trying to install. Message states api-ms-win-crt-string-l1-1-0.dll is missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.2.0 target:6.1.3
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-16 20:44 UTC by jamison_moffitt72
Modified: 2019-01-14 18:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jamison_moffitt72 2018-09-16 20:44:01 UTC
Description:
Trying to install.  Message states api-ms-win-crt-string-l1-1-0.dll is missing.  Version is 6.1

Actual Results:
install issue

Expected Results:
install issue


Reproducible: Always


User Profile Reset: No



Additional Info:
install properly
Comment 1 Julien Nabet 2018-09-17 09:13:59 UTC
- What Windows version do you use?
- Which LO version do you try to install 6.1 as you quote it or 6.0.1.1 as you put in version Field?

I think https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows may help.

Waiting for your feedback.
Comment 2 Timur 2018-09-17 15:39:05 UTC
I guess Bug 108580.Please read and comment there.

*** This bug has been marked as a duplicate of bug 108580 ***
Comment 3 Mike Kaganski 2018-09-17 17:26:28 UTC
This is confusing - as mentioned in comment 1. And it's possible that it is a dupe of bug 108580 (as per comment 2). But another possibility is - again - broken *existing* UCRT on you system that existed prior to LibreOffice installation. I suspect this because you mention api-ms-win-crt-string-l1-1-0.dll (note that "string" there); and when UCRT is totally missing on a system, we get api-ms-win-crt-runtime-l1-1-0.dll missing (note that "runtime"), which is used earlier than api-ms-win-crt-string-l1-1-0.dll. So - you likely have *some* UCRT libraries on your system that were installed by some other application in a wrong manner; our setup detected the key UCRT library presence, and didn't install the UCRT. Then it failed on accessing the missing parts.

What is your OS? Could you uninstall LibreOffice, and reinstall it with verbose logging - using command like

> msiexec /i path\to\libreoffice.msi /l*vx c:\libreoffice-install.log

and attach the resulting c:\libreoffice-install.log (packed) here?

I start to think that we should possibly try to install UCRT even in cases when it's present (in "restore" mode), because of so many apps trying to cheat - so that we cannot rely on the library being present...
Comment 4 Commit Notification 2018-09-20 07:17:10 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1882827320ed760de82211cf690b686f8d34ff74

tdf#115405, tdf#119910: don't check if UCRT is already installed

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Mike Kaganski 2018-09-20 07:20:38 UTC
Well - I decided to use this bug for the change mentioned in the commit message above. I want to delay backporting to 6-1 branch for one minor release, to allow some basic testing of daily installer builds on different systems. I'm pretty sure the change should be safe, but I'm always pretty sure I do the right things, and stupid universe just doesn't want to behave correctly :-)
Comment 6 Mike Kaganski 2018-10-04 10:41:27 UTC
Thanks to a person from IRC, I discovered that at least Avast Antivirus has this behavior to install incomplete UCRT to System32 on unsupported systems (e.g., to Win8.1 without April 2014 update rollup), without proper registration and all. Good job Avast!

My request there: https://forum.avast.com/index.php?topic=222347.0
Comment 7 Commit Notification 2018-10-09 12:04:29 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa78a46a3063330f3c6b08fb01952790b81734e4&h=libreoffice-6-1

tdf#115405, tdf#119910: don't check if UCRT is already installed

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Justin Jack 2018-11-18 12:16:46 UTC Comment hidden (spam)