Bug 115572 - table format gets reset by deleting a row
Summary: table format gets reset by deleting a row
Status: RESOLVED DUPLICATE of bug 115573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-09 08:29 UTC by Michael K.
Modified: 2018-03-19 10:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bug demonstration (135.12 KB, image/gif)
2018-02-09 08:43 UTC, Michael K.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael K. 2018-02-09 08:29:57 UTC
Description:
I created a table and gave it a different format: font type, size ('IBM Plex Mono Medium', 10) and table alignment (centered).
When I erase a complete row or a column those changes are reset.
Can't bring it back with the undo function.

Steps to Reproduce:
1.create table
2.format (different font, size, alignment)
3.delete row or column

Actual Results:  
format changes are reset

Expected Results:
just delete the row/column without changing the format


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Michael K. 2018-02-09 08:43:23 UTC
Created attachment 139718 [details]
bug demonstration
Comment 2 raal 2018-02-09 13:32:49 UTC
This seems to have begun at the below commit.
Adding Cc: to Jim Raykowski; Could you possibly take a look at this one? Thanks

6e98aaf28c164b2d42f69bd016443467ae6a6411 is the first bad commit
commit 6e98aaf28c164b2d42f69bd016443467ae6a6411
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Dec 27 06:49:24 2017 -0800

    source sha:203b913155812706e9be14c5fe2b8f543cc4fdc7

	author	Jim Raykowski <raykowj@gmail.com>	2017-10-31 15:48:07 -0800
committer	Yousuf Philips <philipz85@hotmail.com>	2017-12-27 15:27:50 +0100
commit	203b913155812706e9be14c5fe2b8f543cc4fdc7 (patch)
tree	e2233e80cbc67d0bf834d4eb716ff935cebe6d08
parent	023949fac0043408ac1b86dc67732666d041875e (diff)
tdf#107555 Apply 'Default Style' table style to newly inserted tables
Comment 3 Telesto 2018-02-09 22:14:56 UTC

*** This bug has been marked as a duplicate of bug 115573 ***
Comment 4 Jim Raykowski 2018-02-10 22:34:49 UTC
Hi All,

It seems removing the following line of code fixes this. 

https://opengrok.libreoffice.org/xref/core/sw/source/core/docnode/ndtbl.cxx#2135
Comment 5 Commit Notification 2018-03-18 10:04:59 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b0cfc9f5b82a11897446cd81f04a0653cc2a1d7

uitest for bug tdf#115572

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.