Bug 115683 - When CSV file importing to calc, if LibreOffice already open, text import dialog box open behind a grey window.
Summary: When CSV file importing to calc, if LibreOffice already open, text import dia...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All Mac OS X (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.1.0 target:6.0.4
Keywords:
: 116512 (view as bug list)
Depends on:
Blocks: CSV-Import
  Show dependency treegraph
 
Reported: 2018-02-13 11:31 UTC by nurcantur
Modified: 2018-05-17 06:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Wrong window order on LO Calc 6.0 opening CSV file (50.41 KB, image/jpeg)
2018-03-20 16:33 UTC, Julehti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nurcantur 2018-02-13 11:31:26 UTC
Description:
When CSV file importing to calc, if LibreOffice already open, text import dialog box open behind a grey window. 

if LİbreOffice were not opened and the user just opened up a CSV file with libre, text importer dialog box appears on top and user can use this window. 

However if the libreOffice already open, the user wants to import CSV file then this problem occurs. Because of the grey window, user can't see dialog box and thinks that there is a problem about importing CSV.  

Steps to Reproduce:
1.Open LibreOffice
2.Open a calc document
3.Just drag and drop a CSV file on calc document

Actual Results:  
On top, there is a finder window 
Behind there is a blank grey window
Behind the grey window, there is a text importer dialog box.



Expected Results:
text importer dialog box should be on top.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Version: 6.0.0.1
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: tr-TR (en_TR.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36
Comment 1 Alex Thurgood 2018-02-13 13:36:26 UTC
This should have been fixed in the upcoming 6.1.0 release.

*** This bug has been marked as a duplicate of bug 32935 ***
Comment 2 Mike Kaganski 2018-02-13 13:59:39 UTC
... and even in already-released 6.0.1.1 - please test if it fixes the issue for you (I'd be very grateful for feedback, because I couldn't test this on OSes I don't have access to).
Comment 3 nurcantur 2018-02-13 16:04:14 UTC
I tested the same issue again on LİbreOffice version:6.0.1.1. this version still has the same bug :( version details are below. 

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: tr-TR (en_TR.UTF-8); Calc: group


Mike; if you find out the way to solve this issue, I  can test the issue on OS, gladly.
Comment 4 Mike Kaganski 2018-02-13 17:26:36 UTC
Sigh... no, I don't feel like I could come up with something clearly OS-specific for macOS (which I don't have).

Probably better to confirm this as macOS-specific, and track separately?
Also could you please create a kind of screencast to show the problem to those who would try to reproduce and fix. Thank you!
Comment 5 V Stuart Foote 2018-02-14 01:44:15 UTC
Hey Chris, care to flex your new macOS skills?
Comment 6 Alex Thurgood 2018-02-14 10:31:06 UTC
This is no repro for me with:

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group


1) Strted LO
2) Opened new Calc document.
3) Dragged CSV file from Finder onto Calc document.
4) Dialog opens on top with focus.
Comment 7 Alex Thurgood 2018-02-14 10:31:46 UTC
@nurcantur : specifc to OSX 10.12 ?
Comment 8 Alex Thurgood 2018-02-14 10:36:30 UTC
Tested on 2 separate macOS 10.13.3 machines - no repro.
Comment 9 Mike Kaganski 2018-02-14 10:58:20 UTC
(In reply to Alex Thurgood from comment #6)
> 1) Strted LO
> 2) Opened new Calc document.

Just to make sure: please edit the new spreadsheet: this will allow for the grey window

> 3) Dragged CSV file from Finder onto Calc document.
> 4) Dialog opens on top with focus.
Comment 10 Alex Thurgood 2018-02-14 15:25:14 UTC
(In reply to Mike Kaganski from comment #9)
> (In reply to Alex Thurgood from comment #6)
> > 1) Strted LO
> > 2) Opened new Calc document.
> 
> Just to make sure: please edit the new spreadsheet: this will allow for the
> grey window


Ah, the crucial missing step. Now I can reproduce with :

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
Threads CPU : 8; OS : Mac OS X 10.13.3; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 11 Telesto 2018-02-15 20:50:42 UTC
Is this also reproducible with 4.4.7.2? It could be bug 115315 (didn't check)
Comment 12 Julehti 2018-03-20 16:10:33 UTC
This bug found on LibreOffice Calc 6.0.1 on macOS is still relevant non LibreOffice Calc 6.0.2.1: when you have an open LO Calc file and you open a CSV file, the CSV input window will be behind the front window.
Comment 13 Julehti 2018-03-20 16:33:14 UTC
Created attachment 140750 [details]
Wrong window order on LO Calc 6.0 opening CSV file

Wrong window order on LO Calc 6.0 opening CSV file
Comment 14 Julehti 2018-03-20 16:35:34 UTC
Sorry, my comment should have been this: This bug found on LibreOffice Calc 6.0.1 on macOS is still relevant on LibreOffice Calc 6.0.2.1

- I tested LO Calc 6.0.1 and then 6.0.2.1 both under macOS 10.11 and macOS 10.13. This bug was no on LO Calc 5.x or older versions.

Here is attached a screen dumb. I moved the grey window little bit, so the CSV input dialog window can be seen.
Comment 15 Alex Thurgood 2018-03-21 10:07:41 UTC
*** Bug 116512 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2018-03-21 10:11:46 UTC
@Caolan : is this another ocurrence of the parent window / modal dialog dependency?
Comment 17 Caolán McNamara 2018-03-21 13:08:34 UTC
yeah, same class of problem.
Comment 18 Commit Notification 2018-03-21 14:49:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=754f6e2fe0d329e12e9e083d4fccc4086d9b4d04

tdf#115683 there are other cases of dialogs before document load

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Caolán McNamara 2018-03-21 14:56:18 UTC
backport to 6-0 in gerrit
Comment 20 Commit Notification 2018-04-05 14:13:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d604d977a748e982c3e71f09daf08ed5af778ed0&h=libreoffice-6-0

tdf#114648 tdf#115683 don't show new document until dialogs are gone

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Dave Miller 2018-05-16 03:08:34 UTC
I've been running into this, so as instructed in comment 20 I was going to download the nightly and test it, but there are no Mac builds in https://dev-builds.libreoffice.org/daily/libreoffice-6-0/
Comment 22 Mike Kaganski 2018-05-16 05:39:56 UTC
(In reply to Dave Miller from comment #21)
> ... as instructed in comment 20 I was going to
> download the nightly and test it, but there are no Mac builds in
> https://dev-builds.libreoffice.org/daily/libreoffice-6-0/

... but there are in https://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/
Comment 23 nurcantur 2018-05-17 06:30:31 UTC
I tested this issue with the daily build 6.1.0.0.alpha1+ (version details written below). 

This problem is totally solved :) In addition to that, the other window order problems on macOS are also solved.  Thank you Caolán McNamara. 

-------------------
Version: 6.1.0.0.alpha1+
Build ID: b2b1d0a4c4ffcba0e32e5909a61de43eeaf98c25
CPU threads: 4; OS: Mac OS X 10.13.4; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-05-15_23:37:15
Locale: en-TR (en_TR.UTF-8); Calc: group