Bug 116512 - FILEOPEN: Text Import dialogue box hides behind empty spreadsheet when importing CSV
Summary: FILEOPEN: Text Import dialogue box hides behind empty spreadsheet when import...
Status: RESOLVED DUPLICATE of bug 115683
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-20 01:19 UTC by tagishsimon
Modified: 2018-03-21 10:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The blank spreadsheet seen when invoking a CSV open fro finder (634.94 KB, image/png)
2018-03-20 01:22 UTC, tagishsimon
Details
The text Import dialogue box hiding behind he blank spreadsheet (763.63 KB, image/png)
2018-03-20 01:23 UTC, tagishsimon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tagishsimon 2018-03-20 01:19:14 UTC
Description:
Double-clicking on a CSV file in Finder (on a mac) causes OO Calc to open the file (presuming appropriate file associations) ... OO Calc will put up a Text Import dialogue box allowing the user to specify character set, seperators, etc.

When double-clicking on a CSV file in Finder, with OO Calc already open and with an existing spreadsheet window open & being displayed, OO puts up a blank spreadsheet window, and puts up the Text Import dialogue box  ... but hides the Text Import dialogue box behind the blank spreadsheet window. The unsuspecting user can see the blank spreadsheet window, but may have no clue that there's a Text Import dialogue box open.

Note that when clicking on a CSV in finder:
- with OO closed, the Text Import dialogue box is foregrounded
- with OO open, but no files open, the Text Import dialogue box is foregrounded
- with OO open, and with a calc file minimised, the Text Import dialogue box is foregrounded
- with OO open, and with a calc file being displayed, the Text Import dialogue box is BACKGROUNDED
 

The Text Import dialogue box

Steps to Reproduce:
1. Open openoffice
2. Create a spreadsheet, and leave the spreadsheet window displayed (i.e. do not minimise it)
3. Go to Finder
4. Double-click on a .CSV file


Actual Results:  
The Text Import dialogue box is hidden behind a blank spreadsheet

Expected Results:
The Text Import dialogue box is foregrounded in front of a blank spreadsheet, or, the Text Import dialogue box alone is displayed ... the user should see the dialogue box which requires her attention; the dialogue box should not be hidden behind a window


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 tagishsimon 2018-03-20 01:22:56 UTC
Created attachment 140730 [details]
The blank spreadsheet seen when invoking a CSV open fro finder
Comment 2 tagishsimon 2018-03-20 01:23:48 UTC
Created attachment 140731 [details]
The text Import dialogue box hiding behind he blank spreadsheet

Note that I moved the blank spreadsheet so we could see the dialogue box
Comment 3 tagishsimon 2018-03-20 01:26:03 UTC
Finally, note that when presented with the Text Import dialogue box hidden behind the blank spreadsheet window, Cmd-TABbing away fro and then back to OO causes the blank spreadsheet window to disappear, and leave the Text Import dialogue box visible.

So my suspicion here is that there's an unneeded blank spreadsheet window being created at an inappropriate point in the proceedings
Comment 4 tagishsimon 2018-03-20 02:38:11 UTC
One more issue. For the error case described above (invoke CSV from finder when there is a calc spreadsheet being displayed), once the user has found and actioned the Text Import dialogue box, such that the CSV loads into a window, the CSV window is hidden.

Steps to Reproduce:
1. Open openoffice
2. Create a spreadsheet, and leave the spreadsheet window displayed (i.e. do not minimise it)
3. Go to Finder
4. Double-click on a .CSV file
5. Find the obscured Text Import dialogue box
6. OKay the Text Import dialogue box

Expected: the CSV spreadsheet window is displayed
Actual: the CSV spreadsheet window is minimised. The user has no clue that it has been created.
Comment 5 tagishsimon 2018-03-20 02:41:11 UTC
Oops ... re: my comment 4 ... I'm minimising the blank spreadheet to see the text Import dialogue box ... the CSV opens minimised because of this. If I move the blank spreadsheet instead of minimising it, then the CSV loads into the previously blank spreadsheet, albeit the CSV spreadsheet window displays behind the pre-existing open calc spreadsheet, rathe than in the foreground.
Comment 6 Alex Thurgood 2018-03-21 10:07:41 UTC

*** This bug has been marked as a duplicate of bug 115683 ***