Download it now!
Bug 115722 - Images get lost when a document is exported to epub
Summary: Images get lost when a document is exported to epub
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.1.0
Keywords:
: 116217 116776 (view as bug list)
Depends on:
Blocks: EPUB-Export
  Show dependency treegraph
 
Reported: 2018-02-14 16:02 UTC by dsestero@gmail.com
Modified: 2018-04-03 16:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dsestero@gmail.com 2018-02-14 16:02:16 UTC
Description:
When exporting a document to the EPUB format (both version 2 and 3) the images do not appear exported (looking at the e-book with Calibre e-book Viewer) and they are not present in the produced e-book (inspecting it with Calibre e-book editor).
I'm on Ubuntu 17.10 with Gnome shell and installed LibreOffice 6 from the fresh PPA repo.

Steps to Reproduce:
1. Download and open the new LibreOffice 5.4 Writing Guide from https://documentation.libreoffice.org/en/english-documentation/writer/
2. Export to EPUB (2 or 3)
3. Open the e-book with a reader like Calibre e-book viewer

Actual Results:  
No images in the resulting e-book

Expected Results:
Should see the images in the correct position


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Versione: 6.0.1.1
Build ID: 1:6.0.1~rc1-0ubuntu0.17.10.1~lo1
Thread CPU: 4; SO: Linux 4.13; Resa interfaccia: predefinito; VCL: gtk3; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 raal 2018-02-14 22:04:27 UTC
I can not confirm with Version: 6.1.0.0.alpha0+
Build ID: a097077e1f3d433ab7cbc84c408c96f9adce1534
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

tested epub 3

Seems to be fixed with dev version. Please could you test it with
dev version?  You can download it here:
http://dev-builds.libreoffice.org/daily/master/
Comment 2 Telesto 2018-02-14 22:06:23 UTC
In addition to comment 1: EPUB support is still work in progress. LibO 6.0 only handles as-char images. See also: https://vmiklos.hu/blog/epub3-improvements.html
Comment 3 dsestero@gmail.com 2018-02-15 09:10:10 UTC
I tried the development version:

Version: 6.1.0.0.alpha0+
Build ID: 09fcdbd5e0ae35fb7db8c8784329035edd82573b
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: it-IT (it_IT.UTF-8); Calc: group

and, as raal said the images get correctly exported.

So feel free to close the bug or help me to mark it as 'would be resolved in the next release' and... please keep up with the good work :-)
Comment 4 Miklos Vajna 2018-02-15 09:37:06 UTC
Thanks. And sorry, no plan to backport this to 6.0, master has loads of changes for EPUB, hard to cherry-pick just this one.
Comment 5 Aron Budea 2018-03-06 02:26:32 UTC
*** Bug 116217 has been marked as a duplicate of this bug. ***
Comment 6 raal 2018-04-03 16:48:26 UTC
*** Bug 116776 has been marked as a duplicate of this bug. ***