Download it now!
Bug 115739 - LibreOffice Writer crashes when trying to save an untitled document
Summary: LibreOffice Writer crashes when trying to save an untitled document
Status: RESOLVED DUPLICATE of bug 115971
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-15 09:23 UTC by kubuntu-fan
Modified: 2018-02-24 10:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kubuntu-fan 2018-02-15 09:23:56 UTC
Description:
LibreOffice Writer starts with an empty document calles "untitled". When I try to save it ("Save As..." or "Strg+S"), Writer crashes with the output in the console:

Couldn't open /usr/share/kde4/config/kdebug.areas
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6400c30
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6400c30
Couldn't open /usr/share/kde4/config/kdebug.areas

Steps to Reproduce:
1. Start from the console: :~$ /usr/bin/libreoffice --writer
2. Try to "Save as..."

Actual Results:  
Couldn't open /usr/share/kde4/config/kdebug.areas
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6400c30
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6400c30
Couldn't open /usr/share/kde4/config/kdebug.areas

Expected Results:
It should have opened the "Save-As-dialogue".


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xisco Faulí 2018-02-15 10:27:00 UTC Comment hidden (obsolete)
Comment 2 kubuntu-fan 2018-02-15 10:37:36 UTC
Also crashes with an new/reset Libreoffice profile.
Comment 3 Xisco Faulí 2018-02-15 10:51:38 UTC
Does it crash if you call LibreOffice from the commandline like: 'SAL_USE_VCLPLUGIN=gtk3 soffice' ?
Comment 4 kubuntu-fan 2018-02-15 11:03:36 UTC
Yes, it does!

It says:

:~$ SAL_USE_VCLPLUGIN=gtk3 soffice
Couldn't open /usr/share/kde4/config/kdebug.areas
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6800db1
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6800db1
Couldn't open /usr/share/kde4/config/kdebug.areas
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x660018b
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x660018b
Comment 5 am_dxer 2018-02-20 20:55:12 UTC Comment hidden (obsolete)
Comment 6 am_dxer 2018-02-20 20:59:01 UTC Comment hidden (obsolete)
Comment 7 meolar 2018-02-22 18:53:38 UTC
I noticed the same problem with both Writer and Calc (LibreOffice version 5.4.5.1) on Kubuntu 17.10.

It also occurs with doing "Save As" or trying to Open a file from the menu.  

Opening a previously saved file from Dolphin works... and subsequent re-saving works.
Comment 8 clalamity 2018-02-23 06:55:00 UTC
Using Kubuntu 17.10. Sometime between last use on 17 Feb and attempted use on 22 Feb, all attempts to save a new file resulted in a crash and recovery. All subsequent attempts to save again resulted in crash and recovery.

From the command line:
$ libreoffice
Couldn't open /usr/share/kde4/config/kdebug.areas (startup)

Upon starting a new file and attempting to save it, Writer crashes with a recovery window. All subsequent attempts to save a file result in the same action.

Upon shutdown the command line startup note is reiterated:
Couldn't open /usr/share/kde4/config/kdebug.areas

/usr/share/kde4/config/kdebug.areas is owned by root:root with the permissions of 644.
Comment 9 clalamity 2018-02-24 04:23:19 UTC
When I start an instance of Writer and attempt to open a document, it immediately crashes and goes through an empty recovery process (because there was nothing yet saved that can be recovered). But if I load an existing document from the CLI ($libreoffice myfile.odt), I can load the document, edit it, and save it.

If I create an empty ODT file using 'touch' and load it from the command line, I get the following:

$libreoffice test.odt
Couldn't open /usr/share/kde4/config/kdebug.areas
:1: parser error : Extra content at the end of the document
^
:1: parser error : Extra content at the end of the document
^
:1: parser error : Extra content at the end of the document


Then it loads the empty document. I can edit it and save it, but I have to choose between saving it as a text file and saving it as an ODF file. Choosing the Text option loses any formatting that I apply to the document. If I attempt a Save As, Writer crashes again.
Comment 10 Xisco Faulí 2018-02-24 10:33:09 UTC
Let's close this one as a dupe of bug 115971.

*** This bug has been marked as a duplicate of bug 115971 ***