Bug 115866 - ErrCode() Warning strings not translated and "Warning" word missing
Summary: ErrCode() Warning strings not translated and "Warning" word missing
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.6 target:5.4.7
Keywords: bibisected, regression
Depends on:
Blocks: Dialog-Msgbox Not-Localizable
  Show dependency treegraph
 
Reported: 2018-02-19 21:15 UTC by Laurent BP
Modified: 2018-04-14 12:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Dialog in French UI in LibO 5.4.5.1 (21.33 KB, application/pdf)
2018-02-19 21:30 UTC, Laurent BP
Details
Warning word is missing, only 1st sentence is translated when too many rows for XLS format (14.20 KB, image/png)
2018-02-22 21:42 UTC, Laurent BP
Details
Another not translated message: Split cells in Writer (91.29 KB, image/png)
2018-02-22 22:09 UTC, Laurent BP
Details
Screen shot of dialog mixing French and English text (14.92 KB, image/png)
2018-03-06 12:42 UTC, Laurent BP
Details
Screen shot of dialog mixing German and English text (11.82 KB, image/png)
2018-03-06 15:13 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2018-02-19 21:15:49 UTC
Description: During CSV export, dialog warning that "only the active sheet was saved" is corrupted: first word "Warning" is missing, and second sentence is not translated.

Steps to reproduce:
1. Create a new file with at least 2 sheets
2. File > Save, select format CSV
3. OK to validate options

Actual behavior:
Text in dialog is corrupted:
/!\" saving the document ...:
Only the active sheet was saved."
/!\ is (correctly) the warning picto
... is (correctly) replaced by the name of the file. First sentence is (correctly) in UI language. Second sentence is in English whatever UI language.

Expected behavior:
With previous branch (5.3.7 for instance) and next branch (6.0.1) the text was/is:
/!\"Warning saving the document ...:
Only the active sheet was saved."
Both sentences are translated in UI language.

Test various versions of 5.4 branch, with UI in English and German.
Oldest version I've got, contains already the bug:
- Version: 5.4.0.0.alpha0+ (x64)
Build ID: a94ef79826fdb52bcde2d0ee8b76da6df46962f2
CPU threads: 2; OS: Windows 6.1; UI render: default;
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2017-04-11_11:00:05
Locale: fr-FR (fr_FR); Calc: CL 

No bug in 5.3.7.2 nor 6.0.1.1.

I was unable to found the untranslated string in pootle 5.4 branch.
Comment 1 Laurent BP 2018-02-19 21:30:52 UTC
Created attachment 140006 [details]
Dialog in French UI in LibO 5.4.5.1
Comment 2 sophie 2018-02-20 13:40:43 UTC
String is not present on Pootle source language in 5.4 UI.
In master, you can find it in master UI sc/messages.po, keyID rseoe
WARNINGS - Set as new - Sophie
Comment 3 Laurent BP 2018-02-21 21:23:49 UTC
This bug is bibisectable, not for its translation pb but for the first word missing "Warning".
Manual bibisection:

Reproduce with:
- Version: 5.4.0.0.alpha0+
Build ID: 0999c403a0a7cc9248a1773042ad09fd85004267
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-21_23:15:44
Locale: fr-FR (fr_FR); Calc: CL

NOT reproduce with:
- Version: 5.4.0.0.alpha0+
Build ID: d7736283aae4a79aa497bd2196a076ff402e671f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-02_00:30:31
Locale: fr-FR (fr_FR); Calc: CL

So bug was introduced in master between 2017-02-02_00:30:31 and 2017-02-21_23:15:44.

This bug does not exist in 6.0 branch

No Warning dialog at all:
- Version: 6.0.0.0.alpha0+
Build ID: 18f80da7a689ab962735c0f657497b8f1ed4d606
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-07-28_05:19:39
Locale: fr-FR (fr_FR); Calc: CL

Correct dialog:
- Version: 6.0.0.0.alpha0+
Build ID: 5d1f948cfcaec6127080cd035734492c1bb1d9b2
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-14_03:21:44
Locale: fr-FR (fr_FR); Calc: CL

So dialog was repaired between 2017-07-28_05:19:39 and 2017-08-14_03:21:44. This reparation is expected to be backported to 5.4 branch.

I hope to have time to make this bibisection next week-end.
Comment 4 Laurent BP 2018-02-22 21:34:21 UTC
Bibisection of the bug in 5.4 branch:
c4160729ec120beae63d50db31dca1c6b05eef93 is the first bad commit
commit c4160729ec120beae63d50db31dca1c6b05eef93
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Feb 16 13:45:05 2017 +0100

    source sha:2c91fc19445bb503652e97cc8b9f9014db436c37
    
    source sha:2c91fc19445bb503652e97cc8b9f9014db436c37

:040000 040000 5e1351f1a6a3f87c3140eccf2d4d18f0d698895b 412b2a9066ee625bc707d97a6b3a891043f7c3c2 M	instdir

"culprit" candidate:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=2c91fc19445bb503652e97cc8b9f9014db436c37
Comment 5 Laurent BP 2018-02-22 21:42:02 UTC
Created attachment 140073 [details]
Warning word is missing, only 1st sentence is translated when too many rows for XLS format

I can reproduce same bug with another warning message:
1. Go to last row # 1,048,576 with Ctrl+down arrow
2. Enter a value
3. File > Save as > sample.xls
4. Confirm XLS format

Actual behavior:
See attached file:
- no "Warning" word
- only 1st sentence is translated
Comment 6 Laurent BP 2018-02-22 22:09:23 UTC
Created attachment 140074 [details]
Another not translated message: Split cells in Writer

In Writer, warning messages are neither translated:
1. Insert a table
2. Split cells as long as you get a warning message

Actual behavior:
See attached screenshot: message is in English

Expected behavior:
As UI is in French, message should also be in French.

In Basic, warning messages are correctly translated.
Comment 7 Laurent BP 2018-02-24 15:51:09 UTC
In 6.0 branch, bug is resolved since:
https://cgit.freedesktop.org/libreoffice/core/commit?id=f1a896c71c495bdef5861eb664581507b6b9b5bb
author	Noel Grandin <noelgrandin@gmail.com>	2017-08-13 08:34:14 +0200
committer	Julien Nabet <serval2412@yahoo.fr>	2017-08-13 09:42:45 +0200
commit	f1a896c71c495bdef5861eb664581507b6b9b5bb (patch)
*fix some ErrCode IgnoreWarning() usage*

which says that regression was introduced by
author	Noel Grandin <noel.grandin@collabora.co.uk>	2017-02-09 08:52:13 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2017-06-21 08:42:30 +0200
commit	528632660b72b105345945c13c5b68060d94a91b (patch)
*convert ErrCode to strong typedef*

This last commit seems huge and difficult to backport to 5.4 branch.

Add CC to Noel and Caolan
Change Summary to reflect more the root pb
Change component to UI (Calc+Writer)
Comment 8 Caolán McNamara 2018-02-25 20:57:53 UTC
https://gerrit.libreoffice.org/#/c/50329/ should address the missing 'Warning'/'Error' piece
Comment 9 Commit Notification 2018-02-26 09:13:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f3d1b49a02744532d637ea398b76b7486e83ea63&h=libreoffice-5-4

Related: tdf#115866 'Warning' missing

It will be available in 5.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2018-02-26 11:04:00 UTC
I see from make translations that some of these warnings are not getting into the .pot, and I also see that if I remove the comments inside the StringArray blocks that it then works, so it looks like those comments break the older tooling
Comment 11 Caolán McNamara 2018-02-26 11:18:05 UTC
https://gerrit.libreoffice.org/#/c/50353/1 for me makes make translation find those missing translations
Comment 12 Laurent BP 2018-02-26 20:17:20 UTC
(In reply to Caolán McNamara from comment #8)
> https://gerrit.libreoffice.org/#/c/50329/ should address the missing
> 'Warning'/'Error' piece

Yes, I confirm it fixes the missing first word missing.
Comment 13 Commit Notification 2018-03-05 13:00:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba9572cb7a5e9e5bde8175e56f9b684919bfd2cb&h=libreoffice-5-4

tdf#115866 comments inside StringArray blocks drop translations

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Laurent BP 2018-03-06 12:42:16 UTC
Created attachment 140381 [details]
Screen shot of dialog mixing French and English text

Test with LibO 5.4.6.1
Version: 5.4.6.1 (x64)
Build ID: 7d6c666f03cf1f0a0c2c51a17c0f67a8d5a8012b
Threads CPU : 4; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: group

The "Warning" is correctly translated, but the end of dialog is in English, instead of French as expected.
Comment 15 Caolán McNamara 2018-03-06 13:31:18 UTC
Presumably because there is no French translation for it. Probably because the parser error affected the extraction of the original strings that got imported into pootle to get translated.
Comment 16 Laurent BP 2018-03-06 15:13:14 UTC
Created attachment 140392 [details]
Screen shot of dialog mixing German and English text

I can confirm same bug with German UI
Comment 17 Commit Notification 2018-03-13 20:10:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f36da93f6f58bf5fe8e6390133240e0f0476b55&h=libreoffice-5-4-6

tdf#115866 comments inside StringArray blocks drop translations

It will be available in 5.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Xisco Faulí 2018-04-13 08:41:24 UTC
A polite ping to Caolán McNamara && Laurent BP: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 19 Laurent BP 2018-04-14 12:33:07 UTC
It is NOT fixed in Version: 5.4.7.1
Build ID: ef425abf896c652d177000096228d1dbcfe9c7af
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group