Download it now!
Bug 115868 - Tabbed Notebookbar does not accept Firefox themes
Summary: Tabbed Notebookbar does not accept Firefox themes
Status: RESOLVED DUPLICATE of bug 107266
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-20 05:04 UTC by Joe
Modified: 2018-02-22 09:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Concept on how tabbed notebookbars could handle colors better (102.64 KB, image/png)
2018-02-20 05:06 UTC, Joe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe 2018-02-20 05:04:01 UTC
Description:
The tabbed notebook bar does not show Firefox themes. The background of the tabbed notebookbar is white despite the theme being used. All non-tabbed notebookbar variants seem to handle theme colors correctly. I have attached a simple mockup of how this can be handled better.

Steps to Reproduce:
Activate dev options and switched to tabbed notebookbar, and load a Firefox theme.

Actual Results:  
White notebookbar backgeounds for tabbed content areas

Expected Results:
Persona colors applied.


Reproducible: Always


User Profile Reset: No



Additional Info:
Only tested on Windows 10. May appear in earlier versions of LO and on other platforms.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Joe 2018-02-20 05:06:22 UTC
Created attachment 140010 [details]
Concept on how tabbed notebookbars could handle colors better
Comment 2 Xisco Faulí 2018-02-21 23:40:30 UTC
Hi Joe,
It think this can be closed as dupe of bug 107266.
Anyway, thank you for the concept attached. it looks really great!

Do you know about the LibreOffice Design Team -> https://th.libreoffice.org/get-involved/ux-visual-designers/ ?

They need people like you make LibreOffice look nicer.

Heiko Tietze ( Added as Cc ) is the UX Designer and UX mentor at The Document Foundation.

*** This bug has been marked as a duplicate of bug 107266 ***
Comment 3 Heiko Tietze 2018-02-22 08:51:08 UTC
(In reply to Joe from comment #1)
> Created attachment 140010 [details]
> Concept on how tabbed notebookbars could handle colors better

Awesome. But even when Personas work you never have two sections and need to define the colors on one bitmap. The problem is that tabs have varying height on the different systems. Nevertheless, Microsoft users would feel home.
Comment 4 andreas_k 2018-02-22 09:22:37 UTC
It was also something like I had in mind for firefox personas, but I have to say that firefox personas aren't 100% stable and in the end you have a lot of issues with different heights as Heiko wrote.

In addition the reason why personas didn't work in tabbed bars is that the tabs aren't "transparent".

The easiest way to solve this issue would be to define a one color firefox personas theme (for writer blue, calc green, ...) and the tab section get something like 80% transparent so the blue color will shine through it but will be a bit different.

There is a second bug with firefox personas that the color of the menubar change depand on the personas background but not the labels from the notebookbar.