Bug 107266 - Persona flipped on Notebookbars
Summary: Persona flipped on Notebookbars
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.0.2
Keywords:
: 107417 115868 (view as bug list)
Depends on:
Blocks: Notebookbar-Theming Firefox-Themes
  Show dependency treegraph
 
Reported: 2017-04-19 09:57 UTC by Heiko Tietze
Modified: 2018-10-08 09:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with Personalization set for classic toolbar and for contextual sections below (131.50 KB, image/png)
2017-04-19 09:57 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2017-04-19 09:57:23 UTC
Created attachment 132680 [details]
Screenshot with Personalization set for classic toolbar and for contextual sections below

Notebookbars can be personalized like classic toolbars via tools > options > personalization. But the background image seems to be flipped (see attachment).

(In case of the tabbed variant the background image is hidden completely.)
Comment 1 Yousuf Philips (jay) (retired) 2017-04-19 16:09:48 UTC
Confirmed

Version: 5.4.0.0.alpha0+
Build ID: 04edc5c796c1b96e5228d0c1fcf73bcf52465b66
CPU threads: 2; OS: Linux 3.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-15_03:25:45
Locale: en-US (en_US.UTF-8); Calc: group
Comment 2 Adolfo Jayme 2017-04-26 00:12:08 UTC
*** Bug 107417 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2018-02-21 23:40:30 UTC
*** Bug 115868 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2018-05-30 16:56:51 UTC
Kshitij Pathania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e02b3b095e472646c58eecd36d5a27b056dcb99e

tdf#112034 , tdf#107266 label color on basis of persona and persona

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-06-06 17:35:54 UTC
Kshitij Pathania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=09cc173d59c0b79dca1ea11b37c858e8716062d3

tdf#107266 made background continous for menubar and notebookbar

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-07-06 10:43:22 UTC
Kshitij Pathania committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b848a51e9b8bc59aeb327d5c8349a29b26c31dc&h=libreoffice-6-1

tdf#107266 made background continous for menubar and notebookbar

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-07-06 10:43:40 UTC
Kshitij Pathania committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22211ce6e9f5947f644ef82dd07e99ebc9f8d8a1&h=libreoffice-6-1

tdf#112034 , tdf#107266 label color on basis of persona and persona

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-08-06 11:38:21 UTC
A polite ping to Kshitij Pathania:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 9 Xisco Faulí 2018-09-06 09:21:01 UTC
(In reply to Xisco Faulí from comment #8)
> A polite ping to Kshitij Pathania:
> Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
> Otherwise, Could you please explain what's missing?
> Thanks

Ping?
Comment 10 Heiko Tietze 2018-10-08 09:13:49 UTC
Don't see the problem anymore. CLosing as fixed.