Download it now!
Bug 116201 - hyperlinks won't word wrap in Impress
Summary: hyperlinks won't word wrap in Impress
Status: RESOLVED DUPLICATE of bug 40563
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-05 12:27 UTC by john
Modified: 2018-03-10 17:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2018-03-05 12:27:45 UTC
Description:
I create a small text box in LibreOffice. I create the text "veolia woodlawn bioreactor" and then I make the box small enough that the text wraps, one word per line. Then select the last two words ('woodlawn bioreactor') and Insert->Hyperlink. I paste in the hyperlink 

https://www.veolia.com/anz/our-services/our-facilities/landfills/woodlawn-bioreactor-facility

After doing that, my word-wrapped text has un-wordwrapped, and now shows

veolia
woodlawn biore

(and the last bit of the word 'bioreactor' is chopped off).

After I press escape, I can see that my text was wordwrapped BADLY as follows

veolia
woodlawn bior
eactor

In summary, hyperlinks in LibreOffice are not properly treated as multiple words, but are instead wordwrapped as though they are one single word.

Preferred behaviour would be that hyperlinks are wordwrapped just like normal text (as they would be in a browser, for example).



Steps to Reproduce:
Description as above.

Actual Results:  
As above

Expected Results:
As above


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Buovjaga 2018-03-10 17:48:30 UTC

*** This bug has been marked as a duplicate of bug 40563 ***