Bug 116334 - Double-click does not expand option tree
Summary: Double-click does not expand option tree
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: bibisected, bisected, needUITest, regression
: 116356 (view as bug list)
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2018-03-10 13:35 UTC by Buovjaga
Modified: 2018-03-28 15:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2018-03-10 13:35:04 UTC
1. Tools - Options
2. Double-click load/save or any of the other top-level items

Regression from 6.0.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 22b1d4784d02070ae1933c59cf2c9bb5a5284773
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 10th 2018
Comment 1 Xavier Van Wijmeersch 2018-03-10 14:58:19 UTC
confirm with

Version: 6.1.0.0.alpha0+
Build ID: 7c693fc3f7218e1ca0c85a0de76ae84226391256
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group

Version: 6.1.0.0.alpha0+
Build ID: 598cf9f76176c6bef00402755d0e941a036c6a2d
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: group

but not with

Version: 6.0.3.0.0+
Build ID: 97b65102db4b1e8f95faf08521329da37cc3f2ec
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 2 Xisco Faulí 2018-03-10 23:02:02 UTC
Regression introduced by:

author	Jim Raykowski <raykowj@gmail.com>	2018-01-01 14:52:41 -0900
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-01-11 11:30:08 +0100
commit	582b2ed5ba25657afc2c2d45860899325b3b2450 (patch)
tree	60ec98ab10f80fb2da3a08ab8beb3d73e3c344b7
parent	f66fbd947f70f6be6b22ab372facaeb9e2fb63ae (diff)
tdf#36308 make double click not expand/collapse node in Navigator tree

Bisected with: bibisect-linux64-6.1

Adding Cc: to Jim Raykowski
Comment 3 Jim Raykowski 2018-03-11 11:10:20 UTC
(In reply to Xisco Faulí from comment #2)
> Regression introduced by:
> 
> author	Jim Raykowski <raykowj@gmail.com>	2018-01-01 14:52:41 -0900
> committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-01-11 11:30:08
> +0100
> commit	582b2ed5ba25657afc2c2d45860899325b3b2450 (patch)
> tree	60ec98ab10f80fb2da3a08ab8beb3d73e3c344b7
> parent	f66fbd947f70f6be6b22ab372facaeb9e2fb63ae (diff)
> tdf#36308 make double click not expand/collapse node in Navigator tree
> 
> Bisected with: bibisect-linux64-6.1
> 
> Adding Cc: to Jim Raykowski

Hi Xisco,

Yes this patch did cause a regression but was fixed by the patch for bug 115105.

What I can see is happening to cause this now is that double clicks are being seen as single clicks here [1] causing the code that expands/collapses on double click to be skipped over.
 
[1] https://opengrok.libreoffice.org/xref/core/svtools/source/contnr/svimpbox.cxx#2020
Comment 4 Xisco Faulí 2018-03-12 14:18:22 UTC
*** Bug 116356 has been marked as a duplicate of this bug. ***
Comment 5 Jim Raykowski 2018-03-13 10:33:15 UTC
(In reply to Jim Raykowski from comment #3)

> 
> What I can see is happening to cause this now is that double clicks are
> being seen as single clicks here [1] causing the code that expands/collapses
> on double click to be skipped over.
>  
> [1]
> https://opengrok.libreoffice.org/xref/core/svtools/source/contnr/svimpbox.
> cxx#2020

So this isn't due to the double clicks being seen as single clicks but a few lines of code down the DoubleClickHdl() has been recently changed to return false.

commit 7651e57573952758032ceb88f16e2dbbb6cc4e18
Author: Jan Holesovsky <kendy@collabora.com>, Thu Mar 1 12:13:53 2018 +0100 (12 days ago)
Committer: Jan Holesovsky <kendy@collabora.com>, Thu Mar 1 15:41:13 2018 +0100 (12 days ago)
Follows: libreoffice-6-0-branch-point
Branches: <Expand>

tdf#115950: Indicate that the dialog was already destroyed.

The DoubleClickHdl()'s return value does not mean "was handled", but actually
"is there anything more to be done"; so if we actually destroy the dialog in
the aDoubleClickHdl.Call(this), we have to return 'false'.

Change-Id: I7c510e8341eb5f74703b4266f86cb1e840a2b1fd
Reviewed-on: https://gerrit.libreoffice.org/50261
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Jan Holesovsky <kendy@collabora.com>
Comment 6 Jan Holesovsky 2018-03-13 11:51:15 UTC
Thanks for spotting this, pushed a fix to gerrit :-)

https://gerrit.libreoffice.org/51211
Comment 7 Commit Notification 2018-03-13 15:29:52 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b9af08481b8f7f4bd15a30508606dff56b8e74f

tdf#116334: Actually when there is no handler, we have to return 'true'.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Jan Holesovsky 2018-03-13 16:34:16 UTC
Thanks all for pointing out the commit! :-)  Fixed now.
Comment 9 Xisco Faulí 2018-03-28 15:06:18 UTC
Verified in

Version: 6.1.0.0.alpha0+
Build ID: 8329f4541e27402d19729ae1588af8bfe61f7b49
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Thank you Kendy!