Bug 116342 - EDITING: Clicking inside text box does nothing
Summary: EDITING: Clicking inside text box does nothing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:6.1.0
Keywords: needsUXEval
: 116535 (view as bug list)
Depends on:
Blocks: Textbox
  Show dependency treegraph
 
Reported: 2018-03-10 16:44 UTC by Jon Yoder
Modified: 2021-02-13 06:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Yoder 2018-03-10 16:44:52 UTC
Description:
Clicking on a text box in any blank area inside the box's frame does nothing. User must click on existing text to begin editing.

Steps to Reproduce:
1. Create a new document
2. Create a large text box and type a few letters
3. Click outside the document to remove focus from the text box
4. Click inside the text box frame without clicking on the entered text.

Actual Results:  
Nothing happens

Expected Results:
Give text box focus, turn on editing of text, and place caret at nearest appropriate location.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.2.1
Build ID: 1:6.0.2~rc1-0ubuntu0.16.04.1~lo1
CPU threads: 6; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: CL


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Buovjaga 2018-03-11 16:05:22 UTC
UX: what do you think? Seems a bit of a balancing act for cases with many (overlapping) elements on a page/slide. I could not find a duplicate request.
Comment 2 Jean-Baptiste Faure 2018-03-13 13:35:58 UTC
I disagree: when you click inside the text box but not on the text it contains, the text box is selected and you can move it, change its size or get its contextual menu. If clicking in the text box did what you expect it to do, you would not be able to access functions of the object text box.

To obtain what you want, you only have to double-click in the text box.

So, for me, it's not a bug. Closing as NotABug. Please feel free to reopen if you disagree.

Best regards. JBF
Comment 3 Regina Henschel 2018-03-13 13:52:54 UTC
Please be aware, that the user can change the behavior of click and double-click for text boxes. It is in Tools > Options > Draw > General, section "Text Objects" and in the toolbar "Options".
Comment 4 Jon Yoder 2018-03-14 00:45:42 UTC
Thank you Jean-Baptiste and Regina for the insights. I still believe this one is a UX bug. I was not aware of the options Regina mentioned.

Am I correct in thinking that 'Only text area selected' is on by default? If it is, it needs to be off by default. This option would be the cause of my initial confusion and frustration.

Is there a purpose to this option? I'm sure there was a reason behind it, but I fail to see what it might have been. With having the option off by default, the user receives some feedback that something is under the pointer and can click to see the size of the box. This provides some relief to the complete invisibility of a text box (outside of its contents) when not selected.

If I'm struggling with this, I'd hate to see how non-technical users would react on this... or at least non-technical Americans (which there are a LOT of).
Comment 5 Samuel Mehrbrodt (allotropia) 2018-03-14 13:22:34 UTC
This has also bothered me ever since.
Also didn't know that this handy option exists, should definitely be off by default!

Also the label should change from "Only text area selected" to "Only text area selectable" which is what it actually means.
Comment 6 Commit Notification 2018-03-14 15:18:12 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4ed9ffad92c83db21c9fcb62e414aa0cb8f5c4c4

tdf#116342 Fix label: selectable, not selected is what this means

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-03-14 19:06:07 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d799436414ab7e28b6bf9a918fd3779b3fc85008

tdf#116342 Allow selecting text boxes anywhere by default

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2018-03-30 15:50:47 UTC
*** Bug 116535 has been marked as a duplicate of this bug. ***
Comment 9 V Stuart Foote 2018-04-03 12:18:07 UTC
*** Bug 116768 has been marked as a duplicate of this bug. ***
Comment 10 Heiko Tietze 2018-04-03 12:35:20 UTC
Trying to edit a text in a shape for bug 116768 Draw crashes when I double click the shape with text sometimes when entering sometimes when leaving the shape.

Version: 6.1.0.0.alpha0+
Build ID: deff95f307ec767b1d19f3debcf092b1b949cc70
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group