Bug 116350 - PPTX: Missing font effect "transformation" support
Summary: PPTX: Missing font effect "transformation" support
Status: ASSIGNED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.2.0 target:6.1.1
Keywords:
Depends on:
Blocks: ImpressDraw-Enhancements
  Show dependency treegraph
 
Reported: 2018-03-11 19:05 UTC by Szymon Kłos
Modified: 2018-10-03 12:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (32.12 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-03-11 19:05 UTC, Szymon Kłos
Details
comparison (32.40 KB, image/png)
2018-03-11 19:06 UTC, Szymon Kłos
Details
ST_TextShapeType from ISO/IEC 29500-1:2016(E) (2.10 KB, text/plain)
2018-07-31 15:56 UTC, Regina Henschel
Details
Document with all WordArt transformations available in PowerPoint (2.06 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-07-31 16:02 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Szymon Kłos 2018-03-11 19:05:43 UTC
Created attachment 140564 [details]
sample

1. Open attached file
2. Text is not formatted

Expected: Text has the arc shape.
Comment 1 Szymon Kłos 2018-03-11 19:06:10 UTC
Created attachment 140566 [details]
comparison
Comment 2 Xisco Faulí 2018-03-12 01:10:12 UTC
Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: adc6ba2ad502f095dde8f36242fda9aaa6c276fd
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Regina Henschel 2018-07-31 15:56:07 UTC
Created attachment 143844 [details]
ST_TextShapeType from ISO/IEC 29500-1:2016(E)

Hi Szymon, I have noticed, that your map does not include all possible transformations. Including "none" there should be 41.
Comment 4 Regina Henschel 2018-07-31 16:02:53 UTC
Created attachment 143845 [details]
Document with all WordArt transformations available in PowerPoint

The attached document contains all WordArt transformations available in the UI of PowerPoint 365. The presentation lists them in the order they are available in the UI. There is each a slide with the WordArt and a next slide with an image of it.
Comment 5 Szymon Kłos 2018-07-31 16:06:03 UTC
Thank you for a test document, I will add all types.
Comment 6 Commit Notification 2018-08-02 15:17:35 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bf3420110cdd21490bc8d49a471340e747585159

tdf#116350 Import preset text geometry (text effects)

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Cor Nouws 2018-08-02 15:53:14 UTC
nice work  ! Thanks :)
Comment 8 Regina Henschel 2018-08-02 21:06:33 UTC
Indeed, your work is great.

One reason, why it looks different in PowerPoint and LibreOffice, is the fact, that the needed attribute draw:text-path-scale of the <draw:enhanced-geometry> element is not implemented in LibreOffice. Instead the text is always scaled to path, but in PowerPoint it is scaled to shape.

If you re-save the file to pptx format, PowerPoint says, that the file is corrupted and wants to repair it, without success. But that problem exists already before your patch.
Comment 9 Commit Notification 2018-08-03 06:07:57 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5934d4ab724c96f69ef0d5b0c76d770c1f615960

tdf#116350 Export preset text geometry (text effects)

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Szymon Kłos 2018-08-03 09:48:02 UTC
(In reply to Regina Henschel from comment #8)
> Indeed, your work is great.
> 
> One reason, why it looks different in PowerPoint and LibreOffice, is the
> fact, that the needed attribute draw:text-path-scale of the
> <draw:enhanced-geometry> element is not implemented in LibreOffice. Instead
> the text is always scaled to path, but in PowerPoint it is scaled to shape.
> 
> If you re-save the file to pptx format, PowerPoint says, that the file is
> corrupted and wants to repair it, without success. But that problem exists
> already before your patch.

I'm still working on it to improve display of arcs with non-default adjustment (now it looks horrible because text is oversized).
Comment 11 Commit Notification 2018-08-08 13:59:32 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e1d6ed941590a771abfc73f9eef4a98346eca762

tdf#116350 Correctly display text on arc

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-08-08 20:39:44 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f536bff1dc0e80c6ef23d132edf471ea75ffb05e

tdf#116350 Fix export of fontwork

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Regina Henschel 2018-08-08 21:48:48 UTC
Case 'arc' is fixed, but there are still fillings, see bug 119160.
Comment 14 Commit Notification 2018-08-16 10:27:53 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a643c8353754c6ce8b318e37cbbc60c3425e9d32

tdf#116350 Better text layout for big shapes

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-08-20 08:13:30 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b56857dbd21083f5d41eaf4c0f08db1977cf8d2e&h=libreoffice-6-1

tdf#116350 Import preset text geometry (text effects)

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2018-08-20 08:14:47 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=409fd186af22bd9c1819cc0f05bfca3bdf427a42&h=libreoffice-6-1

tdf#116350 Export preset text geometry (text effects)

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2018-08-20 08:14:56 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=406280c62843e9ed167e7adaa005fba92a39608f&h=libreoffice-6-1

tdf#116350 Fix export of fontwork

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-08-20 08:16:13 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40b396ef207213ebd07981206674a2260256cb3c&h=libreoffice-6-1

tdf#116350 Correctly display text on arc

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 BogdanB 2018-08-20 08:22:10 UTC
Confirm it work on 6.2.0

Version: 6.2.0.0.alpha0+
Build ID: f05b0a6aaf8af5d78f9cad8bb953228cb0ce09f1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-08-20_01:57:14
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 20 Commit Notification 2018-08-20 15:43:13 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=591b7a689928cf428f63cb31adc5bbe6b56da231&h=libreoffice-6-1

tdf#116350 Better text layout for big shapes

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Xisco Faulí 2018-09-20 08:43:58 UTC
A polite ping to Szymon Kłos:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 22 Zineta 2018-10-03 10:45:29 UTC
Confirm also works in:
Version: 6.1.1.2 (x64)
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: bs-BA (bs_BA); Calc: group threaded

and 
Version: 6.2.0.0.alpha0+ (x64)
Build ID: f780a64a4f62bb7884d9dcfd984dc96ab737b34e
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-01_23:31:23
Locale: bs-BA (bs_BA); Calc: threaded
OS:WIN 7
Comment 23 Timur 2018-10-03 12:18:11 UTC
Szymon, can you please comment on backport to 6.0.7?