Bug 104217 - FILEOPEN: PPTX: Wordart with Gradient Fill is imported with no color
Summary: FILEOPEN: PPTX: Wordart with Gradient Fill is imported with no color
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2016-11-28 10:49 UTC by Xisco Faulí
Modified: 2021-01-14 19:54 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (36.77 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-11-28 10:52 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-28 10:49:18 UTC
Steps:
1. Open attached document

Observed behaviour: Wordart is imported as white

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-28 10:52:14 UTC
Created attachment 129066 [details]
sample
Comment 2 Telesto 2016-11-28 13:42:01 UTC
Confirming with:
Version: 5.4.0.0.alpha0+ (x64)
Build ID: 7aa2b5a041df8e71a435cccbc79ee13799ec9138
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-11-24_11:40:27
Locale: nl-NL (nl_NL); Calc: CL

but not in:

Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: nl-NL (nl_NL)

Note: text-layout is wrong
Comment 3 Aron Budea 2016-12-06 18:16:35 UTC
Yes, looks okay in 5.1.6.2, but white in 5.2.0.4 / Windows 7.
Adjusting version field.
Comment 4 raal 2016-12-11 14:16:14 UTC
This seems to have begun at the below commit.
Adding Cc: to Matus Uzak; Could you possibly take a look at this one? Thanks

		author	Matus Uzak <matus.uzak@gmail.com>	2016-03-07 11:04:01 (GMT)
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2016-03-10 10:20:46 (GMT)
commit	6802f760a69f3b1f203d70399f0d73764f9159d5 (patch)
tree	17252a9645bedcf4bdbdecd4cc8ef43ae589ce2a
parent	a076feda8e6541ce611866e3f20f65648ec2b50b (diff)
tdf#89927: PPTX import: Incorrect inheritance of text run fill properties
Make use of FillProperties in TextCharacterProperties.  DrawingML:
Fill related elements in Text Run Properties are in sync with Table
Cell Properties and all of Line Properties.

51f9111c56a3f0fb531f0ae7ee718a10d6339df5 is the first bad commit
commit 51f9111c56a3f0fb531f0ae7ee718a10d6339df5
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Mar 18 14:03:17 2016 -0700

    source sha:6802f760a69f3b1f203d70399f0d73764f9159d5
 git bisect log
# bad: [6380ca07b05f68dedcaa379302cfe1fa478571c4] source sha:60b74fe1775e647545d2da1fcc58a4c63ec18aa5
# good: [1f670510f08cb800cbae2a1dd6ea70d3542e4721] source sha:49c2b9808df8a6b197dec666dfc0cda6321a4306
git bisect start 'origin/master' 'oldest'
# good: [38f37b8ec1a2d199bb957cfd2581df7d1b273b74] source sha:c0da1080b61a1d51654fc34fdaeba373226065ff
git bisect good 38f37b8ec1a2d199bb957cfd2581df7d1b273b74
# bad: [11ae494d8c566f23e0ef84ba0cc25fb1388b67f7] source sha:470cfa9860232ab70e017e6084d80f80d469555c
git bisect bad 11ae494d8c566f23e0ef84ba0cc25fb1388b67f7
# bad: [d247d25062e6cc4afccdc3c4be84a2b98523b36a] source sha:150c1dcab007dd8acc1551791f42eef692f9e531
git bisect bad d247d25062e6cc4afccdc3c4be84a2b98523b36a
# good: [dc23450cfb87b61fcbd905a7079d8a0d32759e6b] source sha:5c1234eac2b9f3a3ea032e4828a15bedca6b9ebe
git bisect good dc23450cfb87b61fcbd905a7079d8a0d32759e6b
# bad: [3c06b49a11643ee6e22d8184f65dcc129ceb586d] source sha:42d6a165b053ebdccbd6979eb849b1abe305d2ba
git bisect bad 3c06b49a11643ee6e22d8184f65dcc129ceb586d
# good: [ae20ff1c2de6ecec64f34a839a82f6dfd00f5ac5] source sha:70fca3e901e41fa52589eb3f06e6839c4a8582de
git bisect good ae20ff1c2de6ecec64f34a839a82f6dfd00f5ac5
# bad: [6d7499abfffe460a5f7013564141cc51dbc39e87] source sha:127fbac23afa1fc94dd7f8aae390e1ff55ed5d64
git bisect bad 6d7499abfffe460a5f7013564141cc51dbc39e87
# bad: [ead1e6d2162bca106369cec08b6bac34610626dc] source sha:a3fcf5a3b8ea26c289b12216d7f8fdb7e07814b7
git bisect bad ead1e6d2162bca106369cec08b6bac34610626dc
# good: [76ec908f8aa5824caac5af760b0b866e1bb0720b] source sha:3d82b08bcea45408b1998934558e2e28721125df
git bisect good 76ec908f8aa5824caac5af760b0b866e1bb0720b
# bad: [d644a4e4923dfa3b358bbb64eeb77baab7defeb4] source sha:51d1fca2041ba4478c5abae59b1ed4fee37ea1ee
git bisect bad d644a4e4923dfa3b358bbb64eeb77baab7defeb4
# good: [e9331335bf8aa1bad7e9846fc91393f07d3648ef] source sha:5c4717416b7eeaf99765725785278a7437fdaf8a
git bisect good e9331335bf8aa1bad7e9846fc91393f07d3648ef
# good: [d386da0740f30ba035d5dc2e2db7552c26a5e6ec] source sha:a076feda8e6541ce611866e3f20f65648ec2b50b
git bisect good d386da0740f30ba035d5dc2e2db7552c26a5e6ec
# bad: [51f9111c56a3f0fb531f0ae7ee718a10d6339df5] source sha:6802f760a69f3b1f203d70399f0d73764f9159d5
git bisect bad 51f9111c56a3f0fb531f0ae7ee718a10d6339df5
# first bad commit: [51f9111c56a3f0fb531f0ae7ee718a10d6339df5] source sha:6802f760a69f3b1f203d70399f0d73764f9159d5
Comment 5 QA Administrators 2017-12-13 09:29:21 UTC Comment hidden (obsolete)
Comment 6 Aron Budea 2017-12-27 09:18:32 UTC
Still in 6.0.0.1 / Windows 7.
Comment 7 Xisco Faulí 2018-09-12 10:05:56 UTC
*** Bug 119674 has been marked as a duplicate of this bug. ***
Comment 8 Luke 2018-09-12 22:54:12 UTC
Raised priority as this is an orphaned regression.
Comment 9 Xisco Faulí 2018-09-13 08:55:16 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2019-09-14 02:47:51 UTC Comment hidden (obsolete)
Comment 11 Luke 2019-09-14 13:12:44 UTC
Still reproducible in Version: 6.4.0.0.alpha0+ (x64)
Build ID: 396869e0e71bd33f5d962779abf72f35d01245e5
Comment 12 Justin L 2021-01-14 17:16:10 UTC
(In reply to Luke from comment #11)
> Still reproducible in Version: 6.4.0.0.alpha0+

This comment threw me off. I think it is fixed in LO 6.1.1 thanks to bug 116350. Prior to this, I only saw a completely white page. After this, I see "word arts" in black letters - similar (but fancier) to how it looked in 5.1.

@Xisco - please retest to see if this is considered acceptable.
Comment 13 Luke 2021-01-14 19:53:32 UTC
Sorry, this regression has been fixed although the original behavior is not correct despite us supporting gradients in Font Work. The font fill is set as gray to white, but it is imported as black. I filled a new bug for this issue as Bug 139618. 

Xisco, 
Please confirm to make sure I'm not missing anything. Any idea when this was fixed?