Bug 119674 - FILEOPEN: PPTX import WordArt is invisible when Pattern Fill Used
Summary: FILEOPEN: PPTX import WordArt is invisible when Pattern Fill Used
Status: RESOLVED DUPLICATE of bug 127696
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks: FontWork-WordArt
  Show dependency treegraph
 
Reported: 2018-09-03 19:03 UTC by Luke
Modified: 2022-06-02 09:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample WordArt with Solid Fill and Pattern Fill (30.83 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-09-03 19:03 UTC, Luke
Details
PPT format correctly imported (124.50 KB, application/vnd.ms-powerpoint)
2018-09-03 19:08 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2018-09-03 19:03:17 UTC
Created attachment 144644 [details]
Sample WordArt with Solid Fill and Pattern Fill

The OOXML importer does not handle patterns for WordArt

Steps to reproduce:
1. In PowerPoint, Insert WordArt
2. Text Fill -> Pattern Fill -> Any pattern
3. Save, and open in Impress

If our FontWork engine cannot support this feature, we should read the pattern color and use that as a sold fill, so the text is not invisible.
Comment 1 Luke 2018-09-03 19:08:16 UTC
Created attachment 144645 [details]
PPT format correctly imported

The Fontwork engine does support this feature, as the PPT format is correctly imported.
Comment 2 raal 2018-09-03 20:57:17 UTC
This seems to have begun at the below commit.
Adding Cc: to Matus Uzak ; Could you possibly take a look at this one?
Thanks

 6b2c83cfe7685f65332b1ca3c6b339715ae8057c is the first bad commit
commit 6b2c83cfe7685f65332b1ca3c6b339715ae8057c
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Dec 13 02:38:03 2017 +0100

    source sha:6802f760a69f3b1f203d70399f0d73764f9159d5
author	Matus Uzak <matus.uzak@gmail.com>	2016-03-07 12:04:01 +0100
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2016-03-10 10:20:46 +0000
commit 6802f760a69f3b1f203d70399f0d73764f9159d5 (patch)
tree 17252a9645bedcf4bdbdecd4cc8ef43ae589ce2a
parent a076feda8e6541ce611866e3f20f65648ec2b50b (diff)
tdf#89927: PPTX import: Incorrect inheritance of text run fill properties
Comment 3 Luke 2018-09-10 17:07:25 UTC
Adding CC: Katrina as she reviewed and committed the patch responsible for this regression. The original author has not been active for over 2 years.
Comment 4 Luke 2018-09-10 19:13:57 UTC
Per IRC discussion on orphaned regressions, bumped priority and removed CC: Katrina.
Comment 5 Xisco Faulí 2018-09-12 10:05:56 UTC
Commit is the same as in bug 104217.
Closing as RESOLVED DUPLICATED.

*** This bug has been marked as a duplicate of bug 104217 ***
Comment 6 Justin L 2021-01-14 17:10:26 UTC
Apparently not a duplicate, because the second item ("WordArt Hatching") is still invisible in 7.2+.  The alleged duplicate bug appears to be fixed.
Comment 7 Xisco Faulí 2022-06-02 09:34:43 UTC
Issue fixed by

author	Tünde Tóth <toth.tunde@nisz.hu>	2021-12-16 15:10:33 +0100
committer	László Németh <nemeth@numbertext.org>	2022-01-03 14:40:09 +0100
commit 678790f292b63c9def1f0427df20028a1f734c15 (patch)
tree b9d25d13c2ff874fc6a8fd52413160b9532aa8d0
parent f6fefed87a3ffac4a8d236e6a96a6405bfbb31f0 (diff)
tdf#127696 PPTX export: fix lost outline character formatting

Closing as RESOLVED FIXED
Comment 8 Xisco Faulí 2022-06-02 09:54:56 UTC
Actually this is the same issue as bug 101569, thus closing as DUPLICATED of bug 127696

*** This bug has been marked as a duplicate of bug 127696 ***