Bug Hunting Session
Bug 116355 - Can't open special characters dialog with .uno:CharmapControl > More Characters... in Calc
Summary: Can't open special characters dialog with .uno:CharmapControl > More Characte...
Status: RESOLVED DUPLICATE of bug 118993
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2018-03-12 08:59 UTC by Thomas Lendo
Modified: 2018-08-24 07:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-03-12 08:59:03 UTC
When using the .uno:CharmapControl command for example in a toolbar, the special characters dialog can't be openend with the 'More Characters...' button. This only occurs in Calc.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: cab04bc39b5164ea74216cd849c3af5f5b298f79
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-12_00:50:50
Locale: de-AT (de_AT); Calc: CL
Comment 1 Buovjaga 2018-03-14 18:54:21 UTC
(In reply to Thomas Lendo from comment #0)
> When using the .uno:CharmapControl command

How can I add it? I'm not seeing it in the list.
Comment 2 Thomas Lendo 2018-03-14 19:02:21 UTC
Search for Symbol. There are 2 items and one of them is the old command and one the new command. Maybe both are in the toolbar but only the old one is activated.
Comment 3 Buovjaga 2018-03-14 19:49:32 UTC
(In reply to Thomas Lendo from comment #2)
> Search for Symbol. There are 2 items and one of them is the old command and
> one the new command. Maybe both are in the toolbar but only the old one is
> activated.

Ah, I see. It was the lower one and indeed was a split-button.

The dialog opens with More characters just fine. Maybe try turning OpenGL off?

Version: 6.1.0.0.alpha0+
Build ID: 5b87abe06da35ca3a11628674af23460349b439a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-12_23:45:38
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 6a9326803c01f4c9bc7da855053ce4e80646fad8
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 14th 2018
Comment 4 Thomas Lendo 2018-03-15 16:53:23 UTC
Hm, turning OpenGL off has no effect.
Clicking at 'More Characters...' has still no effect.
Comment 5 Aron Budea 2018-03-19 01:28:27 UTC
Confirmed.

Version: 6.1.0.0.alpha0+
Build ID: e08e6516a01f28f2dd2581e3326be6d6b6eddb55
CPU threads: 16; OS: Windows 6.1; UI render: GL; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 6 Heiko Tietze 2018-08-24 07:45:46 UTC
Solved, backport to 6.1 in progress.

*** This bug has been marked as a duplicate of bug 118993 ***