Download it now!
Bug 116419 - Wrong calculation of coordinates when adding a text box to a shape that is anchored in a frame
Summary: Wrong calculation of coordinates when adding a text box to a shape that is an...
Status: RESOLVED DUPLICATE of bug 107225
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2018-03-15 16:36 UTC by Maxim
Modified: 2019-10-30 06:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Invalid text field location (19.99 KB, image/jpeg)
2018-03-15 16:45 UTC, Maxim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim 2018-03-15 16:36:26 UTC
Description:
In the drawing function, when you add a text field to a shape, if it is placed in a frame, the coordinates of the text field are incorrectly calculated. The position of the text field does not match the position of the shape.Also, if you add a text field to the shape, then cancel the action, then you can not add a text field to this figure.


Steps to Reproduce:
1. Create a new document
2. Add a incut
3. Add a shape to the incut
4. Select the shape
5. Right-click
6. Select add text field

Actual Results:  
The text field is added outside the shape


Expected Results:
The text field is added inside the shape



Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.0.1.1
ID сборки: 60bfb1526849283ce2491346ed2aa51c465abfe6
Потоков ЦП: 2; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU); Calc: group



User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Maxim 2018-03-15 16:45:59 UTC
Created attachment 140656 [details]
Invalid text field location
Comment 2 Dieter 2018-03-16 08:53:42 UTC
I can't find anything named "incut" in the UI. Where is it?
Comment 3 Maxim 2018-03-16 09:07:46 UTC
(In reply to Dieter Praas from comment #2)
> I can't find anything named "incut" in the UI. Where is it?

It is a text frame
Translation error
Comment 4 Dieter 2018-03-16 09:34:54 UTC
I could reproduce it:

1. Open new document
2. Insert => Frame => Frame
3. Ad a shape to the frame
4. right click in the shape => add text box
5. Text box is outside the shape

I also noticed, that if you create a shape without a frame, the textbox is also only partially in the shape.
Comment 5 Xisco Faulí 2018-03-19 15:47:31 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.13; Render: default;
Comment 6 QA Administrators 2019-03-20 03:49:55 UTC Comment hidden (obsolete)
Comment 7 Dieter 2019-03-20 08:03:25 UTC
Still repro

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 8 sdc.blanco 2019-10-30 02:53:34 UTC
Have changed title of the bug to indicate that it only occurs when the shape is inside the frame.

No problem with adding textbox to a shape.
And no problem with:  Create shape outside a frame, add the textbox, then anchor the shape in the frame.

Tests done with: 6.3.3.1, Windows 10.0; UI render: default; VCL: win;
Comment 9 Buovjaga 2019-10-30 06:55:29 UTC
sdc.blanco noticed there is an older report for this

*** This bug has been marked as a duplicate of bug 107225 ***