Bug 107225 - Wrong position of textbox in shape, if shape is contained in a frame
Summary: Wrong position of textbox in shape, if shape is contained in a frame
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: All All
: medium minor
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.1.0
Keywords:
: 116419 (view as bug list)
Depends on:
Blocks: Shape-Textbox
  Show dependency treegraph
 
Reported: 2017-04-17 09:36 UTC by Telesto
Modified: 2020-08-14 19:19 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (10.63 KB, application/vnd.oasis.opendocument.text)
2017-04-17 09:36 UTC, Telesto
Details
How it looks in the current master (272.48 KB, image/png)
2020-07-28 09:42 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-04-17 09:36:32 UTC
Description:
The position of the textbox in a shape is wrong, if shape is contained in a frame and the textbox is added afterward. 

It happens with a 'Insert Caption" frame or adding a regular frame (Insert -> Frame). The effect is the same as report in bug 84691 

Steps to Reproduce:
1. Open attached file
2. Add a textbox to the circle (by right clicking the circle and click add textbox)
3. Add a textbox to the triangle 

After saving and re-opening the position of the textboxes changes again (likewise as in bug 84691)

Actual Results:  
Textbox is misplaced

Expected Results:
Textbox should be correctly positioned



Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-05_23:32:27
Locale: nl-NL (nl_NL); Calc: CL

and in
Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: en-US (nl_NL)
Locale: nl-NL (nl_NL)


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-04-17 09:36:52 UTC
Created attachment 132632 [details]
Example file
Comment 2 Buovjaga 2017-04-26 12:42:30 UTC
Reproduced (except position does not change after save & reload)

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+ (x64)
Build ID: 1f73ac90da31b62ccf6f040c68e5c0150171240f
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-04-20_07:32:30
Locale: fi-FI (fi_FI); Calc: CL
Comment 3 QA Administrators 2018-06-25 02:41:16 UTC Comment hidden (obsolete)
Comment 4 sdc.blanco 2019-10-30 03:03:33 UTC
reproduced (except position does not change after save & reload)

Version: 6.3.3.1 (x64)
Build ID: f41f4c7f9507aeca13cb9df51f34d80e8ba30a99
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 

Seems to be duplicate with bug #116419
Comment 5 Buovjaga 2019-10-30 06:55:29 UTC
*** Bug 116419 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2020-07-23 15:29:02 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fd88bb81236ad6d1a63436b7ce20f2f93410d359

tdf#107225 tdf#122887 sw: fix reanchoring of textboxes

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Attila Bakos (NISZ) 2020-07-28 09:42:07 UTC
Created attachment 163676 [details]
How it looks in the current master
Comment 8 BogdanB 2020-08-14 19:19:02 UTC
Solved.
Verified in
Version: 7.1.0.0.alpha0+
Build ID: 6ad2f463784a24c566477cdd60ae729651bb8564
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded