Bug 116484 - OpenGL: Windows bitmap corruption
Summary: OpenGL: Windows bitmap corruption
Status: RESOLVED DUPLICATE of bug 116213
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OpenGL Images
  Show dependency treegraph
 
Reported: 2018-03-19 06:53 UTC by Luke
Modified: 2018-03-21 17:06 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Before and After on a Nvidia GTX 650 (177.03 KB, image/png)
2018-03-19 16:42 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2018-03-19 06:53:29 UTC
Steps to Reproduce:

1. In Windows, open a Writer, Calc, or Impress file with an image such as attachment 81709 [details]
2. Note the corruption

Version: 6.1.0.0.alpha0+ Build ID: df4253787e9f6ba4951ee2f416ec65937b2c8ddf
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-16_22:59:27
Bad


Version: 6.1.0.0.alpha0+ Build ID: 4b2d899bc079240c32b7dacd139d6d4a29ab1b11
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Good

The linux GTK backend does not suffer from this issue. Disabling OpenGL works around this issue.
Comment 1 Telesto 2018-03-19 07:28:35 UTC
Probably bug 116213
Comment 2 Luke 2018-03-19 16:31:58 UTC
Yes, the fix for bug 116213 is the cause. I bisected this regression down to

https://cgit.freedesktop.org/libreoffice/core/commit/?id=460f39e687393b3a8906d2adc3e8f7a0c749851a

tdf#116213 OS X and OpenGL bitmap scaline sizes are not 32-bit aligned
Comment 3 Luke 2018-03-19 16:42:49 UTC
Created attachment 140717 [details]
Before and After on a Nvidia GTX 650
Comment 4 V Stuart Foote 2018-03-19 17:26:48 UTC
from coincident bug 116467#10

Hmm, toggling OpenGL enabled and disabled on TB42 builds from the 17th, 18th and today is controlling the glitch. Sure seems to be OpenGL dependent, and splash screen, toolbar icon, and document thumbnail "smearing" does not manifest with HA or CPU only default rendering.

Images that are smeared show grayscale, and slant--so look off by 1 in stacking a raster.
Comment 5 Xisco Faulí 2018-03-20 11:11:43 UTC
Adding Cc: to Chris Sherlock
Comment 6 Stephan Bergmann 2018-03-21 16:13:26 UTC
(In reply to Luke from comment #2)
> Yes, the fix for bug 116213 is the cause. I bisected this regression down to
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=460f39e687393b3a8906d2adc3e8f7a0c749851a
> 
> tdf#116213 OS X and OpenGL bitmap scaline sizes are not 32-bit aligned

Note that I had to revert that commit now, <https://cgit.freedesktop.org/libreoffice/core/commit/?id=ebe247642d85d39b6e1ffae3cf92c31748f2e983> "Revert 'tdf#116213 OS X and OpenGL bitmap scaline sizes are not 32-bit aligned'".
Comment 7 Xisco Faulí 2018-03-21 16:56:01 UTC
The problematic commit has been reverted in https://cgit.freedesktop.org/libreoffice/core/commit/?id=ebe247642d85d39b6e1ffae3cf92c31748f2e983

Let's close this as a dupe of bug 116213 for now...

*** This bug has been marked as a duplicate of bug 116213 ***
Comment 8 Michael Meeks 2018-03-21 17:06:09 UTC
Thanks Stephan - sorry for not getting to that myself; distracted this afternoon.