Download it now!
Bug 116612 - FORMATTING: Paragraph double line border not drawn correctly and unaligned
Summary: FORMATTING: Paragraph double line border not drawn correctly and unaligned
Status: RESOLVED DUPLICATE of bug 81643
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Borders
  Show dependency treegraph
 
Reported: 2018-03-24 23:21 UTC by Robert Gonzalez MX
Modified: 2018-03-25 15:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file and screenshots (41.88 KB, application/vnd.oasis.opendocument.text)
2018-03-24 23:25 UTC, Robert Gonzalez MX
Details
Test file from bug 89604 (303.35 KB, application/vnd.oasis.opendocument.text)
2018-03-24 23:26 UTC, Robert Gonzalez MX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gonzalez MX 2018-03-24 23:21:45 UTC
Description:
When a paragraph is defined with a double border, this double border is not drawn correctly and in the corners, the union is not aligned.

Steps to Reproduce:
1. Create a new writer document
2. In the styles and formatting window, create a new style, based on text body with right click and select New
3. In the paragraph style window, select the organizer tab, name the style as you wish like "double line test"
4. Select the borders tab and choose Line Arrangement  preset all borders
5. Select in the Line Style in the dropdown list a double border, the inner border thin and the outer border thick.
5. Line Width 4.0 or 5.0 pt.
6. Then the OK button.

type some text and then apply the style or vice-versa



Actual Results:  
The borders are drawn as one thick line, and the corners are unaligned 

Expected Results:
It should draw and display a double border well aligned and joined in the corners.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
This is related to bug 89604 I filed, that was marked as duplicate of bug 81643 that was closed recently. Maybe the last commit resolved Calc issues, but for Writer it made it worse. So I filed a new bug with this.
I noticed that in the context help text that this borders options apply to Writer and Calc.




User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Robert Gonzalez MX 2018-03-24 23:25:53 UTC
Created attachment 140866 [details]
Test file and screenshots
Comment 2 Robert Gonzalez MX 2018-03-24 23:26:45 UTC
Created attachment 140867 [details]
Test file from bug 89604
Comment 3 V Stuart Foote 2018-03-25 15:18:37 UTC
The sample documents work correctly in current master/6.1.0, as do samples from bug 89604 and bug 81643--corrected by refactoring done for bug 114934

*** This bug has been marked as a duplicate of bug 81643 ***