Download it now!
Bug 116679 - All modules crash in Format > Character, or opening Print dialog (Crash in: RC96E100.DLL driver) with RICOH RPCS Printer selected for use (comment 14 for workaround)
Summary: All modules crash in Format > Character, or opening Print dialog (Crash in: R...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: IA64 (Itanium) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsRicohNetworkPrinter
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-28 10:00 UTC by Leo
Modified: 2020-04-14 17:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["RC96E100.DLL"]


Attachments
BT without symbols (5.92 KB, text/plain)
2018-03-28 15:06 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leo 2018-03-28 10:00:20 UTC
This is 100% reproducible on my PC by doing just the action:
Format > Character

Happens on any file, even a clean new Impress presentation.

I upgraded today to 5.4.6.2. My previous version was 5.4.5, and had the same issue (hence my upgrading...)


This bug was filed from the crash reporting server and is br-a7e31d6f-dc60-4d40-b4f7-487147ea5672.
=========================================
Comment 1 Xisco Faulí 2018-03-28 10:08:28 UTC
Thank you for reporting the bug.

I can't reproduce it in

Versión: 6.0.1.1
Id. de compilación: 60bfb1526849283ce2491346ed2aa51c465abfe6
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

Could you please try to reproduce it with version 6.0.2 of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Leo 2018-03-28 11:01:25 UTC
Hi Xisco, thanks for your quick reply.

I've just updated to 6.0.2, but the problem is still there.

This is the 'About' info:
Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: nl-BE (en_US); Calc: group

After the crash I get a 'LibreOffice has stopped working' popup, with the option to debug, and when I click that it states 'An unhandled win32 exception occurred in soffice.bin [12056]' and offers to open VS2017 as debugger.

But when I then open it, VS says that the project type is unsupported.

I can still click 'OK' then, and get a little more information on the next screen:

Version: 7.0.16299.125 (WinBuild.160101.0800)
Original Location: C:\Windows\System32\msvcrt.dll
...
Unhandled exception at 0x00007FF9242030DA (msvcrt.dll) in soffice.bin: 0xC000041D: An unhandled exception was encountered during a user callback. 

I can also get the call stack:
msvcrt.dll!00007ff9242030da()
RC96E100.DLL!00000000004fbe0a()
RC96E100.DLL!00000000004fba02()
RC96E100.DLL!00000000004fb018()
RC96E100.DLL!00000000005390d8()
gdi32full.dll!00007ff922a10beb()
user32.dll!00007ff924548c3a()
ntdll.dll!00007ff926673b54()
win32u.dll!00007ff922b72a24()
gdi32full.dll!00007ff922a0c891()
gdi32.dll!00007ff925133f63()
gdi32.dll!00007ff92513509a()
mergedlo.dll!00007ff8d9eac4b2()
mergedlo.dll!00007ff8d9eac646()
mergedlo.dll!00007ff8d9eab845()
mergedlo.dll!00007ff8d9d6022d()
mergedlo.dll!00007ff8d9d5d45e()
mergedlo.dll!00007ff8d9070191()
mergedlo.dll!00007ff8d91fcc92()
mergedlo.dll!00007ff8d91fba1a()
mergedlo.dll!00007ff8d91fb771()
mergedlo.dll!00007ff8d91ffc0e()
mergedlo.dll!00007ff8d9aa95b1()
mergedlo.dll!00007ff8d9aa6aa0()
mergedlo.dll!00007ff8d9aa4ac7()
mergedlo.dll!00007ff8d9aa33a1()
mergedlo.dll!00007ff8d9aa4b1d()
mergedlo.dll!00007ff8d9aa33a1()
mergedlo.dll!00007ff8d9aa4b1d()
mergedlo.dll!00007ff8d9aa33a1()
mergedlo.dll!00007ff8d9a8c9cf()
mergedlo.dll!00007ff8d9b2c39f()
mergedlo.dll!00007ff8d8c59f7f()
cuilo.dll!00007ff8dd1c6c6f()
cuilo.dll!00007ff8dd1c5b61()
cuilo.dll!00007ff8dd1ca47b()
mergedlo.dll!00007ff8d8c5b4b9()
mergedlo.dll!00007ff8d9bd3614()
mergedlo.dll!00007ff8d9bcb9fb()
mergedlo.dll!00007ff8d9b4b940()
mergedlo.dll!00007ff8d9b4b64e()
mergedlo.dll!00007ff8d9ade4a1()
mergedlo.dll!00007ff8d9ae2bcb()
mergedlo.dll!00007ff8d9ada6ea()
mergedlo.dll!00007ff8d9ae50dd()
mergedlo.dll!00007ff8d9b28df2()
mergedlo.dll!00007ff8d9db30ea()
mergedlo.dll!00007ff8d9e92d00()
mergedlo.dll!00007ff8d9e8f6b0()
mergedlo.dll!00007ff8d9e8f14b()
mergedlo.dll!00007ff8d9dc6c83()
mergedlo.dll!00007ff8d9ab307e()
mergedlo.dll!00007ff8d92f879f()
mergedlo.dll!00007ff8d92f823f()
mergedlo.dll!00007ff8d8e0ec21()
mergedlo.dll!00007ff8d8e06553()
mergedlo.dll!00007ff8d9dcdf8c()
sal3.dll!00007ff91d70a66b()
sal3.dll!00007ff91d742ef9()
KernelBase.dll!00007ff922f195a0()
ntdll.dll!00007ff9266a23a1()
ntdll.dll!00007ff926673ac0()
ntdll.dll!00007ff926674c7d()
ntdll.dll!00007ff9265ed1d8()
ntdll.dll!00007ff926673bae()
msvcrt.dll!00007ff9242030da()
RC96E100.DLL!00000000004fbe0a()
RC96E100.DLL!00000000004fba02()
RC96E100.DLL!00000000004fb018()
RC96E100.DLL!00000000005390d8()
gdi32full.dll!00007ff922a10beb()
user32.dll!00007ff924548c3a()
ntdll.dll!00007ff926673b54()
win32u.dll!00007ff922b72a24()
gdi32full.dll!00007ff922a0c891()
gdi32.dll!00007ff925133f63()
gdi32.dll!00007ff92513509a()
mergedlo.dll!00007ff8d9eac4b2()
mergedlo.dll!00007ff8d9eac646()
mergedlo.dll!00007ff8d9eab845()
mergedlo.dll!00007ff8d9d6022d()
mergedlo.dll!00007ff8d9d5d45e()
mergedlo.dll!00007ff8d9070191()
mergedlo.dll!00007ff8d91fcc92()
mergedlo.dll!00007ff8d91fba1a()
mergedlo.dll!00007ff8d91fb771()
mergedlo.dll!00007ff8d91ffc0e()
mergedlo.dll!00007ff8d9aa95b1()
mergedlo.dll!00007ff8d9aa6aa0()
mergedlo.dll!00007ff8d9aa4ac7()
mergedlo.dll!00007ff8d9aa33a1()
mergedlo.dll!00007ff8d9aa4b1d()
mergedlo.dll!00007ff8d9aa33a1()
mergedlo.dll!00007ff8d9aa4b1d()
mergedlo.dll!00007ff8d9aa33a1()
mergedlo.dll!00007ff8d9a8c9cf()
mergedlo.dll!00007ff8d9b2c39f()
mergedlo.dll!00007ff8d8c59f7f()
cuilo.dll!00007ff8dd1c6c6f()
cuilo.dll!00007ff8dd1c5b61()
cuilo.dll!00007ff8dd1ca47b()
mergedlo.dll!00007ff8d8c5b4b9()
mergedlo.dll!00007ff8d8c5e119()
mergedlo.dll!00007ff8d8c5c274()
sdlo.dll!00007ff8ddba513e()
sdlo.dll!00007ff8ddba4f0d()
sdlo.dll!00007ff8ddd6ca11()
mergedlo.dll!00007ff8d8ba7c6a()
mergedlo.dll!00007ff8d8bab9ba()
mergedlo.dll!00007ff8d8d64061()
mergedlo.dll!00007ff8d9b64f07()
mergedlo.dll!00007ff8d9ebe30f()
mergedlo.dll!00007ff8d9ec13d1()
mergedlo.dll!00007ff8d9ec1940()
user32.dll!00007ff92452b85d()
user32.dll!00007ff92452b1ef()
mergedlo.dll!00007ff8d9e8f612()
mergedlo.dll!00007ff8d9e8f14b()
mergedlo.dll!00007ff8d9dc5581()
mergedlo.dll!00007ff8d8e0924f()
mergedlo.dll!00007ff8d9dcd97e()
mergedlo.dll!00007ff8d9dcde62()
mergedlo.dll!00007ff8d8e26fa7()
soffice.bin!00007ff6fad8102e()
soffice.bin!00007ff6fad81317()
kernel32.dll!00007ff923dd1fe4()
ntdll.dll!00007ff92663efc1()
Comment 3 Telesto 2018-03-28 13:20:03 UTC
RC96E100.DLL -> RICOH RPCS Printer Driver. A driver update might do the trick (if available of course)
Comment 4 Xisco Faulí 2018-03-28 14:02:06 UTC
(In reply to Telesto from comment #3)
> RC96E100.DLL -> RICOH RPCS Printer Driver. A driver update might do the
> trick (if available of course)

I don't understand why it would need the printer driver to display the format dialog...
Comment 5 Xisco Faulí 2018-03-28 14:02:35 UTC
@Leo, to be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 6 Leo 2018-03-28 14:55:38 UTC
@Xisco, resetting my user profile didn't make a difference. I deleted C:\Users\Leo\AppData\Roaming\LibreOffice\4, restarted LibreOffice to let it create a new user profile, but the result was the same. Also when running in safe mode the crash happens.

@Telesto, that is a driver for a shared office printer, which I've recently managed to get working after much trouble and much time spent. The fact that I'm now getting these crashes could indeed indicate a correlation, but seeing the amount of effort and time I've spent to get this driver working I'd rather not start meddling with it unless there is really no other way. After all, the printer is now working OK for me and it's LibreOffice that crashes...
Comment 7 Telesto 2018-03-28 15:06:47 UTC
Created attachment 140943 [details]
BT without symbols

(In reply to Xisco Faulí from comment #4)
> (In reply to Telesto from comment #3)
> > RC96E100.DLL -> RICOH RPCS Printer Driver. A driver update might do the
> > trick (if available of course)
> 
> I don't understand why it would need the printer driver to display the
> format dialog...

It's checks the for printers for some (dubious) reason.. BT from Process Monitor. Format -> Character

I have seen more bug reports related to network printers (mostly crashing after a print jobs). Might be related..
Comment 8 V Stuart Foote 2018-03-28 23:58:10 UTC
@Leo, check in appwiz.cpl -> "Turn Windows Features on or off" to see if SMB 1.0/CIFS File Sharing and SMB 1.0/CIFS client have been unchecked. This security change in Windows 10 disrupts some of the network printer configurations.
Comment 9 Leo 2018-03-29 06:12:53 UTC Comment hidden (obsolete)
Comment 10 Leo 2018-04-09 14:08:38 UTC
Back from vacation :-)

@Stuart, I've checked my windows features settings. "SMB 1.0/CIFS Automatic Removal" and "SMB 1.0/CIFS Server" were checked, "SMB 1.0/CIFS Client" was unchecked.

I unchecked all under SMB 1.0/CIFS File Sharing and rebooted, but it still crashes in the same way.
Comment 11 V Stuart Foote 2018-04-09 14:44:38 UTC
(In reply to Leo from comment #10)
> Back from vacation :-)
> 
> @Stuart, I've checked my windows features settings. "SMB 1.0/CIFS Automatic
> Removal" and "SMB 1.0/CIFS Server" were checked, "SMB 1.0/CIFS Client" was
> unchecked.
> 
> I unchecked all under SMB 1.0/CIFS File Sharing and rebooted, but it still
> crashes in the same way.

Hate to send you down that rabbit hole, but the SMB 1.0/CIFS Client would need to be checked enabled.

Otherwise there is bug 115649 -- could dupe to that, so check a current 6.0.3.2 release build, or current master/6.1.0 which have been patched.

=-ref-=
daily 64-bit
https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/

release build archive
http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 12 Leo 2018-04-11 07:01:05 UTC
I've upgraded to 6.0.3.2 (I rely on LibreOffice for my productivity, so unless strictly required I prefer to stay away from dev builds), but even with SMB 1.0/CIFS Client enabled I still get the same crash each time.

In fact I've tried all logical combinations -- 8 in total --  of the three check boxes under SMB 1.0/CIFS File Sharing Support, rebooted after each change, but I still get the crash.
Comment 13 V Stuart Foote 2018-04-11 15:05:51 UTC
(In reply to Leo from comment #12)
> with SMB 1.0/CIFS Client enabled I still get the same crash each time.
> 
OK, thanks for poking at that potential source of instability.

Are your Windows user profiles setting the Ricoh network printer as default?

Does the crash happen with the other LibreOffice modules or just Impress?

Does the crash happen if you set a different Default printer (so document gets created with no linkage to the Ricoh printer)?

=-ref-=
Breakpad crash dump reports on that signature for both OpenGL and default rendering
https://crashreport.libreoffice.org/stats/signature/RC96E100.DLL
Comment 14 Leo 2018-04-13 13:43:26 UTC
In the other LibreOffice modules I get the same crash when I try to open the Format>Character dialog. Also when opening the Print dialog it crashes immediately.

The setting I had was 'Let Windows manage my default printer', meaning that it picks the one most recently used.

After setting a different default printer the crash no longer happens when I open the Format>Character or Print dialog (yeah!). But when I then select the Ricoh printer it crashes again...

At least I can continue editing documents -- I just cannot print them here in the office, unless I first export to PDF and then print the PDF.

So it's quite obvious now that the problem is caused by the Ricoh printer driver. What do you recommend? I'm a bit reluctant to try a different driver because I've had to spent a lot of time to get it working (we're in a shared office, and the printer driver was provided by the office management, but otherwise not much support). Besides it works OK for other applications. 

Long shot: I use Visual Studio for .NET development, but I think that I can also build and debug C/C++, so I could try to download the source code and try to reproduce the exception in the debugger...
Comment 15 V Stuart Foote 2018-04-13 14:13:03 UTC
(In reply to Leo from comment #14)

> So it's quite obvious now that the problem is caused by the Ricoh printer
> driver. What do you recommend? I'm a bit reluctant to try a different driver
> because I've had to spent a lot of time to get it working (we're in a shared
> office, and the printer driver was provided by the office management, but
> otherwise not much support). Besides it works OK for other applications. 
> 

I would probably give up on the printer specific driver, and at least check a current "Universal Print" driver. Ricoh has fairly active support page, and PCL6 and PS driver packages for Windows 10, 8.1, 7 both 64-bit and 32-bit.

http://support.ricoh.com/bb/html/dr_ut_e/rc3/model/p_i/p_i.htm?lang=en

Larger projects (e.g. for Autodesk, Adobe) have been able to get custom driver work done, but I think LibreOffice is going to be left hanging. Of course, it also depends on how old the printer in question is.


> Long shot: I use Visual Studio for .NET development, but I think that I can
> also build and debug C/C++, so I could try to download the source code and
> try to reproduce the exception in the debugger...

Possibly, but a lot of work and you still may end up with the same non-helpful pointers into the Ricoh drivers DLL.  Without symbols from Ricoh don't think you'll get anything helpful. If you look at the URL linked in comment 13 any of the reports there will have a breakpad delivered stack trace annotated from LibreOffice and Microsoft debug symbols. The missing piece is the Ricoh code.
Comment 16 V Stuart Foote 2018-04-19 13:39:16 UTC
To NEW per duplicates in crashreport.libreoffice.org
Comment 17 V Stuart Foote 2018-04-19 13:55:33 UTC
Specific issues of bug 115649 not the case here as OP reports 6.0.3.2 build with that patch still crashes--but could be something similar.

@Mike K, plenty of traces in crash reporter--any advice for OP here?
Comment 18 Mike Kaganski 2018-04-20 21:02:38 UTC
The bits "printer driver problem" and "unhandled exception was encountered during a user callback" suggest something very close to that bug 115649 - but of course not the same: some other callback needs love.

I appreciate all the efforts Leo have already done here; but we need some (hopefully last) bit of information: the same thing that helped us to find and fix bug 115649 - a minidump. Could you please use procdump from SysInternals to get the soffice.bin minidump and post it here? Thank you!
Comment 19 QA Administrators 2019-06-15 02:59:00 UTC Comment hidden (obsolete)
Comment 20 Julien Nabet 2020-04-14 13:55:14 UTC
Following last Mike's comment, let's put this one to NEEDINFO?

Also, you can give a try to 6.3.5 or last 6.4.2
Comment 21 Leo 2020-04-14 16:17:41 UTC
Hi All,

I seem to have missed the notification of the update last year. Sorry for that. 

Anyway, we've moved over a year ago to a new office, so me and the dreaded Ricoh printer driver haven't crossed paths for a long while. I've checked my different PCs, but I don't have that driver installed anymore. So I'm afraid I can't help you with reproducing this bug.

So I guess this ticket can be closed.

Thanks anyway for following up.

Regards,
Leo
Comment 22 Julien Nabet 2020-04-14 17:19:44 UTC
Thank you for your feedback.
Let's put this one to WFM then