Bug 115649 - 64-bit Writer v.6.0.1.1 crashes every time I send an older file to network printer after clicking OK to print (ucrtbase.dll)
Summary: 64-bit Writer v.6.0.1.1 crashes every time I send an older file to network pr...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords: regression
: 116398 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-12 11:19 UTC by Tyr Antilles
Modified: 2018-08-17 14:45 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
msinfo32 output als attachment (85.77 KB, application/x-zip-compressed)
2018-03-02 21:00 UTC, t34
Details
Crash Dump (procdump) (1.02 MB, application/x-zip-compressed)
2018-03-09 21:46 UTC, Klaasklever
Details
procdump and file that caused it (772.16 KB, application/zip)
2018-03-10 12:56 UTC, Gregor Kopka
Details
Procdump crashes just after LO6 crashes (299.28 KB, image/png)
2018-03-13 08:23 UTC, Tyr Antilles
Details
Also, when I was setting the printer, Procdump reported the following: (239.78 KB, image/png)
2018-03-13 08:37 UTC, Tyr Antilles
Details
Print successfully (200.26 KB, image/png)
2018-03-14 06:52 UTC, Tyr Antilles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tyr Antilles 2018-02-12 11:19:35 UTC
Description:
When I try to print from Writer LibreOffice v.6.0.1.1 crashes, but the file prints correctly. This happen with all documents every time I try to print. I only tried this with Writer, but probably other componets have the same problem. I am running Windows 7 x64.

Solution: I uninstalled LibreOffice v.6.0.1.1 and installed back LibreOffice v.5.4.5.1. Print work perfect with the older version, so, is clearly a problem with 6.0.1.1.

Steps to Reproduce:
1.Open print menu
2.Select printer
3.Click OK to print
4.Wait for the file to be sent to printer

Actual Results:  
LibreOffice v.6.0.1.1 crashes, but the file prints correctly.

Expected Results:
To not crash


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.17
Comment 1 Julien Nabet 2018-02-12 20:36:07 UTC
Any chance to have a crashreport or a backtrace?

Just for the test, do you reproduce this with OpenGL disabled?
(see https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.28OpenGL.29)
If you don't reproduce this with OpenGL disabled, could you please attach <user profile>/cache/opengl_device.log ?
Comment 2 Tyr Antilles 2018-02-13 08:32:32 UTC
- LibreOffice v.6.0.1.1 was installed clean, with all settings default. By default at Graphics Output three settings are checked: Hardware accel, anti-alising and OpenGL. It looks like it crashes regardeless if I use OpenGL or not. I do not know where to find another crashreport or a backtrace.

- Here are cache and crash folders from c:\Users\<my user>\AppData\Roaming\LibreOffice\4\
Hardware accel, anti-alising and OpenGL = all enabled

cache\opengl_device.log

DriverVersion: 8.15.10.2696
DriverDate: 3-19-2012
DeviceID: PCI\VEN_8086&DEV_0102&SUBSYS_D0001458&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0102
AdapterSubsysID: 0xd0001458
DeviceKey: System\CurrentControlSet\Control\Video\{69D29FBA-05BF-4B34-B10D-7733541EAA43}\0000
DeviceString: Intel(R) HD Graphics 


crash\dump.ini

ProductName=LibreOffice
Version=6.0.1.1
BuildID=60bfb1526849283ce2491346ed2aa51c465abfe6
URL=https://crashreport.libreoffice.org/submit/
OpenGLDevice=0x0102
OpenGLDriver=8.15.10.2696
OpenGLVendor=0x8086
UseOpenGL=false
Language=en-US

Strange, it says UseOpenGL=false even if is enabled in settings. In Options window it says GL is currently disabled.


- Next I enabled GL clicking on "Ignore OpenGL blacklist". After restart it says GL is currently enabled. Here is other bug because after I forcefully enabled GL, some of the icons in Libre Office Writer becomes square black.
- Time to try to print again....and a new crash.

crash\dump.ini

ProductName=LibreOffice
Version=6.0.1.1
BuildID=60bfb1526849283ce2491346ed2aa51c465abfe6
URL=https://crashreport.libreoffice.org/submit/
OpenGLDevice=0x0102
OpenGLDriver=8.15.10.2696
OpenGLVendor=0x8086
UseOpenGL=true
Language=en-US

Every time it prints the jobs correctly, but still crashes after that. No idea what to do next except revert to the older version.
Comment 3 Xisco Faulí 2018-02-14 09:48:33 UTC
Hi Tyr,
Do you get any crashreport when LibreOffice crashes?

OTOT, to be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 4 Tyr Antilles 2018-02-15 08:22:05 UTC
Thank you for answers.
No, I do not get any crashreport. How can I enable this? After print, it appears the classic window "LibreOffice has stopped working" and the only option I have is "Close the program".

I am sure is no corruption in the user profile because I installed LibreOffice v.6.0.1.1 clean => that means I uninstalled the old version then manually delete old LibreOffice folders:
c:\Users\<my user>\AppData\Roaming\LibreOffice
c:\Program Files\LibreOffice\
Only after that I installed LibreOffice v.6.0.1.1

I also did the safe mode thing as instructed and re-tested: same crash even from safe mode.
Comment 5 Tyr Antilles 2018-02-19 11:57:39 UTC
Update: I installed one more printer and two virtual printers to test this issue further. No problems on those printers when I print from LibreOffice v.6.0.1.1. But on my main printer (Xerox AltaLink B8055 PS) the problem persists.
It is probably a badly optimized driver, but strange thing is that from all other programs including older versions of LibreOffice, print works without glitches. Only LibreOffice v.6.0.1.1 seems to crash every time on Xerox AltaLink B8055 PS. Strange.
Comment 6 Xisco Faulí 2018-02-21 23:28:35 UTC
Could you please follow the instructions provided at this link < https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg > and submit a backtrace ? That way a developer can look into the underlying reason of the crash.
Comment 7 Tyr Antilles 2018-02-22 13:55:47 UTC
I am sorry. I cannot install those tools of this computer. Hopefully is either, an isolate issue that will not affect someone else, or if is not, maybe someone else affected can do the debug thing.
Comment 8 Timur 2018-02-22 14:04:40 UTC
If you cannot install WinDBG you may use procdump portable tool from Sysinternals.
path-to\procdump.exe soffice.bin -h path-to\soffice.bin.dmp
Comment 9 t34 2018-02-22 18:24:51 UTC
Similar probleme here with

LibreOffice v.6.0.1.1
Windows 7 32bit german version
Printer: Kyocera FS920
Driver: KX Driver v6.3.0909 connected to a network printer (via FRITZ!Box)

The document is printed correct but LibreOffice freezes and i have to kill it via task manager.

Everything is fine with 5.4.5
Comment 10 Tyr Antilles 2018-02-23 10:43:26 UTC
I tried to use Procdump to track the problem but I didn't succeed. I never got any dump files after the crash. My knowledge of command line programs is very limited and programming knowledge is close to 0.
Other thing: it seems the only module affected is WRITER because I printed from Calc and Draw of LibreOffice v.6.0.1.1 with success.
Comment 11 Tyr Antilles 2018-02-23 11:28:15 UTC
Things are getting even more complicated. If I create a new file with very simple text (sometimes) it prints without crash. If I insert a photo on it and save the file, it crashes. But usually it crashes on simple text too.

Here is a screen recording with the problem: https://1drv.ms/v/s!AqtI3rSJQnG_kidcWwh85RSm6Q_D
Comment 12 Timur 2018-02-23 11:59:32 UTC Comment hidden (obsolete)
Comment 13 Timur 2018-02-23 12:46:29 UTC
Spoke too soon. I don't repro crash printing to network printer with 32-bit master 6.1+ and 6.0.1.1 but I DO with 64-bit master and 6.0.1.1.
Please confirm you also have 64-bit LO.
Comment 14 Timur 2018-02-23 12:50:40 UTC
I tested with attachment 81320 [details].
Comment 15 Tyr Antilles 2018-02-23 17:32:43 UTC
Yes, on that computer with network printer I have 64 bit LibreOffice as well as 64 bit Windows 7. I won't have access on it till Monday. Then I can do more tests. I will take down the attachment from above now too.
Comment 16 Kurt Hoffmann - von Mörs 2018-02-26 15:13:21 UTC
Setting / Load / Save / General Point: Load printer settings with the document when this item is activated the Writer crashes in version 6.0.1.1 (x64) (print labels with pictures)

Einstellung / Laden/Speichern / Allgemein Punkt: Drucker-Einstellungen mit dem Dolkument laden, wenn dieser Punkt aktiviviert ist stürzt der Writer in der Version 6.0.1.1 (x64) ab (Druck Etiketten mit Bildern)
Comment 17 Timur 2018-02-28 14:13:06 UTC
No idea why this happens, but I see ucrtbase.dll in Bug 108580.
Comment 18 V Stuart Foote 2018-02-28 14:32:59 UTC
(In reply to Tyr Antilles from comment #2)
...
> 
> DriverVersion: 8.15.10.2696
> DriverDate: 3-19-2012
> DeviceID: PCI\VEN_8086&DEV_0102&SUBSYS_D0001458&REV_09
> AdapterVendorID: 0x8086
> AdapterDeviceID: 0x0102
> AdapterSubsysID: 0xd0001458
> DeviceKey:
> System\CurrentControlSet\Control\Video\{69D29FBA-05BF-4B34-B10D-
> 7733541EAA43}\0000
> DeviceString: Intel(R) HD Graphics 
> 
...

Please post the top lines of the summary page from a run of msinfo32--need the Windows details

Also the 2696 build Graphcis driver _is_ going to cause issues. Current for your Sandy Bridge Intel HD Graphics 2000 on Windows 7 is 4229 -- fix any OS dependencies needed to install that, and retest.
Comment 19 Timur 2018-02-28 18:02:36 UTC
Here is mine Windows 7 64-bit, looks also 2nd generation processor Intel HD 2000: 
DriverVersion: 9.17.10.3517
DriverDate: 3-20-2014
DeviceID: PCI\VEN_8086&DEV_0102&SUBSYS_047E1028&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0102
AdapterSubsysID: 0x047e1028
DeviceKey: System\CurrentControlSet\Control\Video\{5F57C8A2-4E34-49D3-99DA-F165CA9BF8F8}\0000
DeviceString: Intel(R) HD Graphics

which I updated from https://www.intel.com/content/www/us/en/support/products/80939/graphics-drivers.html:
DriverVersion: 9.17.10.4229
DriverDate: 5-26-2015
DeviceID: PCI\VEN_8086&DEV_0102&SUBSYS_047E1028&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0102
AdapterSubsysID: 0x047e1028
DeviceKey: System\CurrentControlSet\Control\Video\{5F57C8A2-4E34-49D3-99DA-F165CA9BF8F8}\0000
DeviceString: Intel(R) HD Graphics

And I don't repro bug now.
Comment 20 Xisco Faulí 2018-03-01 10:01:32 UTC Comment hidden (obsolete)
Comment 21 Tyr Antilles 2018-03-01 18:25:33 UTC Comment hidden (obsolete)
Comment 22 Tyr Antilles 2018-03-02 08:24:40 UTC
- The relevant lines of the summary page from a run of msinfo32 for Windows details:

System Information report written at: 03/02/18 08:44:26
[System Summary]
OS Name	Microsoft Windows 7 Home Premium	
Version	6.1.7601 Service Pack 1 Build 7601	
System Manufacturer	Gigabyte Tecohnology Co., Ltd.	
System Model	H61M-DS2	
System Type	x64-based PC	
Processor	Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz, 3300 Mhz, 2 Core(s), 4 Logical Processor(s)	
BIOS Version/Date	American Megatrends Inc. F4, 2011.12.21	
SMBIOS Version	2.7	
Hardware Abstraction Layer	Version = "6.1.7601.24024"	
Installed Physical Memory (RAM)	4.00 GB	
Total Physical Memory	3.90 GB	
Available Physical Memory	2.02 GB	
Total Virtual Memory	7.89 GB	
Available Virtual Memory	5.93 GB	
Page File Space	4.00 GB	
Page File	C:\pagefile.sys


- I have updated my video driver from the old(= DriverVersion: 8.15.10.2696 DriverDate: 3-19-2012) to the new(= DriverVersion: 9.17.10.4229 DriverDate: 5-26-2015)

Computer restarted and... I got the same crash at the next print on the network printer. File printed correctly as usual.  :(
Comment 23 Timur 2018-03-02 10:50:52 UTC
May not be related, but my Visual C++ redistributable is 14.0.23026. 
Tyr, can you please test with both vcredist_2015upd2 and vcredist_2015upd3?
And see whether Bug 42673 is related.
Comment 24 Tyr Antilles 2018-03-02 13:25:05 UTC Comment hidden (obsolete)
Comment 25 t34 2018-03-02 21:00:37 UTC
Created attachment 140298 [details]
msinfo32 output als attachment

I install LO 6.0.2.1 (32bit) and redistributable 2015upd3 and redistributable 2017 but the problem still exist.

Problemsignatur:
  Problemereignisname:	APPCRASH
  Anwendungsname:	soffice.bin
  Anwendungsversion:	6.0.2.1
  Anwendungszeitstempel:	5a90808c
  Fehlermodulname:	ucrtbase.DLL
  Fehlermodulversion:	10.0.10586.1171
  Fehlermodulzeitstempel:	59ae5046
  Ausnahmecode:	40000015
  Ausnahmeoffset:	000846fa
  Betriebsystemversion:	6.1.7601.2.1.0.768.3
  Gebietsschema-ID:	1031
  Zusatzinformation 1:	8379
  Zusatzinformation 2:	8379e785032335032d2770be032d4a42
  Zusatzinformation 3:	ae19
  Zusatzinformation 4:	ae19bb907d810a11e01b34374a8edad6

msinfo32 output als attachment
Comment 26 t34 2018-03-02 21:11:38 UTC
I deactivate the checkbox from comment #16 (Drucker-Einstellungen mit dem Dokument laden) and my printing problems are gone.
Comment 27 Tyr Antilles 2018-03-05 08:19:03 UTC
- I tried to disable the option "Load printer settings with the document" with no effect on Writer v.6.0.1.1 x64 (tools > options > Load/Save > General > Load printer settings with the document). Crash at print on network printer still happen.

- I installed the newer version LibreOffice v.6.0.2.1 x64. Crash still happen.

- I checked and I see I have installed multiple versions of Microsoft Visual C++ Redistributable, 2008, 2010, with the most recent being 2015 14.0.24215.

- Tried to install "Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.24123 Update 3 RC" but install failed because it says I have already a newer version.

- I installed the newest version "Microsoft Visual C++ 2017 Redistributable (x64) - 14.12.25810" and test print again: crash still happen no matter what settings I try.

- I checked Bug 42673 and I have indeed several offline network printers on my Windows Devices and Printers. But my LibreOffice doesn't hang at all, only at print it crashes. I removed these offline printers and tried again, but crash after print still happen every time on Writer v.6.0.2.1 x64.
Comment 28 Julien Nabet 2018-03-05 09:00:46 UTC
First thing, could you clean your Windows registry with a free Windows registry cleaner? (eg: Glary utilities, there's also ccleaner but some versions of it were corrupted).
Indeed, if it's linked to ucrtbase.dll, perhaps there are pb of multiple referenced versions in Win registry.

Also, reading https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/gpupdate-causes-word-2016-to-crash/1a672a6c-3ee5-4237-a61e-3cc89d667644, would it be possible you uninstall and reinstall last printer driver?
Comment 29 Tyr Antilles 2018-03-06 14:01:15 UTC
- I had cleaned registry with the latest version oc CCleaner = no effect.

- GPUpdate =? I saw the article but I fail to see the connection with LibreOffice 6 vs 5.

- I updated the printer driver several days ago hoping the latest version will solve this problem, but it didn't. As I said in the beginning, in LibreOffice v.5.4.5.1 and all other programs, print works without glitches. Only LibreOffice 6 crash after the file is printed correctly. It must be something changed between LO5 and LO6.
Comment 30 Timur 2018-03-06 16:36:02 UTC
We may had different issues here. 
Do you have https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows?
Comment 31 Tyr Antilles 2018-03-06 19:53:35 UTC
I suppose it does. My Win7 x64 machine is updated automatically with Windows update. I will check tomorrow though.
Comment 32 Tyr Antilles 2018-03-07 06:19:55 UTC
- I installed the update you pointed Windows6.1-KB2999226-x64.msu and no effect. It still crashes.
Comment 33 Mike Kaganski 2018-03-07 06:31:49 UTC
(In reply to Tyr Antilles from comment #32)

Thank you for your dedication in this issue!

Unfortunately, the only thing that might help us here is to get a backtrace. I understand that you said in comment 7, that installing tools for getting them on affected systems is not an option. But you didn't say if suggestion in comment 8 fits you. Could you evaluate that? or try to reproduce this with some system specifically created for testing this (so that you could install the debug software)?

The problem indeed exists; it is reported on AkLibO site as well (https://ask.libreoffice.org/en/question/146161/libreoffice-6-writer-crashing-on-print/ - mentioning it here for completeness); so reproducing it in an environment that allows us to track it down and fix would be great help. Thank you again for your persistence!
Comment 34 Klaasklever 2018-03-08 17:34:28 UTC
Same problem here,

*older* LO documents lead to LO crashing very often when files are printed.

The issue does NOT occur with fresh documents created with LO 6.0.x.

Exactly the same issue as described by Tyr Antilles.
The problems started to occur with LO 6.0.x.

I did not have any problems whatsoever with LO 5.4.x., so this
is clearly a regression.

Right now I am using LO 6.0.2.1 (64 bit!) with Windows 10 v1709.

I have created a FRESH user profile - that does NOT help!

I have tried to uncheck "Load printer settings with the document" -
that does NOT help either.

This issue is driving me nuts. It renders LO 6.0.x pretty much
unusable at the moment. A real showstopper bug for me.
Comment 35 Klaasklever 2018-03-08 17:41:12 UTC
By the way, I'm using a Kyocera color laser printer
(FS-C5350DN) that is attached locally via USB and uses
a fairly recent Kyocera KX Driver 7.2.0731.

Disabling OpenGL does not help. I tried it with OpenGL on and off,
does not make any difference. Same crash.

Maybe only the x64 Version is affected ?
Comment 36 Timur 2018-03-09 12:46:28 UTC
(In reply to Klaasklever from comment #35)
> Maybe only the x64 Version is affected ?
That's what we found out earlier and it's in the title. I update now with "an older file". 
Please try to get a backtrace per Comment 8 with free and portable "procdump".
Comment 37 Tyr Antilles 2018-03-09 14:51:50 UTC
(In reply to Mike Kaganski from comment #33)
I am the one to thank for the great software that LibreOffice is. I tried to use procdump portable to create a dump, but I didn't succeed, as I posted on Comment 10.
I will try Monday to see it will be a way to get a backtrace, but I am afraid my skills in doing those things are very limited.
Comment 38 Klaasklever 2018-03-09 21:46:26 UTC
Created attachment 140525 [details]
Crash Dump (procdump)

I have managed to create a crash dump
as instructed. Hope this helps.

I had to use the -e parameter with procdump
to get this dump. An unhandled exception
occured on printing ("Unhandled: C0000409" in procdump's
output) and the dump was created.
Comment 39 Klaasklever 2018-03-09 21:55:25 UTC
@ Tyr Antilles:

The command line I used with the portable Procdump utility:

procdump64 soffice.bin -e c:\download\soffice.bin.dmp

The -h parameter did not work for me either. I had to use -e.
Comment 40 Gregor Kopka 2018-03-10 12:56:44 UTC
Created attachment 140543 [details]
procdump and file that caused it

Same issue with printing old files (possibly created with OpenOffice back then) using 6.0.1.1 (x64) on Win7x64 to a Kyocera P2035d.

It seems that changing the text in the documents itself dosn't change anything:
I was able to replace the full text with 'x' in the attached .odt and the file still crashes reproduceable, but deleting the characters (without modifying the paragraph structure) made the crash on print go away.

Also I noticed in my tests that crash seems to be driver specific:
In case I use the driver

==> Kyocera ECOSYS p2035d
driver: UNIDRV.DLL
file version: 0.3.7601.17514
product name: MS Windows Operating System
product version: 6.1.7601.17514
date: 20.11.2010 14:27

it works without problem (with all files I tested with, incl. the one in the attachment), but with with the driver

==> Kyocera ECOSYS p2035d KX
driver: KMUC60XN.DLL
file version: 0.3.0.0
product name: KYOCERA Printing System
product version: 5, 0, 0, 0
date: 24.09.2013 02:44

soffice.bin crashes reproduceable after spooling to the printer.

Attached dump taken with procdump.exe soffice.bin -h soffice.dmp
I hope any of this helps in fixing this.
Comment 41 Mike Kaganski 2018-03-10 17:33:20 UTC
The crashdump (attachment 140525 [details]) from comment 38 has this call stack:

> ucrtbase.dll!abort()
> mergedlo.dll!comphelper::GenericSolarMutex::doRelease(bool bUnlockAll) Line 72
> mergedlo.dll!SalYieldMutex::doRelease(bool bUnlockAll) Line 177
> [Inline Frame] mergedlo.dll!SolarMutexReleaser::{ctor}() Line 1473
> mergedlo.dll!WinSalInstance::DoYield(bool bWait, bool bHandleAllCurrentEvents) Line 550
> mergedlo.dll!ImplYield(bool i_bWait, bool i_bAllEvents) Line 469
> mergedlo.dll!SalPrintAbortProc(HDC__ * hPrnDC, int __formal) Line 1308
> gdi32full.dll!vSAPCallback()
> gdi32full.dll!ExtEscapeImpl()
> gdi32.dll!ExtEscape()
> [Frames may be missing, no binary loaded for KMUU727V.DLL]
> KMUU727V.DLL!0000000011d0dc21()

It apparently tries to release solar mutex it doesn't own.
Jan-Marek: could you please take a look? don't you have an idea what could change recently here?
Comment 42 Mike Kaganski 2018-03-10 17:50:52 UTC
A blind fix is https://gerrit.libreoffice.org/51052.
Comment 43 Commit Notification 2018-03-12 15:03:37 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43bf50d5ced4b878f747075f8c0f1b32991c290e

tdf#115649: ensure we own SolarMutex in the callback

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 44 Tyr Antilles 2018-03-13 08:23:10 UTC
Created attachment 140600 [details]
Procdump crashes just after LO6 crashes
Comment 45 Tyr Antilles 2018-03-13 08:23:57 UTC
- I installed the latest dev build "LibreOfficeDev 6.0.3.0.0 x64" ---> "libo-60-64~2018-03-12_03.21.13_LibreOfficeDev_6.0.3.0.0_Win_x64.msi" from https://dev-builds.libreoffice.org/daily/libreoffice-6-0/Win-x86_64@42/current/  and sadly the problem is still present.

- With LibreOfficeDev 6.0.3.0.0 x64 I created a new ODT file, I paste special with unformatted text some text on it, I inserted a random picture and saved the file. Crash still happen, so, is not only happening on older ODT files.

- I fire up Procdump again, used the command line 
procdump64 soffice.bin -e d:\PDF\soffice.bin.dmp
but again no file is created. I managed to capture a screenshot (see attach from previous comment).
Comment 46 Mike Kaganski 2018-03-13 08:26:36 UTC
Erm, the latest build at https://dev-builds.libreoffice.org/daily/libreoffice-6-0/Win-x86_64@42/current/ is from 2018-03-12 04:28 UTC, while the fix is pushed at 2018-03-12 15:02 UTC
Comment 47 Mike Kaganski 2018-03-13 08:30:05 UTC
... and it's pushed to master (i.e., to 6.1); the 6.0 backport is still under review (https://gerrit.libreoffice.org/51153).
Comment 48 Tyr Antilles 2018-03-13 08:37:25 UTC
Created attachment 140601 [details]
Also, when I was setting the printer, Procdump reported the following:

I am not sure if this helps or not.
Comment 49 Tyr Antilles 2018-03-13 08:39:31 UTC
Ah, ok, I will wait then for 6.1 and report back when I will get access to the fixed version. Thank you.
Comment 50 Timur 2018-03-13 12:02:29 UTC
Tyr, it will take long to 6.1. 
Please try https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/. 
It's Dev edition that will not mess your working LO.
Comment 51 Commit Notification 2018-03-13 20:09:16 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=96cd4feb3ae133c19808ca0df2dab02595bb5588&h=libreoffice-6-0

tdf#115649: ensure we own SolarMutex in the callback

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 52 Tyr Antilles 2018-03-14 06:52:19 UTC
Created attachment 140628 [details]
Print successfully

- I downloaded and installed clean "https://dev-builds.libreoffice.org/daily/libreoffice-6-0/Win-x86_64@42/2018-03-14_04.13.38/libo-60-64~2018-03-14_04.13.38_LibreOfficeDev_6.0.3.0.0_Win_x64.msi" made on 2018-Mar-14 05:20.

- With it I created a new ODT file, I paste special some unformatted text on it, I inserted a random picture and saved the file. Print SUCCESSFULLY AND NO CRASH.

- Next I opened a file created with an older version of LO that previously crashed in LO 6.0. Print SUCCESSFULLY AND NO CRASH.

It looks like this fix is working great. Thank you!  :)
Comment 53 Mike Kaganski 2018-03-14 06:54:45 UTC
Great! Let's call it fixed, then :)
Comment 54 t34 2018-03-14 23:33:30 UTC
successful test for 32Bit Windows 7: With https://dev-builds.libreoffice.org/daily/libreoffice-6-0/Win-x86@42/2018-03-14_03.02.20/libo-60~2018-03-14_03.02.20_LibreOfficeDev_6.0.3.0.0_Win_x86.msi i could print documents without a problem that craches with LO 6.0.2.1
Comment 55 Timur 2018-03-20 09:55:17 UTC
*** Bug 116398 has been marked as a duplicate of this bug. ***
Comment 56 wendy 2018-08-17 14:45:49 UTC Comment hidden (no-value)