Download it now!
Bug 119250 - LibreOffice doesn't print since upgraded to 6.0.5 on Windows 10 Pro ver 1803 - for solution see Comment 56 Comment 57 - userprofile
Summary: LibreOffice doesn't print since upgraded to 6.0.5 on Windows 10 Pro ver 1803 ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 117977 119179 119644 119660 119879 119902 120020 120517 122310 (view as bug list)
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2018-08-13 13:28 UTC by wendy
Modified: 2019-01-10 14:03 UTC (History)
19 users (show)

See Also:
Crash report or crash signature:


Attachments
Forthcoming itinerary table (25.35 KB, application/vnd.oasis.opendocument.text)
2018-08-14 14:06 UTC, wendy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wendy 2018-08-13 13:28:45 UTC
I have LibreOffice Version: 6.0.5.2 (x64) on Windows 10 Pro ver 1803. My printer is a Funai Kodak Verite 65 plus. Since upgrading LibreOffice I can't print. I've uninstalled and reinstalled printer driver. When I send a document to the print queue the queue is empty I can print from pdf and all other applications, just not LibreOffice. Seem to remember having this problem before after a previous upgrade.
Comment 1 Julien Nabet 2018-08-13 13:41:21 UTC Comment hidden (obsolete)
Comment 2 wendy 2018-08-14 13:05:30 UTC
HI and thanks for your help. I've tried that but still doesn't print, in fact, document never appears in print queue.
Any other suggestions?
Comment 3 Julien Nabet 2018-08-14 13:30:14 UTC
Wendy: just to be sure, if you create a brand new file (eg: Writer odt), type "test" and click Print icon, do you get something like an error message?

Xisco: put you in cc because it's the third bug I see about printing pb on Windows.
See tdf#119179 + related to this one but closed as WFM because the user had reinstalled everything and it was ok.
Comment 4 wendy 2018-08-14 13:51:12 UTC
Hi
Did that and it printed! BUT if I copy the contents of the document I really want to print into the new document it still doesn't print.
The doc I'm trying to print consists of a multi-page table.
Just tried a doc that only has a few lines of simple text and that also prints.
What doesn't it like about tables???
Comment 5 Julien Nabet 2018-08-14 13:54:31 UTC Comment hidden (obsolete)
Comment 6 wendy 2018-08-14 14:06:41 UTC
Created attachment 144173 [details]
Forthcoming itinerary table

File attached
Comment 7 Julien Nabet 2018-08-14 14:15:28 UTC
On Win7 with LO 6.0.6, I got this:
- if printer is PDFCreator, no pb, I could save the pdf.
- if printer is a Ricoh (via network), the printer queue displays an error on the doc (so impossible to print it).
Comment 8 Timur 2018-08-14 14:46:47 UTC
*** Bug 119179 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2018-08-16 08:42:24 UTC Comment hidden (obsolete)
Comment 10 wendy 2018-08-16 11:31:25 UTC
I've previously been able to print the document before I upgraded to LO 6.*.*
If I export it as a pdf I can print it but not as a LO document.
Comment 11 Timur 2018-08-16 12:55:58 UTC
*** Bug 117977 has been marked as a duplicate of this bug. ***
Comment 12 Timur 2018-08-16 12:59:25 UTC Comment hidden (obsolete)
Comment 13 Timur 2018-08-17 15:00:31 UTC Comment hidden (obsolete)
Comment 14 wendy 2018-08-19 16:15:25 UTC
With regards to reply:
Q1. is it true you can print new documents, problem is only for old/existing documents?
A1. I can print a simple writer text document, I haven't tried a multi-page table document

Q2. did you switch, one by one, Options - Load/Save - General: Load user-specific OR printer settings with the document
A2. tried each of these options but didn't make any difference.

Q3. dis you try to deinstall 64-bit LO and install 32-but LO 6.0.6?
A3. Yes, made no difference.

Q4. can you try free procdump portable tool from Sysinternals to get dump, like this:
path-to\procdump.exe soffice.bin -h path-to\soffice.bin.dmp
A4. Sorry, but I don't understand this. I am not a power Windows user, straightforward us of applications only. Please can you explain this one a little more.

Thanks
Comment 15 Timur 2018-08-20 09:26:13 UTC Comment hidden (obsolete)
Comment 16 wendy 2018-08-20 17:53:47 UTC Comment hidden (obsolete)
Comment 17 Timur 2018-08-22 10:18:54 UTC
There's no dump, meaning no crash in LO. So I wonder why there's no print. 
Is it related to Bug 116370? Please test with https://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/ that now has it fixed.
Comment 18 Xisco Faulí 2018-08-22 16:10:15 UTC Comment hidden (obsolete)
Comment 19 wendy 2018-08-22 17:32:49 UTC Comment hidden (obsolete)
Comment 20 Buovjaga 2018-08-22 18:20:22 UTC Comment hidden (obsolete)
Comment 21 Xisco Faulí 2018-08-23 07:56:22 UTC Comment hidden (obsolete)
Comment 22 Xisco Faulí 2018-08-23 08:03:59 UTC
(In reply to Xisco Faulí from comment #21)
> (In reply to wendy from comment #19)
> > I've tried that, still the same problem.
> > 
> > Can I "downgrade" to an earlier version of LO and if so, how?
> 
> According to the summary, it stops working with 6.0.5.
> Could you please confirm it works with version 6.0.4 ?

You can download it from https://downloadarchive.documentfoundation.org/libreoffice/old/6.0.4.2/.
Thanks
Comment 23 Xisco Faulí 2018-08-23 08:41:52 UTC Comment hidden (obsolete)
Comment 24 Xisco Faulí 2018-08-30 14:00:23 UTC Comment hidden (obsolete)
Comment 25 wendy 2018-08-30 14:15:02 UTC
Hi, no, still won't print, even "downgraded" to version 6.0.0.3 (x64).
Is this the info you requested:
Version: 6.0.0.3 (x64)
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: CL

I'm going to be out of the country for three weeks wef 2 Sept
Comment 26 Julien Nabet 2018-08-30 14:23:47 UTC
Just for information, I don't reproduce this on Win7 (64 bits) with LO 6.1.0.3 64 bits.
Now I must recognize this bug resembles a bit "Schrödinger", at least in my case. I mean I noticed several jobs (certainly some made with 6.0.6) on the printer which were present on the queue.
To explain a bit further, at office we got several network printers. Each time we print, the job is sent to the printer but not printed.
I must go to the printer, authentify with some badge, then I can see the whole of my jobs to print. From this, I can print and remove job or remove job.

In brief, I'm a bit afraid that the result of my tests may provide wrong/tainted information :-(
Comment 27 Julien Nabet 2018-09-03 08:14:23 UTC
*** Bug 119644 has been marked as a duplicate of this bug. ***
Comment 28 Julien Nabet 2018-09-03 08:15:14 UTC
Adding HP in title considering tdf#119644
Comment 29 Timur 2018-09-03 11:54:17 UTC
*** Bug 119660 has been marked as a duplicate of this bug. ***
Comment 30 james 2018-09-03 12:12:55 UTC
libreoffice won’t even send to the printer everything else on my laptop can print except for libreoffice. I have windows 10 and the printer is a Epson 4750 it also won’t let me print on my Epson 440. It won’t even send it to my printers print queue which it was doing before and printer fine I updated libreoffice but it was still sending to the printer and printing until about 2-3 weeks ago. It was working fine now it won’t even send to any printer at all. I do not know why I was sent to this page when it is 100% libreoffice not anything else seeing as how everywhere else on my laptop sends to every printer. I’ve tried everything and still libreoffice won’t send to any printer and everything else on my computer will.
Comment 31 Timur 2018-09-10 14:02:18 UTC
I don't reproduce issue with Win 10 ver 1709 printing to Konica network printer. 
So far, only specifics we have is that issue occures in Windows 10 ver 1803, as written by Wendy and Dejoie. 

James and Jensen and David, can you please confirm your Windows 10 version?
Did you all test with with master https://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/ ? Please do.
Comment 32 Julien Nabet 2018-09-14 15:09:38 UTC
*** Bug 119879 has been marked as a duplicate of this bug. ***
Comment 33 Julien Nabet 2018-09-14 15:14:13 UTC Comment hidden (obsolete)
Comment 34 dgreusard 2018-09-14 16:07:05 UTC
Thank you Julian [bug 119879], I followed your advice Bug 119250 and printed a new file (saved or not): it appears well in the printer queue.
Comment 35 raal 2018-09-16 06:30:09 UTC
*** Bug 119902 has been marked as a duplicate of this bug. ***
Comment 36 Timur 2018-09-18 14:02:53 UTC
I didn't reproduce issue with Win 10 ver 1803 printing existing document (and attached one) to Konica network printer. 
So we may have an issue with some printers only.
Comment 37 Julien Nabet 2018-09-21 06:36:42 UTC Comment hidden (obsolete)
Comment 38 Julien Nabet 2018-09-21 06:38:11 UTC
(In reply to Julien Nabet from comment #37)
> *** Bug 120020 has been marked as a duplicate of this bug. ***
From initial comment of this tdf, LO 6.1.1.2 + Canon MX 410 series printer + Windows 10 home
Comment 39 BogdanB 2018-09-21 08:25:38 UTC
NO problem printing on Windows 10

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 3208fcb3a36d75d6290d9c548430682f153b09db
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-20_22:43:20
Locale: ro-RO (ro_RO); Calc: threaded
Comment 40 wendy 2018-09-21 09:36:06 UTC
Upgraded to Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-GB (en_US); Calc: CL
Still have the same problem, document doesn't even appear in the print queue.
Comment 41 Julien Nabet 2018-09-21 09:53:05 UTC
Just looking at dups and trying to summarize, the pb is on:
- only on Windows, more specifically on Win10 (so not reproduced in WinVista, Win7 or Win8 unless I missed something)
- 6.0 and 6.1 branches
- only for some printers (only network printers or some reproduce this with usb printers?)
- seems 64 bits only (I don't know if some people use Win10 32 bits on tablets or something else).

To use a brand new file "might" help in some cases but obviously, the goal is to make LO work for every file

So for those who have the pb, it could be interesting to give a try to daily build 6.2 (see https://dev-builds.libreoffice.org/daily/master/)
Of course, it's just for the test since it's an alpha version (so not at all a stable one).
Comment 42 dgreusard 2018-09-21 11:42:37 UTC
Hello,
having to switch permanently between LibreOffice and WPS because of other bugs that I will go back, I notice that:
- I can not print either from WPS Writer through PDF Suite 2016, but without problems on my HP Series 5810 printer;
- Impressions work from LibreOffice and WPS through Microsoft Print to PDF;
- Reminder: the impression since LibreOffice through PDF Suite 2016 does not work.
If it can help you.
Best regards.
Comment 43 Julien Nabet 2018-10-05 13:09:40 UTC
Michael: do you know if someone works on this one?
Indeed, I saw nothing in ESC these last weeks so I wonder if this one is still on the scope of blocker bugs.
Comment 44 Michael Meeks 2018-10-05 13:11:21 UTC
Hi Julien, we are really hoping for some bisection action here by someone affected so we can more easily find the root cause - if we have that, fixing it should become reasonably easy I hope. It was dropped from the ESC agenda due to lack of concrete details IIRC.
Comment 45 wendy 2018-10-05 13:53:42 UTC Comment hidden (obsolete)
Comment 46 Buovjaga 2018-10-05 13:59:35 UTC
(In reply to wendy from comment #45)
> Hi guys
> I still have this problem. I would appreciate a resolution if at all
> possible.

All affected can try bibisecting to find the problem:
Install cygwin: https://wiki.documentfoundation.org/QA/Bibisect/Windows#Setting_up_Environment

Then in your cygwin environment:
git clone git://gerrit.libreoffice.org/bibisect-win32-6.0

Wait a long time while it downloads.

Finally start bibisecting:
https://wiki.documentfoundation.org/QA/Bibisect/Windows#Bibisecting_the_Bug

I don't remember if the 6.0 repo has "latest" tag, so use "master" instead if needed.
Comment 47 Michael Meeks 2018-10-05 14:01:17 UTC
Hi Wendy - sorry for the problem; we're struggling to identify the issue. What would really help would be if you could help bisect the issue - by working out exactly which version this issue crept into. I believe Xisco can help out training on bibisection here if you're interested - it would be great to get more data on this ! Thanks for helping out by filing, and getting involved.
Comment 48 Gary 2018-10-07 04:46:45 UTC
I always try to use the current version so whatever version was the current stable install when I submitted the problem would have been the version I was using.  I had recently updated to that version. 

Currently I am using:
LibreOffice Writer 10/06/2018
Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group threaded

Windows specifications
Edition	Windows 10 Home
Version	1803
Installed on	7/3/2018
OS build	17134.285

I use SUMo to identify my out of date software so that I can monitor all my apps. Previously I was using Secunia PSI which has been discontinued.

I still have the original problem I reported while OpenOffice correctly prints the file.  I am using a HP Officejet Pro 8600 Plus.
Comment 49 Gary 2018-10-07 04:50:35 UTC
Unable to test the master release you referenced as that is beyond my knowledge and skill set.
Comment 50 wendy 2018-10-07 13:41:32 UTC Comment hidden (obsolete)
Comment 51 Buovjaga 2018-10-08 12:09:58 UTC Comment hidden (obsolete)
Comment 52 Julien Nabet 2018-10-11 20:02:01 UTC
*** Bug 120517 has been marked as a duplicate of this bug. ***
Comment 53 Timur 2018-10-17 11:56:56 UTC
From Bug 120517: "All my other programs print, with one exception. I installed OpenOffice and it does not print. "
Comment 54 Timur 2018-10-17 12:54:40 UTC
Dear LO users that have this critical issue. 
As written before, we must pinpoint it before it can be solved, and we were not able to reproduce. 
Looking around, seems that there's a general issue with printing in Win 10 1803.
Can you please try the following advices - if haven't alredy:

A. delete and reinstall printer with latest drivers?
B. enable the SMB1.0 client in Windows Features?
C. Workaround (please backup the registry first before making changes):

    Press windows key + R. Type 'regedit' in the Open box, and then click OK.
    Locate, and then click the following registry subkey if it exists: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\PostSPUpgrade
    On the Edit menu, click Delete, and then click Yes to confirm the removal of the PostSPUpgrade registry key.
    Restart your PC (OR run ‘net stop spooler’ followed by ‘net start spooler’ from an elevated command prompt).

Please note this is best effort to help. And please write your feeedback.
Comment 55 Timur 2018-11-07 11:07:25 UTC
Please test and respond to the previous message. Or confirm that issue is solved somehow, like an upgrade to a new Windows 10 version.
Comment 56 lloyde4628 2018-11-07 14:29:29 UTC
I solved my printing problem. I restarted LO in Safe Mode, then sent the user configuration to archive. When I restarted in normal mode, it began printing. (Not: I had manually renamed the user config file with no result.)
Comment 57 Steven Kleinman 2018-11-27 10:42:38 UTC
I had same issue. Windows 10, version 6.0.7.3 (x64). Issue appeared when I upgraded to this version. It happened with different printers selected, including Microsoft Print to PDF. The issue did not appear if I started in Safe Mode. The issue did not appear in software other than LibreOffice.

I re-booted. I started LibreOffice in safe mode. I selected Reset to Factory Settings, Reset settings and user interface modifications, and Reset entire user profile. I did not have any user extensions installed prior to doing this. I then clicked on Apply Changes and Restart. 

This seems to have cleared up the issue.
Comment 58 Timur 2018-12-27 10:26:09 UTC
*** Bug 122310 has been marked as a duplicate of this bug. ***
Comment 59 Cor Nouws 2019-01-10 14:03:21 UTC
thanks loyde and steven for reporting your solution. Helpful for others too.
I close as WorksForMe then.