Bug 116889 - Table from Word 2013 is transformed into text in LibreOffice Writer 6.0.3.2
Summary: Table from Word 2013 is transformed into text in LibreOffice Writer 6.0.3.2
Status: RESOLVED DUPLICATE of bug 118691
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2018-04-08 21:01 UTC by Reiner Banken
Modified: 2018-10-28 22:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Table in .docx format (15.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-04-08 21:03 UTC, Reiner Banken
Details
Table in .doc format (53.00 KB, application/msword)
2018-04-08 21:04 UTC, Reiner Banken
Details
The problem was fixed recently (402.21 KB, image/png)
2018-10-28 22:33 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reiner Banken 2018-04-08 21:01:29 UTC
Description:
When opening in LibreOffice Writer 6.0.3.2 a .docx file created in Microsoft Word 2013, a specific table is transformed into text.  Saving the word document first as a word97-2003.doc document solves the problem. The files of the table both in .docx and .doc formats are attached.
Here is the information on the Word version: 
Word2013 (15.0.5007.1000) MSO (15.0.5007.1000) 32 bits Partie de Microsoft Office Famille et Etudiant 2013  ID de produit (Product ID) : 00197-19038-49802-AA423

Actual Results:  
Opening the copy of the table in .docx format in LibreOffice Writer 6.0.3.2

Expected Results:
Table appears as text, not as a table


Reproducible: Always


User Profile Reset: No



Additional Info:
It seems to be a bug related to the way Word 2013 formats or creates the table.


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/65.0.3325.181 Chrome/65.0.3325.181 Safari/537.36
Comment 1 Reiner Banken 2018-04-08 21:03:22 UTC
Created attachment 141213 [details]
Table in .docx format
Comment 2 Reiner Banken 2018-04-08 21:04:00 UTC
Created attachment 141214 [details]
Table in .doc format
Comment 3 m.a.riosv 2018-04-08 23:01:30 UTC
Opening the doc with LibreOffice, saving with LibreOffice as docx, opening this last docx, open with the table. I have not word to test.
Comment 4 Dieter 2018-04-09 08:27:08 UTC Comment hidden (no-value)
Comment 5 raal 2018-04-09 11:58:57 UTC
I can confirm with LO 4.4 and Version: 6.1.0.0.alpha0+
Build ID: 4f268695787ff6c7052269058f7ae6de34abfd5d
CPU threads: 4; OS: Windows 6.1; UI render: default; 
I see the table in word2010
Comment 6 Justin L 2018-08-23 13:12:48 UTC
Confirmed in 6.2 master that the doc version still solves the problem. It reads fine, and roundtripping that to DOCX is also fine.
Confirmed that the DOCX version still cannot be read, and used bibisect43all to observe that this has never worked. Marking as inherited from OOo.

This is one for the experts. unotext.cxx ConvertCell is throwing lang::IllegalArgumentException() at the end of Row 11.

warn:JCL:17648:17648:sw/source/core/unocore/unotext.cxx:2118: [10]of[19]::convertToTable cells 0 - [5]
...
starting ConvertCell[4] pLastCell[0x55fc525eede0] rowNodes.empty?[0]
LastNodeEndIndex[86] startCellNodeIndext[88]

because it expects the startcell to immediately follow the end. I notice that this is where the merged first cell stops and becomes 6 columns again.

Round-tripping this file in Word2003 "fixes" it, but after round-tripping in 2010 it is still "broken".
Comment 7 Gabor Kelemen 2018-10-28 22:33:02 UTC
Created attachment 146113 [details]
The problem was fixed recently

There is a <w:cr/> tag in the file that caused the table not to appear. This one was recently fixed!
Comment 8 Gabor Kelemen 2018-10-28 22:34:38 UTC

*** This bug has been marked as a duplicate of bug 118691 ***