Bug 116916 - Icon themes missing on LibreOffice Vanilla from macOS appstore
Summary: Icon themes missing on LibreOffice Vanilla from macOS appstore
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.1.0.1 target:6.2.0
Keywords:
Depends on:
Blocks: Icon-Themes MacOS-Vanilla
  Show dependency treegraph
 
Reported: 2018-04-10 08:06 UTC by Heiko Tietze
Modified: 2018-06-07 13:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Missing icons in LO Vanilla 6.0.3 (Sidebar) (73.73 KB, image/png)
2018-04-10 13:20 UTC, Yannick.D
Details
Screenshot from fresh Linux build (89.80 KB, image/png)
2018-04-11 08:04 UTC, Tor Lillqvist
Details
Missing icons in LO Vanilla 6.0.3 (Sidebar) - Fresh version comparison (113.53 KB, image/png)
2018-05-17 09:34 UTC, Yannick.D
Details
Missing icons in LO Vanilla 6.0.3 (Settings) - Fresh version comparison (106.58 KB, image/png)
2018-05-17 09:34 UTC, Yannick.D
Details
Missing icons in LO Vanilla 6.0.3 (Sidebar) - video (won't play?!) (770.35 KB, video/quicktime)
2018-05-17 09:35 UTC, Yannick.D
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2018-04-10 08:06:49 UTC
Collabora kindly provides LibreOffice in the macOS store. However, all icon themes except Tango have been removed. Tested with 6.0.3.2 from Apr/10 via app store.

Breeze (actually the default on macOS), Elementary, Sifr, and Colibre are home-made, and all themes including Industrial, Hicontrast, Oxygen, Galaxy, and Tango are CC0-licensed. Without Galaxy you don't get the final fallback icon if something is missing in Tango, which should be a lot since Tango is not maintained.

Some effort is currently made to remove/replace Industrial, Hicontrast, Oxygen, Galaxy, and Tango from the core in order to fully support SVG and to have maintained themes.
Comment 1 andreas_k 2018-04-10 08:35:36 UTC
you need tango AND galaxy or colibre to have a good experience.

with some work breeze is also possible but at the moment only TANGO AND GALAXY OR COLIBRE are working.
Comment 2 Yannick.D 2018-04-10 13:19:21 UTC
Thanks for reporting, Heiko. This probably causes missing icons in several places, e.g. Settings of Sidebar (topmost icon); Close Sidebar; More Options; Expand Deck; ….

(Sorry for Offtopic: As much as there effort is appreciated, is there any way to report bugs to Collabora directly? There are are some more related to Vanilla only: loosing default fonts on restart; huge app size for example.
Comment 3 Yannick.D 2018-04-10 13:20:23 UTC
Created attachment 141261 [details]
Missing icons in LO Vanilla 6.0.3 (Sidebar)
Comment 4 Heiko Tietze 2018-04-10 13:26:10 UTC
(In reply to Yannick.D from comment #2)
> (Sorry for Offtopic: As much as there effort is appreciated, is there any
> way to report bugs to Collabora directly? There are are some more related to
> Vanilla only: loosing default fonts on restart; huge app size for example.

Would say file it here as most issues are also relevant for the TDF bulld. Caolan, what do you think about the control (screenshot)?
Comment 5 Michael Meeks 2018-04-10 14:28:58 UTC
Sure - please CC Tor Lillqvist and Miklos Vajna on such bugs =) or better - it would be nice to have a tracker bug for them.

Thanks ! =)
Comment 6 Tor Lillqvist 2018-04-10 14:33:17 UTC
So is configure.ac wrong then, when it claims that only tango is compatible with the --enable-mpl-subset option?

AC_MSG_CHECKING([MPL subset])
MPL_SUBSET=

if test "$enable_mpl_subset" = "yes"; then

[...]

    for theme in $WITH_THEMES; do
        case $theme in
        breeze|crystal|default|hicontrast|oxygen|sifr)
            AC_MSG_ERROR([need to disable icon themes from '$WITH_THEMES': $theme present, use --with-theme=tango]) ;;
        *) : ;;
        esac
    done
Comment 7 Tor Lillqvist 2018-04-10 14:35:04 UTC
(Check originally from c32c11fbd49e0194534be9d21c22da6799728be3 )
Comment 8 Heiko Tietze 2018-04-10 14:44:35 UTC
(In reply to Tor Lillqvist from comment #6)
> AC_MSG_CHECKING([MPL subset])
> MPL_SUBSET=

Where/How should the subset be defined?
Comment 9 Tor Lillqvist 2018-04-11 08:02:00 UTC
Sorry if this is a stupid question, but what exactly is missing in the screenshot in comment #3?
Comment 10 Tor Lillqvist 2018-04-11 08:04:23 UTC
Created attachment 141280 [details]
Screenshot from fresh Linux build

So I guess what is missing in comment #3 are the small crosses and the "cog wheel" things?
Comment 11 Heiko Tietze 2018-04-11 17:38:12 UTC
I read Yannick's comment in this way and added Caolan (though it's totally unrelated to the icons question). Thing is that I'm not sure how numerical stepper vs. dropdown controls look under macOS and if the screenshot shows an issue. The Linux theme makes the difference of controls perfectly clear. Pulling all together, please file a bug report, Yannick.

Back to the topic, we decided to keep the status quo until Colibre is ready with 6.1. Then we make the move (I'll do the changes in the scripts).

*** This bug has been marked as a duplicate of bug 116696 ***
Comment 12 Tor Lillqvist 2018-05-15 07:42:33 UTC
No responses to my earlier questions, and this has been marked as a duplicate of another bug, and that bug apparently is fixed by the colibre icon set, which is present in master only, so doesn't really help the 6.0 branch. Thus it seems that I will continue to use just --with-theme=tango when building LibreOffice Vanilla from the 6.0 branch.
Comment 13 Michael Meeks 2018-05-15 08:44:09 UTC
Sounds fine, colibre will look great for 6.1 - looking forward to it.
Comment 14 Yannick.D 2018-05-17 09:32:31 UTC
Thanks for taking care @Tor Lillqvist! I listed the missing icons in Comment 2, Heiko confirmed your own response in Comment 11. Sorry if I'm not able to name the items accordingly but I'll add screenshots of the non-App Store version for comparison. What I noted is missing so far:

- Settings of Sidebar (dropdown menu behind the top right) (cogwheel or sliders depending on theme)
- Close Sidebar (X)
- More Options/Expand Deck (… or ☰)
- Expand triangles in app menu > "Settings…"

As this thread initially was about missing icon themes in Vanilla and already is closed, please let me now if I should open a separate issue for missing icons. I didn't because I don't really get if this is already solved or not. LO standardizes to Breeze on Mac so maybe Vanilla 6.0 should be built with that as well.
Comment 15 Yannick.D 2018-05-17 09:34:14 UTC
Created attachment 142146 [details]
Missing icons in LO Vanilla 6.0.3 (Sidebar) - Fresh version comparison
Comment 16 Yannick.D 2018-05-17 09:34:42 UTC
Created attachment 142147 [details]
Missing icons in LO Vanilla 6.0.3 (Settings) - Fresh version comparison
Comment 17 Yannick.D 2018-05-17 09:35:57 UTC
Created attachment 142148 [details]
Missing icons in LO Vanilla 6.0.3 (Sidebar) - video (won't play?!)
Comment 18 Heiko Tietze 2018-05-17 10:27:51 UTC
Still on my agenda is the update of what themes are MPL and can be shipped on the macOS store, which should resolve the missing icons.
Comment 19 Tor Lillqvist 2018-05-25 08:50:56 UTC
The 6.0.4 build includes galaxy (but the default is still Tango, see https://cgit.freedesktop.org/libreoffice/core/commit/?h=distro/collabora/lov-6.0.4&id=d62acf55f17f5b1213f150fb4fb0fd2e8bb0b9b0 )
Comment 20 Heiko Tietze 2018-05-25 09:36:09 UTC
(In reply to Tor Lillqvist from comment #19)
> The 6.0.4 build includes galaxy (but the default is still Tango, see
> https://cgit.freedesktop.org/libreoffice/core/commit/?h=distro/collabora/lov-
> 6.0.4&id=d62acf55f17f5b1213f150fb4fb0fd2e8bb0b9b0 )

Better we go with Sifr (CC-SA) and ship Tango and Colibre as well. Patch is coming... (and everything for 6.1).
Comment 21 Heiko Tietze 2018-05-25 09:52:30 UTC
(In reply to Tor Lillqvist from comment #19)
> The 6.0.4 build includes galaxy (but the default is still Tango, see
> https://cgit.freedesktop.org/libreoffice/core/commit/?h=distro/collabora/lov-
> 6.0.4&id=d62acf55f17f5b1213f150fb4fb0fd2e8bb0b9b0 )

This patch is not in master. https://opengrok.libreoffice.org/xref/core/vcl/source/app/IconThemeSelector.cxx
Comment 22 Tor Lillqvist 2018-05-25 09:56:37 UTC
... because in master colibre is supposed to be the latest and greatest and everything we need, no?
Comment 23 David 2018-06-01 08:52:39 UTC
This is good news. I've been wondering about this ever since v. 5.2.1.1 -

https://apple.stackexchange.com/q/252051/136150

Breeze is my preferred option, but Sifr would be fine!
Comment 24 Heiko Tietze 2018-06-01 19:52:29 UTC
(In reply to David from comment #23)
> Breeze is my preferred option, but Sifr would be fine!

Breeze is licensed under GPL and thereby it's not possible to ship in the mac store. The patch will enable some other themes and make Tango the default. If you don't load from the mac store but the official site [1] you get all themes and Breeze is the default.

[1] https://www.libreoffice.org/download/
Comment 25 Commit Notification 2018-06-04 20:25:41 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0550189c28cd759c41b8a048a3f667ae12560c5e&h=libreoffice-6-1

tdf#116916 - Icon themes missing on LibreOffice Vanilla from macOS appstore

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Heiko Tietze 2018-06-04 20:25:55 UTC
Solved with https://gerrit.libreoffice.org/#/c/55295/
Comment 27 Commit Notification 2018-06-07 05:51:55 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b20226bb0e431afa4505373aaa0af2d28479528&h=libreoffice-6-1

Revert "tdf#116916 - Icon themes missing on LibreOffice Vanilla from macOS appstore"

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2018-06-07 05:53:20 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90088d43a20cff2623c2f01949955099f9b92845

tdf#116916 - Icon themes missing on LibreOffice Vanilla from macOS appstore

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2018-06-07 13:57:32 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e3ae648ca32806bd6dcdd6e161630ec111bc6d3&h=libreoffice-6-1

tdf#116916 - Icon themes missing on LibreOffice Vanilla from macOS appstore

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.