Bug 117188 - DOCX import -> ODF export hides some text in header
Summary: DOCX import -> ODF export hides some text in header
Status: RESOLVED DUPLICATE of bug 109229
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2018-04-23 16:20 UTC by Patrick Jaap
Modified: 2018-09-11 16:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
docx template (116.22 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-04-23 16:20 UTC, Patrick Jaap
Details
odf export (92.81 KB, application/vnd.oasis.opendocument.text)
2018-04-23 16:20 UTC, Patrick Jaap
Details
original rendering of the docx file in LO Writer (71.50 KB, application/pdf)
2018-04-23 16:21 UTC, Patrick Jaap
Details
rendering after opening the ODF export (71.53 KB, application/pdf)
2018-04-23 16:21 UTC, Patrick Jaap
Details
minimized document (30.92 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-04-24 18:21 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Jaap 2018-04-23 16:20:13 UTC
Description:
Opening the template letter in LO Writer and saving it as odf causes the box in the header "Der ... Dezernat" to shrink and hide the text. To see the effect, the file has to be reopened in LO Writer.

Steps to Reproduce:
1. open the docx template
2. save it as odf
3. reopen the odf in Writer

Actual Results:  
The box "Der ... Dezernat" is shrinked

Expected Results:
no shrinking


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Patrick Jaap 2018-04-23 16:20:28 UTC
Created attachment 141572 [details]
docx template
Comment 2 Patrick Jaap 2018-04-23 16:20:46 UTC
Created attachment 141573 [details]
odf export
Comment 3 Patrick Jaap 2018-04-23 16:21:00 UTC
Created attachment 141574 [details]
original rendering of the docx file in LO Writer
Comment 4 Patrick Jaap 2018-04-23 16:21:23 UTC
Created attachment 141575 [details]
rendering after opening the ODF export
Comment 5 Patrick Jaap 2018-04-23 16:23:17 UTC
The misplaced images are already reported in 
https://bugs.documentfoundation.org/show_bug.cgi?id=115094
Comment 6 Dieter Praas 2018-04-23 19:16:56 UTC
I confimr it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 2325f9ac789cd12e5ecc9d239baf2558e1d678bb
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-05_00:37:47
Locale: en-US (de_DE); Calc: CL
Comment 7 Xisco Faulí 2018-04-24 18:21:08 UTC
Created attachment 141606 [details]
minimized document
Comment 8 Xisco Faulí 2018-04-24 18:59:50 UTC
regression introduced by c761df1e42fd11acc5fc05b0baacd803c3788ca6 which is the same as in bug 109229

*** This bug has been marked as a duplicate of bug 109229 ***
Comment 9 Patrick Jaap 2018-09-11 15:20:22 UTC
Hi!

If I apply the patch from
https://bugs.documentfoundation.org/show_bug.cgi?id=109229#c6

Writer closes without exception when saving and then reopening the odt file.
Comment 10 Patrick Jaap 2018-09-11 16:32:14 UTC
(In reply to Patrick Jaap from comment #9)
> Hi!
> 
> If I apply the patch from
> https://bugs.documentfoundation.org/show_bug.cgi?id=109229#c6
> 
> Writer closes without exception when saving and then reopening the odt file.

Me again, there was something wrong with my setup! The comment can be removed. The mentioned patch resolves the issue!