Bug 109229 - FILESAVE: Textbox's height is reduced after RT
Summary: FILESAVE: Textbox's height is reduced after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.2.0 target:6.1.2
Keywords: bibisected, bisected, regression
: 117188 (view as bug list)
Depends on:
Blocks: Textbox
  Show dependency treegraph
 
Reported: 2017-07-20 10:54 UTC by Xisco Faulí
Modified: 2018-09-14 08:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (17.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-20 10:54 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-07-20 10:54:33 UTC
Created attachment 134746 [details]
sample

Steps:
1. Open attached document
2. Save it as .ODT
3. Reopen the new file

Observed behaviour: Tex box is smaller and the text inside it can't be read

Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: bde72cdae1e7e001d5089c5284672c976b8e43df
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group


[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2017-07-20 10:56:47 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-25 07:05:47 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-25 09:32:01 (GMT)
commit	c761df1e42fd11acc5fc05b0baacd803c3788ca6 (patch)
tree	6ed550b92aefe19191fa14b462894714907baa3c
parent	fab262f115e5c0e6d43b65e376241152ddff82b3 (diff)
tdf#84678 DOCX import: fix handling of textbox margins
Regression from commit d379d18666aa42031359ca8eb34b0021960347ae (oox:
import WPS shape with text as shape with textbox, 2014-06-18), the
problem for a long time was that in Writer text frames without borders
couldn't have text margins, either.

Recently a compat setting was added in the WW8 filter for this
situation, so use that in the DOCX import as well, and improve
SwTextBoxHelper to handle the margin properties.

Bisected with bibisect-linux-64-5.3.

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2017-10-24 20:17:18 UTC
*** Bug 113399 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2018-02-14 11:11:12 UTC
Still reproducible in

Version: 6.1.0.0.alpha0+
Build ID: 48d3ff5c498f8f186d4ee72871af379010403442
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Xisco Faulí 2018-04-24 18:59:50 UTC
*** Bug 117188 has been marked as a duplicate of this bug. ***
Comment 5 Mike Kaganski 2018-09-10 16:58:03 UTC
https://gerrit.libreoffice.org/60267
Comment 6 Commit Notification 2018-09-11 04:04:04 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3422cd205d8da852f5c310b5f08028d6c4c5eb4

tdf#109229: Set "TextBox" prop before filling textbox-related props

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-09-11 08:36:43 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ea0e3b2d657c1d3183e16d72f9b7188a048deabe&h=libreoffice-6-1

tdf#109229: Set "TextBox" prop before filling textbox-related props

It will be available in 6.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-09-13 15:11:50 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: b74db4138342f646fda061eac5d6759ecf2c366f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Mike Kaganski, Thanks for fixing this!