Bug 117285 - WRITER: MAILMERGE: EDIT: insert fields add database function does not register database name in user configuration
Summary: WRITER: MAILMERGE: EDIT: insert fields add database function does not registe...
Status: RESOLVED DUPLICATE of bug 122198
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2018-04-27 11:05 UTC by Marina Latini (SUSE)
Modified: 2019-01-07 11:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
source ods file (8.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-04-27 11:06 UTC, Marina Latini (SUSE)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (SUSE) 2018-04-27 11:05:30 UTC
Description:
If you try to connect a new source (ods file) inserted from the "more field" dialog the connection to the source isn't stored properly.

Steps to Reproduce:
1. Open a new writer document
2. Insert -> Field -> More fields...
3. Select the "Database" tab
4. click on "Browse" (Add database file)
5. Select the provided file - source-ODB.ods - created with this LibreOffice version
6. From the "Database selection" area click the dropdown menu and show the available fields
7. Insert the "fild1", "fild2", "fild3"
8. Close the dialog
9. Close LibreOffice
10. Open the mail-merge ODT file
11. File -> print (and click yes)

Actual Results:  
The database can't be found

Expected Results:
The connection to the database is persistent and the mail-merge feature works fine


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha1
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Linux 4.16; UI render: default; VCL: gtk2; 
Locale: it-IT (it_IT.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Marina Latini (SUSE) 2018-04-27 11:06:13 UTC
Created attachment 141702 [details]
source ods file

source ods file
Comment 2 Drew Jensen 2018-04-27 11:35:01 UTC
This looks like https://bugs.documentfoundation.org/show_bug.cgi?id=117261 except that is using an odt file.
Comment 3 Drew Jensen 2018-04-27 11:54:25 UTC
So, further test and it is not quite the same as the other bug.

I used 5.4 to create my test file in writer and under 5.4 I can save it and open it and no problems, the other issue manifests here also.

I then switch to 6.1Alpha and open the file and 'datasource can't be found'.

Then went the other way, created a document in 6.1 and tried to use it in 5.4 with no luck.

Finally, I tried this. Using the file created in 5.4 that works properly in 5.4 I edited (added a line to the end, but nothing fields wise) it and saved it. Went back into 5.4 and it still works as expected.
Comment 4 Drew Jensen 2018-04-27 12:01:21 UTC
Can confirm using 6.1Alpha

Also verified it worked using:
Version: 5.4.6.2
Build ID: 1:5.4.6-0ubuntu0.17.10.1
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

so setting as a regression.
Comment 5 Drew Jensen 2018-04-27 12:48:36 UTC
updated summary after a little further poking at this.
Comment 6 Buovjaga 2018-06-06 12:36:50 UTC
Step 5b should be "Select Mail merge fields from the Types area"

Bibisected with bibisect-win32-6.0 and it blames this, which sounds right: https://cgit.freedesktop.org/libreoffice/core/commit/?id=97477ee5e11951a5a25a91b89f1b71a1b78ac8f5

commit	97477ee5e11951a5a25a91b89f1b71a1b78ac8f5 (patch)
tree	77d49f492b37bc05ac9eafc77b7a7f28c31530ed
parent	a45800f010f3e063c6f31426fcdba76aa5b43d3e (diff)
tdf#108572 remove connections only for current shell
Also remove connections to temp files.

Change-Id: Ie5c09eb365d1246e053dc52884c72687ac226f3c
Reviewed-on: https://gerrit.libreoffice.org/42095

Adding Cc: to Szymon Kłos
Comment 7 Xisco Faulí 2019-01-07 11:15:16 UTC
it seems the same as bug 122198.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 122198 ***