Download it now!
Bug 117373 - Resize and rotate handles are broken both visually and interacting with the mouse pointer
Summary: Resize and rotate handles are broken both visually and interacting with the m...
Status: RESOLVED DUPLICATE of bug 114700
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2018-05-01 12:28 UTC by kubi
Modified: 2018-10-26 12:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Resize handles (10.77 KB, image/png)
2018-05-01 12:28 UTC, kubi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kubi 2018-05-01 12:28:08 UTC
Created attachment 141811 [details]
Resize handles

Resize and rotate handles are broken both visually and interacting with the mouse pointer. The handles look like broken, "inside out" a bit, and the mouse pointer interaction follows the broken pattern.

Removing ".config/libreoffice" turning OpenGL on/off, creating a new user and running LibreOffice from it does not help.

Linux distribution is Debian Buster.
The bug is version independent. 6.0.2.1 (from Debian), 6.0.3.2 (from the web), 6.0.4-rc1 (from Debian) are all affected.

Reproduce:
1) Start Libreoffice Impress or Writer
2) Insert any shape or a textbox.
3) Select the shape, so that the resize handles are shown
4) Hoover the mouse pointer on top one of the broken shape resize handles
5) Move the mouse pointer a bit back&forth
6) The resize mode will be on/off as the pointer leaves or enters again the broken area. As the pointer is on top of the purple part it enters the resize mode, as the pointer is in the middle white area it leaves resize
Comment 1 kubi 2018-05-01 13:09:51 UTC
Ok, it seems that installing libreoffice-gnome fixes this error.
Also, the icons look far better in the toolbar.
Comment 2 Buovjaga 2018-06-07 17:05:39 UTC
I remembered a similar report related to HiDPI. I found one about image anchors, which look similarly broken in the screenshot.

*** This bug has been marked as a duplicate of bug 114700 ***
Comment 3 Regina Henschel 2018-10-26 12:59:12 UTC
(In reply to Buovjaga from comment #2)
> I remembered a similar report related to HiDPI. I found one about image
> anchors, which look similarly broken in the screenshot.

You are good, I have just searched for it, but not found.
Yes, the reason is the same. The images for handles and for anchors are together in file "markers.png". The crop handles have the same problem. They are in file "cropmarkers.png" in the icon themes.


> 
> *** This bug has been marked as a duplicate of bug 114700 ***