Bug 117421 - VIEWING: Tooltip on the bottom bar of Writer GUI overflows the screen
Summary: VIEWING: Tooltip on the bottom bar of Writer GUI overflows the screen
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.4.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland Tooltip
  Show dependency treegraph
 
Reported: 2018-05-04 06:05 UTC by Jambunathan K
Modified: 2018-10-15 18:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Tooltip overflows the screen (193.12 KB, image/png)
2018-05-04 06:05 UTC, Jambunathan K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jambunathan K 2018-05-04 06:05:30 UTC
Created attachment 141883 [details]
Tooltip overflows the screen

Tooltip overflows the screen.  

In the attached screenshot, the Writer window is maximized and occupies the entire screen.  The tooltip on one of the tools on the bottom bar has flown out of my laptop screen.

Version: 6.0.4.1
Build ID: 1:6.0.4~rc1-4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-IN (en_IN); Calc: group

Debian/Sid and using Package: libreoffice (1:6.0.4~rc1-4)
Comment 1 Xisco Faulí 2018-06-04 09:39:50 UTC
Hello,
thanks for reporting the issue.
I think this is a duplicate of bug 117175. Closing as RESOLVED DUPLICATED
Regards

*** This bug has been marked as a duplicate of bug 117175 ***
Comment 2 Maxim Monastirsky 2018-06-04 12:25:27 UTC
I don't think it's a duplicate of bug 117175.
Comment 3 Buovjaga 2018-06-08 14:46:53 UTC
Jambunathan: does this also happen with a Wayland session?
Comment 4 Susan Gessing 2018-06-16 01:37:57 UTC
Could you please let me know how to display the icon in question onto LibreOffice. I tried displaying several different toolbars but was unsuccessful at getting the icon that is having the tooltip issue. Thank you.
Comment 5 Jean-Baptiste Faure 2018-06-16 17:49:37 UTC
Why do you think that is a bug? The tooltip should be somewhere. If you do not place the tooltip over the status bar you need to place it elsewhere and it will overflow some other data on the screen. As the tooltip is shown for a limited time, I think it is not a problem.

Best regards. JBF
Comment 6 Adolfo Jayme 2018-06-18 19:10:54 UTC
@Jean-Baptiste: The bug is not that the tooltip is covering anything else on the screen. The bug is that the tooltip is unreadable by not being positioned within the boundaries of the screen.
Comment 7 Jean-Baptiste Faure 2018-06-18 19:44:19 UTC
(In reply to Adolfo Jayme from comment #6)
> @Jean-Baptiste: The bug is not that the tooltip is covering anything else on
> the screen. The bug is that the tooltip is unreadable by not being
> positioned within the boundaries of the screen.

Ah, ok, I did not understand that. So I do not reproduce the problem because, for me, the tooltips are always positioned to be readable even if the window is maximized.

Best regards. JBF
Comment 8 Maxim Monastirsky 2018-10-15 18:23:07 UTC
That's an upstream gtk3 bug, and it was fixed recently for gtk 3.24 with the following commit:

https://gitlab.gnome.org/GNOME/gtk/commit/14d22cb3233efbd7e9f8f6244179eccc2cc8beb8