Download it now!
Bug 117451 - For certain fonts, text copied from PDF document created by Writer is garbled on paste
Summary: For certain fonts, text copied from PDF document created by Writer is garbled...
Status: RESOLVED DUPLICATE of bug 115117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-06 03:30 UTC by mkflan
Modified: 2018-05-09 08:57 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mkflan 2018-05-06 03:30:09 UTC
Description:
People often copy/paste *from* a PDF document. When using certain fonts in LibreOffice, and exporting to PDF, then copy/paste from that PDF, the resulting text has all sorts of character replacements.

Steps to Reproduce:
1. Create YourDocument.odt
2. Use Calibri font (default for MSWord, often requested for resumes), or Carlito (metric equivalent to Calibri)
3. Export as / Export as PDF / save (as) YourDocument.pdf
4. Open YourDocument.pdf
5. Select text / copy text / paste text into notepad



Actual Results:  
Characters have been replaced with garbage characters.

Now change the font to Times New Roman/Arial/Courier New. Problem disappears.

Expected Results:
Pasted text should be what is visible in the PDF document created by LibreOffice Writer.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 mkflan 2018-05-09 01:57:26 UTC
To make this even easier to reproduce, use the following text in your document:

testing text 123-456-789
Comment 2 mkflan 2018-05-09 02:32:58 UTC
Could this be related to this bug?: https://bugs.documentfoundation.org/show_bug.cgi?id=99412
Comment 3 Khaled Hosny 2018-05-09 08:57:32 UTC

*** This bug has been marked as a duplicate of bug 115117 ***