Download it now!
Bug 99412 - UTF8 character are not correctly rendered on PDF and Printer for Type 1 font
Summary: UTF8 character are not correctly rendered on PDF and Printer for Type 1 font
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-20 10:25 UTC by David Kremer
Modified: 2018-05-09 05:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A libreoffice file with UTF8 characters to test export to PDF (9.56 KB, application/vnd.oasis.opendocument.text)
2016-04-20 10:25 UTC, David Kremer
Details
Export to PDF with liberation font (10.25 KB, application/pdf)
2016-04-20 10:26 UTC, David Kremer
Details
Export to PDF with nimbus Roman font (127.84 KB, application/pdf)
2016-04-20 10:26 UTC, David Kremer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kremer 2016-04-20 10:25:49 UTC
Created attachment 124527 [details]
A libreoffice file with UTF8 characters to test export to PDF

UTF 8 characters are definetely not rendered correctly on my distro (Archlinux).
This thread contains useful informations :
https://bbs.archlinux.org/viewtopic.php?id=202723
Comment 1 David Kremer 2016-04-20 10:26:16 UTC
Created attachment 124528 [details]
Export to PDF with liberation font
Comment 2 David Kremer 2016-04-20 10:26:39 UTC
Created attachment 124529 [details]
Export to PDF with nimbus Roman font
Comment 3 raal 2016-04-21 21:05:35 UTC
I can not confirm with Version: 5.2.0.0.alpha0+
Build ID: 170a473597534cf59887b1d817538322e7039862
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-04-19_00:41:06
Comment 4 David Kremer 2016-04-21 21:08:05 UTC
Hello. It could very well be a packaging issue as far I know. However, I suppose it may be prudent to wait for the next release and see if the bug persists on 5.2. You are using an alpha build, so I cannot confirm.
Comment 5 raal 2016-04-21 21:15:32 UTC
Please could you test with dev version?
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 6 David Kremer 2016-04-21 21:49:15 UTC
I am using archlinux. I just tested your last build by extracting all your rpms, it is definitely not working on ArchLinux (exactly the same behaviour as with the previous version).
Comment 7 David Kremer 2016-04-21 21:53:43 UTC
I just filled a bug within archlinux. If it *works* on the vanilla build elsewhere, it is probably a packaging issue or a bug whithin my own installation.
Comment 8 Ulrich 2016-04-22 12:58:59 UTC
I have the same trouble only when the PDF is generated with

--headless --convert-to pdf:writer_pdf_Export 

The export to PDF is correct when initiated from the GUI

The faulty PDF has more pages and the font info differs

I hope this helps to reproduce this on other distros,
as I'm on archlinux too.
Comment 9 David Kremer 2016-04-23 17:04:06 UTC
This problem is absolutely recurrent with all the LO tools : draw, calc, writer, etc. It concerns printing as well as pdf export so one must assume that this is a shared subsystem which is concerned.
Comment 10 Buovjaga 2016-05-03 11:06:07 UTC
Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha1+
Build ID: 540fee2dc7553152914f7f1d8a41921e765087ef
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 30th 2016
Comment 11 Khaled Hosny 2016-11-12 00:06:49 UTC
We are dropping support for Type 1 fonts in 5.3. The latest versions of GhostScript fonts are now in OpenType format as well.
Comment 12 mkflan 2018-05-09 04:16:02 UTC
I'm wondering if this issue is the same as the issue I logged here: https://bugs.documentfoundation.org/show_bug.cgi?id=117451

"We are dropping support for Type 1 fonts in 5.3." - Which I'm sure means that there is no support for Type 1 fonts in v6.x. However, what I *don't* know is what type of font Calibri and Carlito are. Note that Calibri/Carlito are important fonts, because they are often requested for resumes. They have become something of a defacto standard. So I would say that this is not an edge case issue.

Any insight would be appreciated. Thanks.
Comment 13 Buovjaga 2018-05-09 05:50:53 UTC
(In reply to mkflan from comment #12)
> I'm wondering if this issue is the same as the issue I logged here:
> https://bugs.documentfoundation.org/show_bug.cgi?id=117451
> 
> "We are dropping support for Type 1 fonts in 5.3." - Which I'm sure means
> that there is no support for Type 1 fonts in v6.x. However, what I *don't*
> know is what type of font Calibri and Carlito are. Note that Calibri/Carlito
> are important fonts, because they are often requested for resumes. They have
> become something of a defacto standard. So I would say that this is not an
> edge case issue.
> 
> Any insight would be appreciated. Thanks.

Calibri and Carlito are not Type 1 fonts. I don't think Microsoft ships such obsolete font technologies anymore.