Bug 117509 - Crash pasting a from Impress to Writer as LibreOffice Drawing format
Summary: Crash pasting a from Impress to Writer as LibreOffice Drawing format
Status: RESOLVED DUPLICATE of bug 116977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2018-05-08 18:24 UTC by Telesto
Modified: 2018-05-10 07:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-08 18:24:02 UTC
Description:
Hopefully a dupe; the stack looks a little different (but AW080 related). Crash pasting a from Impress to Writer as LibreOffice Drawing format

Steps to Reproduce:
1. Open Impress
2. Insert table
3. Copy the table
4. Open a Writer Document
5. Edit -> Special Paste -> LibreOffice Drawing format

Actual Results:  
Crash

Expected Results:
No Crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha1+
Build ID: 08441d466dd70c203a519a133aaf1a5997adbbd3
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-06_23:59:40
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2018-05-08 19:28:58 UTC
Unrelated to comment 0, but likely a AW080 issue; hopefully also a dupe
1. Open Writer
2. Insert a shape; say smiley
3. Copy the smiley to the clipboard 
4. Close LibreOffice completely
5. Launch Writer
6. Paste -> Crash
Comment 2 Thomas Woltjer 2018-05-08 19:44:24 UTC
Confirmed, this does crash.

Version: 6.1.0.0.alpha1+
Build ID: 08441d466dd70c203a519a133aaf1a5997adbbd3
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group
Comment 3 Telesto 2018-05-10 07:39:55 UTC
No repro with
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL

in both cases

*** This bug has been marked as a duplicate of bug 116974 ***
Comment 4 Telesto 2018-05-10 07:46:44 UTC

*** This bug has been marked as a duplicate of bug 116977 ***