Download it now!
Bug 117564 - text garbled in a bulleted list item in a DOC
Summary: text garbled in a bulleted list item in a DOC
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOC-Bullet-Number-Lists CommonSalLayout-refactoring-regressions
  Show dependency treegraph
 
Reported: 2018-05-11 14:29 UTC by Roman Kuznetsov
Modified: 2018-07-10 14:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
File .doc (66.00 KB, application/msword)
2018-05-11 14:31 UTC, Roman Kuznetsov
Details
Screenshot for illustration of problem (44.43 KB, image/png)
2018-05-11 14:40 UTC, Roman Kuznetsov
Details
Screenshot of state of commit 9615e45d2e2bac79c252a018846e4f20012cfa34 (39.86 KB, image/png)
2018-05-12 04:08 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-05-11 14:29:50 UTC
Description:
text garbled in a bulleted list item in a DOC

Steps to Reproduce:
1. Open file from attach and look at horror instead good text


Actual Results:  
text garbled in a bulleted list item in a DOC

Expected Results:
text in list looks as text


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
Comment 1 Roman Kuznetsov 2018-05-11 14:31:00 UTC
Created attachment 142035 [details]
File .doc
Comment 2 Roman Kuznetsov 2018-05-11 14:31:55 UTC
in 6.0.4.1 text in list looks like a text -> regression
Comment 3 Roman Kuznetsov 2018-05-11 14:34:02 UTC
bug in 
Version: 6.1.0.0.alpha1+
Build ID: 4374f8b621dbefcb0a78a8005db48eb25675bf3c
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-11_05:17:28
Locale: ru-RU (ru_RU); Calc: group
Comment 4 Roman Kuznetsov 2018-05-11 14:40:38 UTC
Created attachment 142036 [details]
Screenshot for illustration of problem
Comment 5 Mike Kaganski 2018-05-11 16:22:22 UTC
Reproducible with Version: 6.1.0.0.alpha1+ (x64)
Build ID: 2de80f9a21f9601b75a2f43c07eb3e0a6509b1e6
CPU threads: 12; OS: Windows 10.0; UI render: default; 
Locale: ru-RU (ru_RU); Calc: CL

To reproduce, it's important to disable OpenGL.
Toggling Formatting marks (Ctrl+F10), the paragraphs after the round bullet become garbled (when formatting marks are *not* shown) and normal (when formatting marks are shown).
Comment 6 Mike Kaganski 2018-05-11 16:51:46 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=bdccb7e9991d83029eb2f2f11327b54534a00db8

Adding Khaled Hosny and Jan-Marek Glogowski.
Comment 7 Khaled Hosny 2018-05-11 23:50:56 UTC
How did it look like before this commit?
Comment 8 Mike Kaganski 2018-05-12 04:08:23 UTC
Created attachment 142041 [details]
Screenshot of state of commit 9615e45d2e2bac79c252a018846e4f20012cfa34

It looked like it looks currently in OpenGL mode, and also with "default" render with shown formatting marks (modulo formatting marks themselves :) )
Comment 9 Xisco Faulí 2018-06-05 21:04:37 UTC
Adding Cc: to Jan-Marek Glogowski
Comment 10 Xisco Faulí 2018-07-10 13:57:52 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: c290f692dd28094d41dff686f3faa1c4e14b556e
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: group threaded

@Jan-Marek, thanks for fixing this! Should it be closed as RESOLVED FIXED?
Comment 11 Roman Kuznetsov 2018-07-10 14:05:43 UTC
(In reply to Xisco Faulí from comment #10)
 
> @Jan-Marek, thanks for fixing this! Should it be closed as RESOLVED FIXED?

Where is a commit?