Bug 117887 - OpenGL Rendering Bug with SmartArt
Summary: OpenGL Rendering Bug with SmartArt
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: CommonSalLayout-refactoring-regressions
  Show dependency treegraph
 
Reported: 2018-05-29 17:50 UTC by Luke
Modified: 2018-07-12 10:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the issue (225.65 KB, image/png)
2018-05-29 17:50 UTC, Luke
Details
Bibisect log (2.91 KB, text/plain)
2018-05-30 14:05 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2018-05-29 17:50:53 UTC
Created attachment 142390 [details]
Screenshot of the issue

Steps to reproduce:
1. In a recent build of LibreOffice open attachment 81684 [details]
2. Note the SmartArt on the right of the page
3. Tools->Option->View->Uncheck "Use OpenGL for all rendering"
4. Compare

Version: 6.1.0.0.alpha1+
Build ID: 137c38a1ba01c51c421f695e1558d2c1499c6627
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-21_20:52:36
BAD
Comment 1 Christoffer 2018-05-29 18:27:14 UTC
Looks like the same issue as https://bugs.documentfoundation.org/show_bug.cgi?id=117861
Comment 2 Telesto 2018-05-30 13:17:26 UTC
Repro
Version: 6.2.0.0.alpha0+
Build ID: 938ec2597be2e0ad3af2fb99f77de7f87285ad86
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-25_23:38:38
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Telesto 2018-05-30 14:05:22 UTC
Created attachment 142409 [details]
Bibisect log

Bisected to
author	Jan-Marek Glogowski <glogow@fbihome.de>	2017-12-26 15:14:31 +0000
committer	Khaled Hosny <khaledhosny@eglug.org>	2018-05-08 00:55:27 +0200
commit	bdccb7e9991d83029eb2f2f11327b54534a00db8 (patch)
tree	c32e95c49849647dc72c1071f375f3d2b67d8d7a
parent	9615e45d2e2bac79c252a018846e4f20012cfa34 (diff)
Refactor CommonSalLayout font handling
Moves all platform specific code from CommonSalLayout into the
platform specific plugins. This way the vcl library won't depend
on the Qt5 libraries and the Qt5Font header can be moved into the
qt5 VCL plugin.

While at it, switch the CommonSalLayouts font reference from the
FontSelectPattern to the LogicalFontInstance and also add the
harfbuzz font handling to the instance.
Comment 4 Xisco Faulí 2018-06-05 21:04:12 UTC
Adding Cc: to Jan-Marek Glogowski
Comment 5 V Stuart Foote 2018-07-11 20:49:20 UTC
Should be fixed, sample document appears correct.

Retest with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 86ca9badf9be518be3456afde70271bc1f956065
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-11_02:27:04
Locale: en-US (en_US); Calc: CL

or later

=-ref-=

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fad862e290d727fc9fefe206f6e4b807482c4175

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ca4e75d694a5fb41a1c800146319aa6ba34d8bab