Bug 117694 - Firebird: Migration: Column names with spaces generate error
Summary: Firebird: Migration: Column names with spaces generate error
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Firebird-Migration
  Show dependency treegraph
 
Reported: 2018-05-18 15:59 UTC by Drew Jensen
Modified: 2018-10-19 07:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Two table test file (3.19 KB, application/vnd.oasis.opendocument.database)
2018-05-18 15:59 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-05-18 15:59:15 UTC
Description:
Both HSQL and FB support spaces in column names, the migration script breaks on the first space a column name.

Steps to Reproduce:
1. Download and open attached file.
2. Click on Tables, Start the migration process (click Yes)


Actual Results:  
While working with Table1 this Error message is displayed.
Error code: 1

firebird_sdbc error:
*Dynamic SQL Error
*SQL error code = -104
*Unexpected end of command - line 1, column 122
caused by
'isc_dsql_prepare'

Clear the message box and the migration successfully migrates Table2

Expected Results:
Table should migrate as is.


Reproducible: Always


User Profile Reset: No



Additional Info:
In Table1 the column name is 'a col name'
In Table2 the column name is 'a_col_name'


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/66.0.3359.139 Chrome/66.0.3359.139 Safari/537.36
Comment 1 Drew Jensen 2018-05-18 15:59:58 UTC
Created attachment 142191 [details]
Two table test file

Two tables, Table1 (breaks) and Table2 (works)
Comment 2 Drew Jensen 2018-05-18 16:05:40 UTC
This problem was reported via comment on another issue
https://bugs.documentfoundation.org/show_bug.cgi?id=117670#c2
based on some debug information.
Comment 3 raal 2018-05-18 17:17:06 UTC
Confirm . Version: 6.1.0.0.alpha1+
Build ID: 59ef304cff3b363fdcbf8bc56762c9349de78d24
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2;
Comment 4 Xisco Faulí 2018-06-06 17:33:21 UTC
No longer reproducible in

Version: 6.1.0.0.beta1+
Build ID: 8b96445766efe237eb47608ade6c147673466e2e
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

This has been fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=9082e37400baf75296cb94c5588ddeb3d18f0b09

@Julien, thanks for fixing this!!