Bug Hunting Session
Bug 117720 - Delete item Maximum from drop-down list Minimum and delete item Minimum from drop-down list Maximum in dialogue Conditional Formatting
Summary: Delete item Maximum from drop-down list Minimum and delete item Minimum from ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium minor
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.3.0
Keywords: needsDevAdvice
Depends on:
Blocks: Conditional-Formatting Conditional-Formatting-Editing
  Show dependency treegraph
 
Reported: 2018-05-21 08:59 UTC by Roman Kuznetsov
Modified: 2018-11-26 19:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-05-21 08:59:05 UTC
Description:
Delete item Maximum from drop-down list Minimum and delete item Minimum from drop-down list Maximum in dialogue Conditional Foramtting for variants:
All cells - Color Scale (2 Entries)
All cells - Color Scale (3 Entries)
All cells - Data bar

Steps to Reproduce:
1. Open Calc
2. Open dialogue Conditional Formatting and push Add
3. Select variant All cells - Color Scale (2 Entries)
4. Select in left drop-down list item Maximum and in right drop-down list select -> this variant does not work correctly. It is just not logical

I offer Delete item Maximum from drop-down list Minimum and delete item Minimum from drop-down list Maximum

FYI: in MS Excel there isn't item Maximum in drop-down list Minimum and there isn't item Minimum in drop-down list Maximum 

Actual Results:  
we have not logical items in drop-down lists for some variants of conditional formatting

Expected Results:
we have items in drop-down lists, that do not contradict common sense


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
Comment 1 Jacques Guilleron 2018-05-21 13:47:57 UTC
Hi kompilainenn,

This would be clearer, since that is a reverse setting to what is proposed, but does not work this way for now. Colors too can be changed to get the same effect.
Comment 2 Commit Notification 2018-11-26 17:39:00 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d608b0af3f855e01535f40f3473dbee03d581863%5E%21

tdf#117720 Delete Max from list Min and delete Min from list Max in CF dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Roman Kuznetsov 2018-11-26 19:12:33 UTC
Thank you, Mike