Bug 117830 - Wrong header/footer shown for intermittent section in DOC(X)
Summary: Wrong header/footer shown for intermittent section in DOC(X)
Status: RESOLVED DUPLICATE of bug 89297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on:
Blocks: DOCX DOC Section
  Show dependency treegraph
 
Reported: 2018-05-27 06:53 UTC by Aron Budea
Modified: 2019-01-13 22:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOCX (14.90 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-05-27 06:53 UTC, Aron Budea
Details
Sample DOC (23.50 KB, application/msword)
2018-05-27 06:54 UTC, Aron Budea
Details
PDF exported in Word (86.67 KB, application/pdf)
2018-05-27 06:55 UTC, Aron Budea
Details
Screenshot in Word (DOCX) (40.89 KB, image/png)
2018-06-18 21:53 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-05-27 06:53:43 UTC
Created attachment 142302 [details]
Sample DOCX

The attached documents (both DOC and DOCX are the same) start with a continuous section break, and have a section break (next page) on the 2nd page. The header/footer is different for the 1st section, but is the same for sections 2&3.

In Word the 2nd page shows the 2nd header/footer, which is logical, because the first section break is on the first page.
In Writer the 2nd page shows the 1st header/footer.

Additionally, in Writer the DOC has no header/footer on the 3rd page.

Observed using LO 6.2 master daily build (f7f2d03bd6f5aa5dcd0f7976b4a7f2db278c2f03, 2018-05-25_05:00:28) & 4.0.0.3 / Windows 7. DOCX is imported even worse in 4.0.0.3.
Comment 1 Aron Budea 2018-05-27 06:54:17 UTC
Created attachment 142303 [details]
Sample DOC
Comment 2 Aron Budea 2018-05-27 06:55:28 UTC
Created attachment 142304 [details]
PDF exported in Word
Comment 3 Dieter Praas 2018-06-18 21:18:44 UTC
Regarding to the navigator, there is only one section in each document. So where are sections 2&3?
Comment 4 Aron Budea 2018-06-18 21:53:42 UTC
Created attachment 142891 [details]
Screenshot in Word (DOCX)

Please see the attached screenshot.
Comment 5 Dieter Praas 2018-06-19 12:21:29 UTC
I'm no expert in sections, but I see more than one section in your screenshot an alsop section breaks. When I open it in writer, I hve only one section. I assume, that section in writer has the same meaning as section in word. So does the file looses sections when it is opened in writer?
Comment 6 Buovjaga 2018-06-19 19:19:06 UTC
Confirmed.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: dc9ee533dc707cc10b99d537eaccc3ee5aa555fe
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 16th 2018
Comment 7 Justin L 2018-12-14 07:43:40 UTC
LO has no support for continuous sections. I notice that after the page break, the header/footer changes as expected. So, this works as good as can be expected.

*** This bug has been marked as a duplicate of bug 121888 ***
Comment 8 Aron Budea 2019-01-13 22:05:01 UTC

*** This bug has been marked as a duplicate of bug 89297 ***