Bug 121888 - When opening a .docx that has a section break continuous or next page it does not break in LibreOffice
Summary: When opening a .docx that has a section break continuous or next page it does...
Status: RESOLVED DUPLICATE of bug 89297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX Section
  Show dependency treegraph
 
Reported: 2018-12-03 21:22 UTC by fs
Modified: 2018-12-14 09:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
file has section break on page 3 (32.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-12-04 12:45 UTC, fs
Details
Comparison LibreOffice 6.2 and MSO 2010 (164.66 KB, image/png)
2018-12-10 16:28 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fs 2018-12-03 21:22:54 UTC
Description:
I am trying to use a different footer on page 5 of my document. When I make a section break on page 4 in .docx i am able to make a different footer on page 5 because it is a different section. 
When i open that .docx in LibreOffice the section break is not there and the footer on page 5 is the same as the footer on page 4. 

Steps to Reproduce:
1. Make section break in .docx
2. save file
3. Open with LibreOffice 

Actual Results:
No break in LibreOffice

Expected Results:
Break in LibreOffice 


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Timur 2018-12-04 12:10:05 UTC
Not clear. 
Is  .docx created in MSO or LO?
Please attach the file.
Comment 2 fs 2018-12-04 12:45:21 UTC
Created attachment 147271 [details]
file has section break on page 3

The attached file was created in MSO 
If you open the attached file using Microsoft word, you will see that at the end of the third page I made a continuous section break in the .docx file. 
This allows the header and footer on page 4 and for the remaining pages to be a different header and footer. 
If you open this file using LibreOffice you will see that it does not recognize the section break and that all headers and footer on the document are the same.
Comment 3 Timur 2018-12-05 12:38:13 UTC
Confirmed with 6.3+. No repro with LO 5.2.0. Looks like regression from 5.2.2.
Comment 4 Xisco Faulí 2018-12-10 16:28:32 UTC
Created attachment 147429 [details]
Comparison LibreOffice 6.2 and MSO 2010
Comment 5 Xisco Faulí 2018-12-10 16:43:52 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=50bf96d31ab2eb546f6c71cc93c1fa5dd4bf3044

author	Justin Luth <justin_luth@sil.org>	2016-06-25 22:21:08 +0300
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-06-29 07:35:54 +0000
commit	50bf96d31ab2eb546f6c71cc93c1fa5dd4bf3044 (patch)
tree	6fa465f41eb719352e2c9d730cd452fd5bf41d17
parent	1294013bf5d373ded1d050370569acdc2b68c5f5 (diff)
tdf#90697 docx - don't change continuous break into page break

Bisected with: bibisect-linux-64-5.3 

Adding Cc: to Justin Luth
Comment 6 Justin L 2018-12-14 07:20:50 UTC
You missed actually CC'ing me - I just stumbled across this.

LibreOffice has no support for continuous sections at all.  This will never work unless the internals of LibreOffice are re-written.
If you want to make a compatible document, you need to do a page-break instead of a continuous break.
Comment 7 Justin L 2018-12-14 07:43:40 UTC
*** Bug 117830 has been marked as a duplicate of this bug. ***
Comment 8 Justin L 2018-12-14 09:50:51 UTC

*** This bug has been marked as a duplicate of bug 89297 ***