Download it now!
Bug 117872 - LO61b1: On macOS in Impress slide show does not run full screen
Summary: LO61b1: On macOS in Impress slide show does not run full screen
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Tor Lillqvist
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2018-05-29 09:53 UTC by Martin Srebotnjak
Modified: 2019-10-17 01:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot when ODP launched in fullscreen display mode (F5) (52.13 KB, image/png)
2018-05-29 10:25 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2018-05-29 09:53:09 UTC
Description:
On macOS (macOS 10.13.4, on 13" macbook air) unlike in previous versions a presentation does not start in a full screen mode; it starts in a less-than full screen.

Steps to Reproduce:
1. Open a presentation on macOS in LO61b1.
2. Start the slide show.
3.

Actual Results:  
The slide show opens in a special window, that is not full screen, it is like 70 % of the display area.
Also, this sub-screen/window is centrally positioned and cannot be moved.

Expected Results:
The slide show opens full screen.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Alex Thurgood 2018-05-29 10:21:03 UTC Comment hidden (obsolete)
Comment 2 Alex Thurgood 2018-05-29 10:22:46 UTC
@Martin : forget that last comment, I misread your instructions.

Testing with 

Version: 6.2.0.0.alpha0+
Build ID: 7f3c2ee6c135773c98ded063bdf10ec8900bf00f
CPU threads: 4; OS: Mac OS X 10.13.4; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group threaded

and confirming.

@Tor : not anything related to your recent fullscreen code changes by any chance ?
Comment 3 Alex Thurgood 2018-05-29 10:25:00 UTC
Created attachment 142373 [details]
Screenshot when ODP launched in fullscreen display mode (F5)

I am enclosing a screenshot of what this looks like on master 6.2alpha
Comment 4 Tor Lillqvist 2018-05-29 11:41:05 UTC
Argh. Apparently caused by 4b42fd7e9516fbbd8a92d97680524f32dd260fb2. Maybe I should just revert that then and instead apply https://gerrit.libreoffice.org/#/c/48796/
Comment 5 Tor Lillqvist 2018-05-30 08:58:54 UTC
Suggested fix at https://gerrit.libreoffice.org/#/c/55049/ .
Comment 6 Commit Notification 2018-05-30 11:51:34 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1452e73091412ba0bb72306329e1912df2ba513

tdf#117872: Revert "tdf#115284: Unify LibreOffice and system full-screen..."

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-05-30 17:28:25 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fb4b2548289db4d36a7becd249fef20e7d76b86&h=libreoffice-6-1

tdf#117872: Revert "tdf#115284: Unify LibreOffice and system full-screen..."

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-06-04 13:39:11 UTC
A polite ping to Tor Lillqvist:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks