Bug 115284 - Shortcut and behaviour of fullscreen mode on macOS
Summary: Shortcut and behaviour of fullscreen mode on macOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.2.0 target:6.1.0.1
Keywords:
: 118130 122137 123580 123677 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist Shortcuts-Mac Full-Screen-Mode
  Show dependency treegraph
 
Reported: 2018-01-28 17:53 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-03-20 18:33 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2018-01-28 17:53:05 UTC
Bug 98290 that is dealing with improving mac shortcuts has alot of comments about the shortcut for fullscreen mode, so i'm opening this bug report to deal with that discussion.

(In reply to Tor Lillqvist from comment #16)
> I find it somewhat sad that the change in comment #9 are implemented without
> checking how confusing it ends up working in the end. Steve, you say
> "Fullscreen (ctrl cmd F) is identical to fullscreen triggered via the green
> bubble." It very obviously is not. Did not actually check? Did you not see
> any difference in look or behaviour?

I just tested it and yes the behaviour is different, as they are different concepts. Mac's fullscreen is to have the application window take up the fullscreen and LO's fullscreen is to have the document area take up the fullscreen.

> I really think making the Ctrl+Cmd+F shortcut toggle LO's own "full-screen"
> mode was a mistake. That shortcut should mean the same as clicking the green
> bubble on the title bar. It does not. We should have kept the old shortcut
> to avoid confusing the two concepts.

I guess this is true as other apps (i tested firefox) that have document area fullscreen on windows and linux dont utilize Ctrl+Cmd+F in Mac for document area fullscreen.

> I repeat, I think we should just remove the current hack to "support" macOS
> full-screen mode from the code. I will do that when/if I can find
> inspiration. Then just LO's own "full-screen" thing will remain.
>
> Sure, that is far from ideal. What *should* be done, if somebody had the
> inspiration and resources, would be to get rid of LO's own full-screen mode
> completely on macOS, and just implement the macOS full-screen mode properly.

I would be infavour of disabling the Mac fullscreen functionality (disabling the green bubble toggle) and keeping LO's fullscreen functionality and improving LO's fullscreen functionality by hiding the titlebar, just like its hidden in windows and linux. If the plan is to disable the Mac fullscreen functionality, then there isnt a need to change the Ctrl+Cmd+F shortcut from LO's fullscreen functionality.
Comment 1 Alex Thurgood 2018-01-29 08:02:11 UTC
OK, so my ha'penneth would be rather to enable native OSX fullscreen support properly and disable LO's pseudo attempt to do this.

Either we want an app that behaves like a good citizen of the native macOS application world, or we don't, if we decide on not going down that route, then we should also make that perfectly clear to end users...

Setting to new and RFE
Comment 2 Tor Lillqvist 2018-01-29 08:12:41 UTC
Yousuf, Firefox is not necessarily a good application to compare with if you want to figure out what the "ideal" native full-screen look&feel is, as it is also a cross-platform app that is playing catch-up with Apple's ideas;) Better to look at some of Apple's own apps, like Pages, iTunes, Photos.

Alex, I agree of course. That's what we should do. Eventually.
Comment 3 Heiko Tietze 2018-01-29 08:47:02 UTC
I would keep the current implementation as our full screen mode is superior to what macOS does. It is a distraction free view to the document area without any toolbar/sidebar controls. The mac full screen just maximizes the window - and hides the title bar in contrast to other OS. And you can always use both.

The shortcut ctrl+cmd+F is used at Finder and Chrome and some kind of standard, isn't it?
Comment 4 Tor Lillqvist 2018-01-29 08:59:42 UTC
Heiko, that sounds mostly like prejudice. In fact, the Apple guidelines for Full-Screen Mode use the same wordings as you do;) So it is just up to the application to behave like that in Full-Screen Mode. If some sample apps (even Apple ones) don't (but just expand the UI to fill the screen but including all the same GUI), well, that is not the fault of the APIs and reason enough to not use the system APIs for full-screen mode.

I quote from https://developer.apple.com/macos/human-interface-guidelines/app-architecture/fullscreen-mode/ : "An app window in full-screen mode offers a distraction-free working environment. Toolbars, menus, and other standard controls are often hidden and revealed only when the user calls for them, such as by moving the pointer to the top of the screen. Some apps even hide essential controls to increase the focus on content. The controls are hidden, for example, when playing a movie in QuickTime Player or a slideshow in Photos."
Comment 5 Heiko Tietze 2018-01-29 09:04:33 UTC
(In reply to Tor Lillqvist from comment #4)

I don't see any need for action as you can enable the macOS full screen mode with the green bubble. Plus, LibreOffice gives you a second way to show the document with the inbuilt full screen mode. Thus we shouldn't remove one of the two options as they serve different scenarios.
Comment 6 Tor Lillqvist 2018-01-29 09:32:00 UTC
Heiko, so you claim that nobody can ever be confused by these two very different modes? That everybody will always know that they are separate concepts, and never accidentally mix them? (Example scenario that leads to a very confusing situation: Press Cmd+Shift+F which invokes the home-grown full-screen mode, but then try to get out of that by clicking the green button, which additionally puts the window in system full-screen mode, then notice the floating "Full Screen" button, click that.)
Comment 7 Yousuf Philips (jay) (retired) 2018-01-31 04:21:05 UTC
(In reply to Alex Thurgood from comment #1)
> OK, so my ha'penneth would be rather to enable native OSX fullscreen support
> properly and disable LO's pseudo attempt to do this.

I maybe wrong, but LO already has OSX fullscreen support when you click the green bubble button in the title bar, though it likely needs work as i see a black empty bar at the top above the toolbars.

> Either we want an app that behaves like a good citizen of the native macOS
> application world, or we don't, if we decide on not going down that route,
> then we should also make that perfectly clear to end users...

LO having OSX fullscreen support doesnt mean that we cant also have LO fullscreen support, only that we should likely use a different shortcut for them, so mac users arent focused.

(In reply to Tor Lillqvist from comment #2)
> Yousuf, Firefox is not necessarily a good application to compare with if you
> want to figure out what the "ideal" native full-screen look&feel is, as it
> is also a cross-platform app that is playing catch-up with Apple's ideas;)
> Better to look at some of Apple's own apps, like Pages, iTunes, Photos.

I had already tested Pages and Safari and its fullscreen support was identical to Firefox's (simply hide menubar and titlebar), but mentioned Firefox as it is a cross-platform app like LO, and on windows and linux it has document area fullscreen support and doesnt have the feature on mac. Tested Chrome just now and it is similar to Firefox.

(In reply to Tor Lillqvist from comment #4)
> Heiko, that sounds mostly like prejudice. In fact, the Apple guidelines for
> Full-Screen Mode use the same wordings as you do;) So it is just up to the
> application to behave like that in Full-Screen Mode.

So if i get this correctly, you want to implement LO's fullscreen mode but be able to toggle it with OSX fullscreen mode green button and shortcut.

> If some sample apps
> (even Apple ones) don't (but just expand the UI to fill the screen but
> including all the same GUI), well, that is not the fault of the APIs and
> reason enough to not use the system APIs for full-screen mode.

If apps, even Apple ones, have a OSX fullscreen mode that simply fills the app on the screen, wouldnt users want that same functionality in a fullscreen mode with LO when toggled with the green bubble and not what LO defines as a fullscreen mode?
Comment 8 Tor Lillqvist 2018-01-31 07:03:30 UTC
> So if i get this correctly, you want to implement LO's fullscreen mode but be able to toggle it with OSX fullscreen mode green button and shortcut.

Yes.

> wouldnt users want that same functionality in a fullscreen mode with LO when toggled with the green bubble and not what LO defines as a fullscreen mode

How is that different from maximising the window (double-clicking the title bar)?
Comment 9 Yousuf Philips (jay) (retired) 2018-02-02 14:17:48 UTC
(In reply to Tor Lillqvist from comment #8)
> How is that different from maximising the window (double-clicking the title
> bar)?

Maximizing by double-clicking the title bar doesnt hide the application dock at the bottom if its set to always appear and in some apps, maximizing doesnt extend the left and right sides of the window to extend to the edges of the screen, if they arent already touching the edges.
Comment 10 Tor Lillqvist 2018-05-24 11:43:28 UTC
Suggested fix in https://gerrit.libreoffice.org/#/c/54760/ . 

The fix still leaves some minor ugliness in the full-screen support. But the resources (time) available to work on this crack are limited. The alternative would be to simply not participate in the system full-screen mode at all, https://gerrit.libreoffice.org/#/c/48796/ . So don't tempt me.
Comment 11 Commit Notification 2018-05-24 13:40:37 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b42fd7e9516fbbd8a92d97680524f32dd260fb2

tdf#115284: Unify LibreOffice and system full-screen concepts on macOS

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-05-30 11:51:42 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1452e73091412ba0bb72306329e1912df2ba513

tdf#117872: Revert "tdf#115284: Unify LibreOffice and system full-screen..."

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-05-30 17:28:33 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fb4b2548289db4d36a7becd249fef20e7d76b86&h=libreoffice-6-1

tdf#117872: Revert "tdf#115284: Unify LibreOffice and system full-screen..."

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Alex Thurgood 2018-06-18 10:40:42 UTC
*** Bug 118130 has been marked as a duplicate of this bug. ***
Comment 15 V Stuart Foote 2018-12-16 16:52:09 UTC
*** Bug 122137 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2019-02-25 08:42:06 UTC
*** Bug 123677 has been marked as a duplicate of this bug. ***
Comment 17 Alex Thurgood 2019-02-25 08:45:40 UTC
*** Bug 123580 has been marked as a duplicate of this bug. ***
Comment 18 steve -_- 2019-03-03 12:18:18 UTC
What's not working here? ctrl + cmd + f goes to fullscreen, esc closes fullscreen.

I am unable to reproduce the faulty behavior described in https://bugs.documentfoundation.org//show_bug.cgi?id=123677 "any libre office window should not be put in full screen mode, otherwise it can't be brought back to the windowed mode, there is a black line on top instead of the regular menus, and a black screen appears amongst other fullscreen apps." on macOS 10.14.3 w LO 6.2.0.3

@alex can you elaborate what's missing here? should we file a new bug for the remaining issues (unclear what those are) to have a clean report? Setting to NEEDINFO, please set to state according to your decision to proceed in this case.
Comment 19 Xisco Faulí 2019-03-20 18:33:05 UTC
(In reply to steve -_- from comment #18)
> What's not working here? ctrl + cmd + f goes to fullscreen, esc closes
> fullscreen.
> 
> I am unable to reproduce the faulty behavior described in
> https://bugs.documentfoundation.org//show_bug.cgi?id=123677 "any libre
> office window should not be put in full screen mode, otherwise it can't be
> brought back to the windowed mode, there is a black line on top instead of
> the regular menus, and a black screen appears amongst other fullscreen
> apps." on macOS 10.14.3 w LO 6.2.0.3
> 
> @alex can you elaborate what's missing here? should we file a new bug for
> the remaining issues (unclear what those are) to have a clean report?
> Setting to NEEDINFO, please set to state according to your decision to
> proceed in this case.

I think we can close this issue as RESOLVED FIXED.
If you want any related issue, please report a follow-up bug....