Bug 72490 - Full screen doesn't close after CMD + W (close) on macOS
Summary: Full screen doesn't close after CMD + W (close) on macOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: All Mac OS X (All)
: medium normal
Assignee: Tor Lillqvist
URL:
Whiteboard:
Keywords:
: 83378 88424 99087 100804 117163 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist Full-Screen-Mode
  Show dependency treegraph
 
Reported: 2013-12-08 18:26 UTC by Erkan
Modified: 2019-03-03 12:59 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Grey desktop (876.21 KB, image/png)
2013-12-08 18:26 UTC, Erkan
Details
black screens produced by bringingi up "options" in fullscreen mode (816.11 KB, image/png)
2016-02-01 06:31 UTC, Orion
Details
screencast of the issue (1.46 MB, audio/ogg)
2016-08-24 09:59 UTC, Marina Latini (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erkan 2013-12-08 18:26:52 UTC
Created attachment 90473 [details]
Grey desktop

A full screen of LibreOffice 4.2 doesn't close after I want close program example Writer or Calc with W + CMD (no exit of LibreOffice). I got a grey desktop. See an attachment.
When I want open new Writer or Calc, than is another (grey) desktop still save without close. )-:
Comment 1 Jorendc 2013-12-08 18:40:00 UTC
Confirmed, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d

Please note clearly this is NOT a dupe of Bug 53282
Bug 53282 is about closing a document when using the full-screen feature of LibreOffice (cmd+shift+J), THIS is about using the full-screen feature in the right upper corner at the title-bar.

Kind regards,
Joren
Comment 2 retired 2014-04-22 11:25:24 UTC
More detail on this: e.g. Apples own mail.app doesn't do anything when being in fullscreen and cmd + w is pressed. I think LO should behave the same i.e. ignore that command when being in fullscreen.

As an alternative behavoir, LO could close the current document displayed and show any other open LO documents. If no further LO document is currently open, close fullscreen mode.
Comment 3 QA Administrators 2015-06-08 14:42:32 UTC Comment hidden (obsolete)
Comment 4 Alex Thurgood 2015-10-12 10:13:26 UTC
*** Bug 88424 has been marked as a duplicate of this bug. ***
Comment 5 Alex Thurgood 2015-10-12 10:14:27 UTC
Still present in 

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale : fr-FR (fr.UTF-8)

OSX 10.11
Comment 6 Orion 2015-10-12 18:39:52 UTC
Confirmed in: 

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-CA (en_CA.UTF-8)
Comment 7 Orion 2016-02-01 06:28:33 UTC
Confirmed in 5.0.4 on El Capitan (black screens instead of grey screens).
Comment 8 Orion 2016-02-01 06:31:30 UTC
Created attachment 122308 [details]
black screens produced by bringingi up "options" in fullscreen mode
Comment 9 ace_dent 2016-05-10 11:50:28 UTC
Tested with: Mac OS X El Capitan 10.11.4 (15E2066) with LibreOffice Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default.

It seems using the native OSX full-screen behaviour (which now puts the zoomed in window in it's own space), is broken. The central issue is how LO handles Spaces on OSX.

Workaround: Double click on the window's title bar to maximise the window (like 'full screen' in earlier OSX versions).

Related, possibly duplicated, issues ~ 
Missing menu bar: #53282, #76476, #96134, #97402, #97709.
Extra blank screen: (black- was grey) #72490, #83378, #96134.
General: #85259, #95362.
Comment 10 Alex Thurgood 2016-07-18 08:55:26 UTC
*** Bug 100804 has been marked as a duplicate of this bug. ***
Comment 11 Marina Latini (CIB) 2016-08-24 09:59:22 UTC
Created attachment 127000 [details]
screencast of the issue

The issue occurs also using the "x" icon on the toolbar instead of CMD+W

repro on:

Versione: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Versione locale: it-IT (it.UTF-8)

Version: 5.2.0.4 
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265 
CPU Threads: 8; OS Version: Mac OS X 10.11.6; UI Render: default; 
Locale: en-US (en.UTF-8) 

Version: 5.1.5.2
Build ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
CPU Threads: 8; OS Version: Mac OS X 10.11.6; UI Render: default; 
Locale: en-US (en.UTF-8); Calc: group
Comment 12 QA Administrators 2017-11-16 09:22:35 UTC Comment hidden (obsolete)
Comment 13 Orion 2017-11-17 00:09:51 UTC
This bug still exists. 

Version: 5.3.6.1
Build ID: 686f202eff87ef707079aeb7f485847613344eb7
CPU Threads: 4; OS Version: Mac OS X 10.13.1; UI Render: default; Layout Engine: new; 
Locale: en-CA (en_CA.UTF-8); Calc: group
Comment 14 eisa01 2018-04-02 11:50:19 UTC
*** Bug 83378 has been marked as a duplicate of this bug. ***
Comment 15 eisa01 2018-04-02 12:10:46 UTC
*** Bug 99087 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2018-04-23 07:44:02 UTC
*** Bug 117163 has been marked as a duplicate of this bug. ***
Comment 17 Tor Lillqvist 2018-05-29 11:05:51 UTC
Behaviour now changed a lot after:

commit 4b42fd7e9516fbbd8a92d97680524f32dd260fb2
Author: Tor Lillqvist <tml@collabora.com>
Date:   Wed May 23 23:21:21 2018 +0300

    tdf#115284: Unify LibreOffice and system full-screen concepts on macOS
    
    Also tdf#76476, and probably more.
    
    Make it so that when a window is in full-screen mode from
    LibreOffice's point of view, it is also full-screen from the system's
    point of view, and vice versa.
    
    All three ways to enter and leave full-screen mode can now be used
    with the same end result: The Ctrl-Cmd-F shortcut, the "View > Full
    Screen" menu entry, and the green bubble on the title bar.
    
    Don't disable/deactivate/etc menus while in full-screen mode. The menu
    auto-hides so there is no harm in having it function normally.
    
    Don't display the floating toolbar with a single "Full Screen" button
    in it as the way to leave full-screen mode. Instead, the same three
    ways that can be used to enter full-screen mode work to leave it, too.
    
    Sadly I could not figure out a way to set a window properly to
    full-screen at the point where a document window is created and set to
    be the same size as that kind of document window was the previous time
    it was open in LibreOffice. Thus don't save state for full-screen
    windows as we can't properly restore them. At least not for macOS. It
    is not good to just restore them as non-full-screened but still at the
    size they had when full-screen.
    
    One irritating glitch remains, and I was unable to fix that properly:
    I now prevent closing the document window that is in full-screen mode.
    Otherwise, if it is closed, the full-screen mode remains even if no
    window is open there; the desktop is completely black. Moving the
    cursor to the top edge, the LibreOffice menu is there, though. I tried
    to fix that but with no fully satisfying result. (Some attempts even
    lead to crashes, so just disabling closing is better than crashing at
    least.)
    
    Change-Id: Id909077ef9de9f19d48c8b9ad10d748a65b2417f
    Reviewed-on: https://gerrit.libreoffice.org/54760
    Tested-by: Jenkins <ci@libreoffice.org>
    Reviewed-by: Tor Lillqvist <tml@collabora.com>
Comment 18 steve -_- 2019-03-03 12:24:22 UTC
WORKSFORME on macOS 10.14.3 + LO 6.2.0.3

Steps

1. Open LO
2. ctrl + cmd + f to switch to fullscreen
3. cmd + w to close fullscreen window without exiting LO

Expected

close fullscreen window, and have LO still open and active.

setting to fixed as per tors commit and assigning tor. unassign if you disagree and reopen this bug should I have missed something.

i would propose to file a new bug for any remaining macOS fullscreen shenanigans to start with a clear report and have a focus on the remaining issue at hand.