Bug Hunting Session
Bug 97709 - Full-screen mode results in black bar at the top of the screen
Summary: Full-screen mode results in black bar at the top of the screen
Status: RESOLVED DUPLICATE of bug 97402
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-10 14:18 UTC by pljcbsn
Modified: 2016-11-14 15:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the black bar in full-screen mode (18.85 KB, image/png)
2016-02-10 14:18 UTC, pljcbsn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pljcbsn 2016-02-10 14:18:13 UTC
Created attachment 122497 [details]
Screenshot of the black bar in full-screen mode

I noticed that when I go full-screen in LibreOffice on my Mac (OS 10.11.3), there is a black bar at the top of the screen above the toolbar.
Comment 1 Colin 't Hart 2016-02-11 22:13:32 UTC
I can confirm this. Not just in Writer but in all modules that I've tried, including the "main" window when LibreOffice is launched.
Comment 2 Joel Madero 2016-02-12 06:19:22 UTC
Can you guys tell us what version of LibreOffice you're running? Also is this a regression compared to older versions?d 

Marking as NEEDINFO as we need versions of LibreOffice. Once you give us this info please set to UNCONFIRMED.
Comment 3 pljcbsn 2016-02-13 08:58:14 UTC
I changed the version to the current release version, 5.1.0.3. I noticed it in version 5.0.x releases too.
Comment 4 Joel Madero 2016-02-13 19:01:41 UTC
Version is earliest version ("Version: earliest affected). Would be really nice to know if it's a regression by testing older releases:

http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 5 Buovjaga 2016-03-13 18:39:24 UTC
Please test with an old version to find out the last version it worked in: https://wiki.documentfoundation.org/Installing_in_parallel/OS_X

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 6 ace_dent 2016-05-10 11:49:02 UTC
Tested with: Mac OS X El Capitan 10.11.4 (15E2066) with LibreOffice Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default.

It seems using the native OSX full-screen behaviour (which now puts the zoomed in window in it's own space), is broken. The central issue is how LO handles Spaces on OSX.

Workaround: Double click on the window's title bar to maximise the window (like 'full screen' in earlier OSX versions).

Related, possibly duplicated, issues ~ 
Missing menu bar: #53282, #76476, #96134, #97402, #97709.
Extra blank screen: (black- was grey) #72490, #83378, #96134.
General: #85259, #95362.
Comment 7 Telesto 2016-11-14 15:25:09 UTC

*** This bug has been marked as a duplicate of bug 97402 ***