Bug 76476 - macOS: There is a black bar on top when entering native full-screen mode
Summary: macOS: There is a black bar on top when entering native full-screen mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 91086 97402 101937 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist Full-Screen-Mode
  Show dependency treegraph
 
Reported: 2014-03-22 10:37 UTC by Adriano Borgobello
Modified: 2018-06-01 15:51 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice in fullscreen mode (137.83 KB, image/png)
2014-03-22 10:37 UTC, Adriano Borgobello
Details
macOS split view with LibreOffice (left) and NeoOffice (right) (200.30 KB, image/png)
2017-11-16 15:00 UTC, Adriano Borgobello
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adriano Borgobello 2014-03-22 10:37:33 UTC
Created attachment 96198 [details]
LibreOffice in fullscreen mode

In Mac OS fullscreen mode (Mac OS X > 10.7), menubar will disappear (correctly) but screen will not be resized to hide the withe ribbon. Look at Safari, Mail or some other Apple application for the correct behavior.
Comment 1 retired 2014-05-10 15:13:54 UTC
Confirmed:4.2.4.2:OSX

Switch to e.g. https://addons.mozilla.org/de/firefox/addon/libreoffice-40-osx/ under LO > Preferences > Personalization to better view the top white bar which should not be there.
Comment 2 Tor Lillqvist 2014-05-12 06:47:10 UTC
I think we should just remove the current hack to "support" full-screen mode from the code. As I tried to say many times in that other bug report about it, it is a somewhat barebones hack and not at all well thought out and/or tested, and the interaction with LO's own full-screen concept is unclear. Anyway, if it doesn't work, don't try to use it.

@Foss: What does Firefox have to do with this? I don't use Firefox on OS X.
Comment 3 oscar valenzuela 2014-10-26 19:14:14 UTC
Confirmed in LibreOffice (Dev) 4.4.0 alpha1 under Mac OS X 10.10 (Yosemite) x86-64
Comment 4 Adolfo Jayme 2015-08-06 20:16:26 UTC
*** Bug 91086 has been marked as a duplicate of this bug. ***
Comment 5 Bookman900 2015-11-13 10:57:44 UTC
Hi guys!

This bug still exists in LO in further releases. Even in 4.4.6.3

It is strongly necessary to kill or something like that.
Comment 6 steve -_- 2015-11-13 11:02:55 UTC
OS X 10.11.1
LO Version: 5.1.0.0.alpha1+
Build ID: 4d9f4af05f78e8c5126e011e89a172026021691a
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-11-06_10:37:14
Locale: de-DE (de.UTF-8)

Can't reproduce.
Comment 7 Bookman900 2015-11-13 11:20:19 UTC
The problem seems to be specific for users under 10.10

10.8.5 reproduces this bug everywhere, even today's latest dev-version.
Comment 8 Robinson Tryon (qubit) 2015-11-19 00:43:35 UTC Comment hidden (obsolete)
Comment 9 ace_dent 2016-05-10 11:50:40 UTC
Tested with: Mac OS X El Capitan 10.11.4 (15E2066) with LibreOffice Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default.

It seems using the native OSX full-screen behaviour (which now puts the zoomed in window in it's own space), is broken. The central issue is how LO handles Spaces on OSX.

Workaround: Double click on the window's title bar to maximise the window (like 'full screen' in earlier OSX versions).

Related, possibly duplicated, issues ~ 
Missing menu bar: #53282, #76476, #96134, #97402, #97709.
Extra blank screen: (black- was grey) #72490, #83378, #96134.
General: #85259, #95362.
Comment 10 Tor Lillqvist 2016-05-10 11:57:09 UTC
See comment #2. I don't think I have had any reason to change my opinion.
Comment 11 Alex Thurgood 2016-09-06 17:03:40 UTC
*** Bug 101937 has been marked as a duplicate of this bug. ***
Comment 12 Adriano Borgobello 2016-09-06 17:23:33 UTC Comment hidden (abusive)
Comment 13 Tor Lillqvist 2016-11-15 09:11:12 UTC Comment hidden (abusive)
Comment 14 Adriano Borgobello 2016-11-15 10:04:49 UTC Comment hidden (off-topic)
Comment 15 QA Administrators 2017-11-16 09:22:22 UTC Comment hidden (obsolete)
Comment 16 Adriano Borgobello 2017-11-16 10:51:11 UTC
This bug still exists in LO 5.4.3002 on macOS 10.11.6, even it's behavior is a little changed. The menubar now appears replaced from a black bar instead from a withe bar, but document didn't use entry screen like before. The correct behavior for OS X (now macOS) fullscreen mode, is that the content of document windows covers entry screen, even the menubar. There will be 20-30 pixel more space in height, nothing really indispensable... but the bug is still there.
And I noticed another strange behavior related to macOS fullscreen mode (don't know if it need to open another bug report): in fullscreen mode, if I close the opened document, LibreOffice hold in fullscreen mode with a blackscreen, and the only thing I can do, is to open a new document to exit fullscreen mode, or quit LibreOffice. The correct behavior is that LibreOffice exits from fullscreen mode if the fullscreen document will be closed.
Comment 17 Tor Lillqvist 2017-11-16 10:55:33 UTC
Please note that there are two different "full-screen" modes: The traditional cross-platform LibreOffice one (View > Full Screen), and the system one (the green roundel in the left end of the title bar of a window. See comment #2. I have no reason to change my opinion.

When commenting here, please make sure which full-screen mode you are talking about.
Comment 18 Tor Lillqvist 2017-11-16 10:57:04 UTC
If I simply remove the broken "support" for system full-screen mode, will people scream?
Comment 19 Adriano Borgobello 2017-11-16 11:30:31 UTC
(In reply to Tor Lillqvist from comment #17)
> Please note that there are two different "full-screen" modes: The
> traditional cross-platform LibreOffice one (View > Full Screen),
In the latest versions of LibreOffice, it was replaced from system one. LibreOffice "full-screen" mode is still available by doble clicking on the document title bar or option-clicking "the green roundel in the left...". So, as you can see, I'm aware form what I'm talking. But this is not the point.
I'm aware that's not a stopping issue too, but behavior is still there and not OS coherent.
And one more thing: I think that the lake of full-screen exit (systems one) after document closure, is a noisier bug than the wrong document resizing.

> If I simply remove the broken "support" for system full-screen mode, will
> people scream?
I think none will scream, but it's not a serious way to respond to people that spend their time to give a contribution to make LO better (in this case only for OS coherence). Independently how little the contribution are.
Comment 20 Tor Lillqvist 2017-11-16 13:40:18 UTC
Congratulations, you have managed to confuse the issue with a third kind of "full-screen mode".

The two modes I was talking about was LO's own one, View > Enter Full Screen, and the system one (click on the green roundel without Option).

Double-clicking the title bar is a third thing... it would be called "Maximising", not "full-screen", I think. (And apparently Option-clicking the green roundel does the same as double-clicking.)
Comment 21 Tor Lillqvist 2017-11-16 13:49:37 UTC
Er, just View > Full Screen, not "Enter Full Screen", sorry.
Comment 22 Adriano Borgobello 2017-11-16 15:00:30 UTC
Created attachment 137811 [details]
macOS split view with LibreOffice (left) and NeoOffice (right)
Comment 23 Adriano Borgobello 2017-11-16 15:01:03 UTC
> The two modes I was talking about was LO's own one, View > Enter Full
> Screen, and the system one (click on the green roundel without Option).
OK, you are true. Now the two things have different behavior... today morning I tried LO Full Screen and get OS fullscreen mode. Can't explain how it's possible, and can't repeat the behavior again... maybe I'm wrong, but I don't believe so.
In any case, the macOS fullscreen mode, enables another mode called split view, that works with LO (with the same little bug from holding an unused space in place from menubar), so it's not a useless duplicate from LO fullscreen.
I attach a side-by-side screenshot from a split view mode with LibreOffice on the left and NeoOffice on the right.
Comment 24 eisa01 2018-04-02 11:56:18 UTC
Still present (now black bar) and this was also the case in OOo

Version: 6.1.0.0.alpha0+
Build ID: a488c7ad2763b944713997911c1ddb0315d8c93f
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-03-26_00:38:29
Locale: en-US (en_US.UTF-8); Calc: group
Comment 25 Tor Lillqvist 2018-04-02 11:58:40 UTC
Well, why wouldn't it still be present? Do you see any comment claiming any fix would have been committed?
Comment 26 eisa01 2018-04-02 12:14:54 UTC
(In reply to Tor Lillqvist from comment #25)
> Well, why wouldn't it still be present? Do you see any comment claiming any
> fix would have been committed?

Nope, just doing some QA work on mac bugs trying to clean up the bug tracker of duplicates, so thought I'd just update the status on this so other's don't need to test
Comment 27 eisa01 2018-04-02 12:17:36 UTC
*** Bug 97402 has been marked as a duplicate of this bug. ***
Comment 28 Tor Lillqvist 2018-04-02 12:29:54 UTC
Ah ok, good! Sorry for over-reacting.
Comment 29 Mazen Mardini 2018-05-12 14:20:37 UTC
That's strange, admin do you know where my comments went? I wrote a couple years ago and also started this issue, and no sign of my comments anywhere.
Comment 30 Mazen Mardini 2018-05-12 14:25:08 UTC
Nvm found it, it was in 97402.
Comment 31 Tor Lillqvist 2018-05-24 11:42:30 UTC
Suggested fix in https://gerrit.libreoffice.org/#/c/54760/ . 

The fix still leaves some minor ugliness in the full-screen support. But the resources (time) available to work on this crack are limited. The alternative would be to simply not participate in the system full-screen mode at all, https://gerrit.libreoffice.org/#/c/48796/ . So don't tempt me.
Comment 32 Tor Lillqvist 2018-06-01 11:56:34 UTC
Should be fixed now when LibreOffice doesn't participate in the system full-screen mode any longer.
Comment 33 Claude 2018-06-01 15:51:36 UTC Comment hidden (off-topic)