Download it now!
Bug 96134 - Black Menu Bar and Background After Inserting a Table When Maximized
Summary: Black Menu Bar and Background After Inserting a Table When Maximized
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Full-Screen-Mode
  Show dependency treegraph
 
Reported: 2015-11-29 14:09 UTC by arthur
Modified: 2018-04-02 12:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arthur 2015-11-29 14:09:26 UTC
If I maximize LibreOffice and insert a table through the menu bar, the table window will open in a maximized state, and my menu bar will turn completely black. If I restore the LibreOffice window after inserting the table, the window will seemingly shift to another workspace with a totally black background.

I'm running on OS X El Capitan.
Comment 1 arthur 2015-11-29 14:13:40 UTC
This issue also applies to presentation documents (and maybe others?), but it's worse because you can't restore the window after inserting the table.

If I insert a table while the window is restored, it works fine.
Comment 2 Buovjaga 2015-11-30 08:20:51 UTC
What if you disable this and restart LibreOffice: Tools - Options - LibO - View - Use OpenGL for all rendering

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 3 Alex Thurgood 2015-11-30 08:30:12 UTC
Confirming on

Version: 5.1.0.0.alpha1+
Build ID: 0721765417f787c8f4b1382b5d9100fa3a2a61ad
Threads 2; Ver: -; Render: default; 

Locale : fr-FR (fr.UTF-8)

OSX 10.11.1

OpenGL is off by default on OSX. The problem is more than likely linked to LO's incorrect and incomplete full screen management - there are currently sveral other dialog bugs which show the same behaviour (although the shift to a new workspace is yet another additional quirk) when in fullscreen mode.
Comment 4 ace_dent 2016-05-10 11:47:13 UTC
Tested with: Mac OS X El Capitan 10.11.4 (15E2066) with LibreOffice Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default.

It seems using the native OSX full-screen behaviour (which now puts the zoomed in window in it's own space), is broken. The central issue is how LO handles Spaces on OSX.

Workaround: Double click on the window's title bar to maximise the window (like 'full screen' in earlier OSX versions).

Related, possibly duplicated, issues ~ 
Missing menu bar: #53282, #76476, #96134, #97402, #97709.
Extra blank screen: (black- was grey) #72490, #83378, #96134.
General: #85259, #95362.
Comment 5 QA Administrators 2017-11-15 09:15:24 UTC Comment hidden (obsolete)
Comment 6 eisa01 2018-04-02 12:02:10 UTC
This works for me now in the native full screen mode, no trouble inserting a table using the menu

Version: 6.1.0.0.alpha0+
Build ID: a488c7ad2763b944713997911c1ddb0315d8c93f
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-03-26_00:38:29
Locale: en-US (en_US.UTF-8); Calc: group