Bug 117910 - The eyes of the smiley aren't rendered correctly in presentation mode with Skia (or OpenGL)
Summary: The eyes of the smiley aren't rendered correctly in presentation mode with Sk...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2018-05-30 18:19 UTC by Telesto
Modified: 2020-08-28 12:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-30 18:19:00 UTC
Description:
The eyes of the smiley aren't rendered correctly in presentation mode

Steps to Reproduce:
1. Open attachment 142298 [details]
2. Start presentation mode (F5) in OpenGL mode -> 
3. Eyes aren't rendered correctly -> screenshot: attachment 142299 [details]

Actual Results:  
Rendering issues with the eyes

Expected Results:
Shouldn't happen


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 938ec2597be2e0ad3af2fb99f77de7f87285ad86
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-25_23:38:38
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2018-05-30 18:19:38 UTC
Conformation: bug 117826 comment 3
Comment 2 Telesto 2018-05-30 18:20:30 UTC
Bisected to
author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-02-23 16:57:41 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-17 23:15:49 +0100
commit d1027af3c74529827d53e8cf7b0d42a0ee47d1ba (patch)
tree 488efdfb60e5e9bd01af54679872a8b91b0e14c4
parent 9886a69c472f212d88f11cfa0f3835e5dcf485b2 (diff)
OperationSmiley: Added support for using same FillGeometry
It is now possible to use a single FillGeometry to fill objects that
are made of multiple filled objects (e.g. CustomShapes) so that
they look as using a single fill. This is used for CustomShapes,
but may later be 'extended' to be used for more cases. The basic
functionality was already in the primitives, but had to be added
to SDrObject due to these being used for CustomShapeVisualization
(currently - would be better to change this to primitives, too).

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d1027af3c74529827d53e8cf7b0d42a0ee47d1ba
Comment 3 Telesto 2018-05-30 18:21:05 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2018-06-05 19:08:09 UTC
Adding Cc: to Armin Le Grand
Comment 5 Armin Le Grand 2018-06-13 08:18:36 UTC
@Xisco: Sorry, have nothing to do with OpenGL rendering, but adding a generic primitive renderer for OpenGL instead of 'bridging' VCL would help in my opinion - just my 2ct.
Comment 6 Xisco Faulí 2019-05-02 08:53:57 UTC
Hi Miklos, I thought you might be interested in this issue...
Comment 7 Xisco Faulí 2019-07-06 13:03:58 UTC
The problem with the eyes is fixed with my patch for bug 126184 <
https://gerrit.libreoffice.org/#/c/75143/ >
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 126184 ***
Comment 8 Regina Henschel 2019-07-08 19:15:59 UTC
Bug 126184 has a different root cause. But likely the same problem as described in bug 117826.