Bug Hunting Session
Bug 118121 - TABLE: Border between merged cells reappears after open
Summary: TABLE: Border between merged cells reappears after open
Status: RESOLVED DUPLICATE of bug 117884
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Tables Table-Borders
  Show dependency treegraph
 
Reported: 2018-06-12 00:23 UTC by Phil Krylov
Modified: 2018-06-12 11:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document with merged cells (17.23 KB, application/vnd.oasis.opendocument.text)
2018-06-12 00:26 UTC, Phil Krylov
Details
Screenshot from LO 6.0.4 (good) (25.38 KB, image/png)
2018-06-12 00:28 UTC, Phil Krylov
Details
Screenshot from LO 6.1.0b1 (buggy) (24.58 KB, image/png)
2018-06-12 00:29 UTC, Phil Krylov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Krylov 2018-06-12 00:23:54 UTC
Description:
In a table with vertically merged cells, a border appears between these cells although text flows freely through that border. The document looks good when opened in 6.0.3 or 6.0.4, however, 6.1.0b1 has the bug, which also affects preview and PDF output.

Steps to Reproduce:
1. Open the document.
2. Look at the last two columns of the first row

Actual Results:  
The merged cells are crossed with a border that can't be removed.

Expected Results:
There should be no border between the merged cells.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
Comment 1 Phil Krylov 2018-06-12 00:26:18 UTC
Created attachment 142668 [details]
Test document with merged cells
Comment 2 Phil Krylov 2018-06-12 00:28:38 UTC
Created attachment 142669 [details]
Screenshot from LO 6.0.4 (good)
Comment 3 Phil Krylov 2018-06-12 00:29:22 UTC
Created attachment 142670 [details]
Screenshot from LO 6.1.0b1 (buggy)
Comment 4 Xisco Faulí 2018-06-12 08:08:04 UTC
Hello Phil,
Thanks for reporting the issue.
This has been fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=1e21902106cbe57658bed03ed24d4d0863685cfd.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 117884 ***
Comment 5 Phil Krylov 2018-06-12 11:47:40 UTC
Thank you! I tried searching the Bugzilla first but could not find anything. Confirming that the issue does not appear in master build.