Bug Hunting Session
Bug 117884 - Tables in 6.2 Rendered Incorrectly
Summary: Tables in 6.2 Rendered Incorrectly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords: bibisected, bisected, regression
: 118121 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-29 17:15 UTC by Luke
Modified: 2018-06-12 15:00 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example table to show the problem (15.27 KB, application/vnd.oasis.opendocument.text)
2018-05-29 17:15 UTC, Luke
Details
Before and After comparison (170.99 KB, image/png)
2018-05-29 17:16 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2018-05-29 17:15:00 UTC
Created attachment 142386 [details]
Example table to show the problem

In recent builds of 6.2 Tables have multiple rendering issues. 

Steps to reproduce:
1. In 6.1 or earlier open TableBug.odt
2. In 6.2 open TableBug.odt
3. Compare

Converting to .doc,.docx, or .rtf does not help the issue. Verified in both Linux and Windows.

Version: 6.1.0.0.alpha1+ Build ID: 8d42de21c10bfefeaffabc5c939e7830a09f7dca
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-24_03:29:54
GOOD

Version: 6.2.0.0.alpha0+ Build ID: 938ec2597be2e0ad3af2fb99f77de7f87285ad86
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-25_23:38:38
BAD
Comment 1 Luke 2018-05-29 17:16:01 UTC
Created attachment 142387 [details]
Before and After comparison
Comment 2 Aron Budea 2018-05-29 18:23:10 UTC
Confirmed and bibisected using repo bibisect-linux-64-6.1. Adding Cc: to Mark Hung, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e87cc12eaf53efa9b221eae7167ea15bc7896752
author		Mark Hung <marklh9@gmail.com>	2018-05-23 11:25:05 +0800
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-05-24 17:30:47 +0200

tdf#106390 Intersect the table borders with upper frames.
Comment 3 Buovjaga 2018-05-31 10:58:44 UTC
Was just going to file a report, but found the commit after bisecting :)

My case would have been:
1. Insert a 2 x 3 table (anything with more than 2 rows is fine)
2. Merge the first two cells in the first column
Comment 4 Commit Notification 2018-05-31 14:03:21 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e21902106cbe57658bed03ed24d4d0863685cfd

tdf#117884: intersect border with paint area of upper frame.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Buovjaga 2018-05-31 16:07:07 UTC
The commit fixes both cases.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 2b7690d5a1a2c3064b47bd2648ba2452bf4726af
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on May 31st 2018
Comment 6 Xisco Faulí 2018-06-12 08:08:04 UTC
*** Bug 118121 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2018-06-12 15:00:08 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5f42787232a5a2ece35d4c018df8a9b7c856919f&h=libreoffice-6-1

tdf#117884: intersect border with paint area of upper frame.

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.