Bug Hunting Session
Bug 106390 - Table borders go over footer and page boundary
Summary: Table borders go over footer and page boundary
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:6.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Table-Borders
  Show dependency treegraph
 
Reported: 2017-03-07 15:55 UTC by Mark Hung
Modified: 2019-03-12 06:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample test case (21.78 KB, application/vnd.oasis.opendocument.text)
2017-03-07 15:55 UTC, Mark Hung
Details
Illustration about the issue. (225.29 KB, image/png)
2017-03-07 22:54 UTC, Mark Hung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2017-03-07 15:55:37 UTC
Created attachment 131703 [details]
Sample test case

Steps to reproduce:
1. Create new document and insert a new (1x2) table.
2. Enter content so that the cell in the second row goes across the border.
3. Uncheck "Allow row breaks across pages and columns" and "Allow table split across pages and columns".

The sample is attached. 

Expected result:
The contents inside the table and the table border will be cut before footer.

Actual result:
The border go across the border, even the area of the page. It looks somewhat broken.


版本:5.3.0.3
組建 ID:7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU 執行緒:8; OS 版本:Windows 6.2; UI 算繪:預設; 介面配置引擎:新式; 
語言地區:zh-TW (zh_TW); Calc: single
Comment 1 Xisco Faulí 2017-03-07 16:19:15 UTC
it seems like a duplicate of bug 106384, and I recall the same problem reported previously but I can't find it...

*** This bug has been marked as a duplicate of bug 106384 ***
Comment 2 Mark Hung 2017-03-07 22:54:21 UTC
Created attachment 131736 [details]
Illustration about the issue.


Unlike tdf#106384, neither "Allow table split across pages and columns" and "Allow row break across pages and columns" are checked, so data hidden is expected. But border extrusion isn't.
Comment 3 Aron Budea 2017-03-16 04:56:55 UTC Comment hidden (bibisection)
Comment 4 Aron Budea 2017-03-16 04:57:40 UTC
Bisect points to the commit referenced below.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1c6fb266567c8e397e3c65663b21f0fa50696aa5
bde03e88148690ca7d28f65877cd0830d4991629 is the first bad commit
commit bde03e88148690ca7d28f65877cd0830d4991629
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Thu May 28 20:09:10 2015 +0800

    source-hash-1c6fb266567c8e397e3c65663b21f0fa50696aa5
    
    commit 1c6fb266567c8e397e3c65663b21f0fa50696aa5
    Author:     Kohei Yoshida <kohei.yoshida@collabora.com>
    AuthorDate: Mon Mar 17 19:11:35 2014 -0400
    Commit:     Kohei Yoshida <kohei.yoshida@collabora.com>
    CommitDate: Mon Mar 17 19:43:05 2014 -0400
    
        fdo#75260: These old hacks no longer make sense.
    
        The clip region in fact cuts off the lower part of the bottom border, both
        on screen and when printing / exporting to PDF.
    
        Change-Id: Id350531f09b3ded66fd05ea7ebeefe8771260b62
Comment 5 Commit Notification 2017-04-07 10:33:07 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b13a0a27444ffbf9ef45cb16ad69fdff0dc64306

tdf#106390 improve table in table and table in frame clipping.

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Luke 2017-04-09 01:30:38 UTC
Mark,
https://cgit.freedesktop.org/libreoffice/core/commit/?id=b13a0a27444ffbf9ef45cb16ad69fdff0dc64306

breaks tables that have split and merged cells. For example, the merged cell in attachment 114436 [details] is not rendered correctly after your patch. 

Should I file a new report or do you want to track that here?
Comment 7 Mark Hung 2017-04-09 02:47:19 UTC
Hi Luke,

There is still another part of the patch on the way under review. I suggest to create another issue ( in case the test case is different. ).
Comment 8 Commit Notification 2018-05-24 15:31:45 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e87cc12eaf53efa9b221eae7167ea15bc7896752

tdf#106390 Intersect the table borders with upper frames.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Luke 2018-05-30 14:40:39 UTC
https://cgit.freedesktop.org/libreoffice/core/commit/?id=e87cc12e is causing a regression with how tables are rendered. Reported as Bug 117884
Comment 10 Xisco Faulí 2018-07-02 22:33:36 UTC
A polite ping to Mark Hung:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 11 Xisco Faulí 2018-09-12 12:15:46 UTC
(In reply to Xisco Faulí from comment #10)
> A polite ping to Mark Hung:
> Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
> Otherwise, Could you please explain what's missing?
> Thanks

Ping ?
Comment 12 Mark Hung 2019-03-12 06:58:11 UTC
I forgot when does this fixed, but it works for me in 6.2.0.